Problem getting signal from new graphics card

By Pgoetz ยท 6 replies
Mar 24, 2012
Post New Reply
  1. So, earlier last week I picked up a new 450w power supply, and a new graphics card.

    My old setup had a 350w PSU and an integrated geforce piece of garbage

    The new stuff is: Thermaltake TR2 W0070RUC 430W ATX12V V2.2 Intel Core i7 Compliant Dual 80mm Fans Full Cable Sleevings Power Supply

    EVGA 01G-P3-1556-KR GeForce GTX 550 Ti (Fermi) FPB 1GB 192-bit GDDR5 PCI Express 2.0 x16 HDCP Ready SLI Support Video Card

    Basically what happened, is I was a little over zealous when I was putting in the supply and the card, I tossed them both in at the same time, without uninstalling the old integrated graphics drivers, or going in and changing settings in the control panel.

    When I powered on, the power supply worked fine, I didn't have a long enough SATA cable to reach the disk drive so I just plugged in the hard drive and figuered if it worked I could run out and get an extension cable. No noise from the MOBO, no beeps, nothing that sounded like I forgot to plug anything in, however the new card failed to initialize the moniter, "No Signal Found" kept popping up.

    I realized that I haden't set the new card up to display and powered everything back down, plugged the VGA cable back into the integrated card, and the same display message popped up on the moniter. "No Signal Found"

    I tried various versions of plugs, including using an AVI adapter for the VGA cord, taking the new PSU out and putting the old one back in, trying the old PSU with the new card, running the card without the extra 6 pin power adapter required by the card, and running all of these configurations with another moniter, and my TV.

    Nothing - Now what I think is going on, (because the computer was running fine before any changes) is that for some reason, the plug and play changed the display settings to the new PCIE setup that the new card is, without being configured, thus disabling the integrated card that came with the machine, in effect the old setup doesn't work, and neither does the new one.

    a friend of mine reccomended trying to reset the CMOS.

    Any suggestions?
  2. magaman598

    magaman598 TS Booster Posts: 188

    The +12V rail on that PSU is only 18 Amps, you need a bigger amperage on it to run that graphics card. That's just my 2-cents. ;D
  3. Zen

    Zen TechSpot Paladin Posts: 861   +50

    In regards to the possible power supply issues, I took the liberty in doing a little research......hope this helps!


    Good luck..... :)
  4. Pgoetz

    Pgoetz TS Rookie Topic Starter

    Well the new psu has 430. And I understand that I overlooked the amperes. But the old configuration doesn't work either. Integrated graphics with the old or new psu.
  5. Pgoetz

    Pgoetz TS Rookie Topic Starter

    I'm more interested in getting the display back than worrying about the new card.
  6. Zen

    Zen TechSpot Paladin Posts: 861   +50

    I'm just a little curious about something here! Is your problem only limited to when the computer boots into Windows, is it shortly after the boot up that the monitor cuts off? Also a friend recommended for you to reset your BIOS, can you even get into BIOS and see it through the monitor? Sometimes a lot can be told when it comes to which point a monitor decides to stop working. If it's a software problem, you'll be able to get into BIOS when the computer first come on, for Windows hasn't taken over the computer at that point, it's strictly being controlled by BIOS. But if you can't get into the BIOS screen, and the monitor doesn't even kick on, even after pushing the computers "on button" than this is a hardware problem. If this is a hardware problem, the problem might not be with the new video card, seeing that now your old video adapter off the motherboard and new video card share the same "non working" problem, I suspect if it is hardware, your motherboard somehow took a dump!
  7. Pgoetz

    Pgoetz TS Rookie Topic Starter

    Thanks I appreciate the detailed insight. The monitor fails to initialize during power up. It never seems to grab signal. I'll try to reset the CMOS with the old setup. I hope the mobo hasn't crapped the bed off some freak accident.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...