Problem with MicroAdvantage USB QuickiDrive

By jacobb13
Apr 27, 2005
  1. I am having a problem accessing my Micro Advantage 1 GB USB QuickiDrive. It makes funny beeps when i plug it into my USB drive and when i examine its properties it comes up and 0 bytes used space and 0 bytes free space. It won't format (it gives me an insert disk error???) I tried the HP USB Disk Storage Format Tool to see if that would work and it didn't. QuickiDriveTools1.3 from microadvantage won't install because it doesn't recognize the drive. It tells me to unplug and reconnect, which i tried and nothing happened. the software also refuses to install without recognizing the device. Can anyone offer any help or is this thing just fragged.
  2. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    could be you accidently low level formatted the flash drive. I did that and toasted one of my drives.


    you statically wiped out the chip

    ALWAYS stop the device before removing it from the USB port.

    I've toasted flash drives before. Also, they're not that reliable.
  3. patio

    patio TS Guru Posts: 482

    That software will install without the drive so give this a try. Do a clean boot without the drive plugged in and install the software; when it gets to the end and asks to plug in the drive just cancel out and close all running apps and shut down the system. With everything off plug in the USB drive ( use a rear port for this first attempt)and power up...
    XP will pick up the device and the Quickidrive program should launch. Use it to format the drive, power down and re-start.
    Then rite clik My Computer and choose Manage...under disk management it should now see the drive and it's full capacity.
    Let us know how it goes.

    patio. :cool:
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...