Problem with star wars knights of the old republic 2

By usetheforce7 · 75 replies
Feb 13, 2005
  1. AtK SpAdE

    AtK SpAdE TechSpot Chancellor Posts: 1,495


    I am most pleased to hear the news!!

    It is not only ATI cards, b/c i have tried a 5600 and it still continued. All i can do is wait for a patch!

  2. Latoa

    Latoa TS Rookie Posts: 20

    Ok I may have a possible fix, I have spoken to 3 people and all of them have said that their game now runs alot better, the fix is for people who have ATI Radeon Mobility cards, Omega drivers have a rather nice 4.11 catalyst driver that seems to do the trick, link is i cannot say for sure what radeon cards it will work for, but I have been told that desktop users who have problems can also use the driver. (my friends have radeon mobility 9000). Not the patch I know but I hope that this helps someone until the patch is finally released.

    I will test this myself this weekend when I get home and let you know if it works or not.
  3. husypb

    husypb TS Rookie Posts: 22

    aaargh... :dead:
    "the page cannot be displayed"
    but thx anyway
  4. husypb

    husypb TS Rookie Posts: 22

  5. husypb

    husypb TS Rookie Posts: 22

    i tried out the 4.11 catalyst, but it didnt worked, ohh i cant wait for the patch...
  6. Latoa

    Latoa TS Rookie Posts: 20

    was it omega driver or one of ATI's older versions? and whats your specs I'll ask the guys tomorrow but you know I have to endure talk of star trek for an hour before i get any kinda response lol, give let me know your specs and leave the rest to me as for the patch still not heard anything
  7. husypb

    husypb TS Rookie Posts: 22

    hm, i think it was an older ati driver, i couldnt find this omega driver.
    But i'll searxh for one, and try it out.
    my specs:
    AMD Athlon 2400+
    512 RAM
    Ati Radeon 9550 256MB
    mouse+keyboard :D
    im using the ati 4.11 driver right now, but i have the 5.1 too
    thx in forward...
  8. husypb

    husypb TS Rookie Posts: 22

    I'll rty out the 4.11 beta, and the 4.12 omega driver and i'll post you the result
  9. antron

    antron TS Rookie

    same here

    Yea, I am using Windows 2000 on an Athlon XP 1800+ with an ATI Radeon 7200 (so what, I'm poor) and I get a crash too right when the game starts playing on its own engine (right after the beginning cut scene with the asteroid field).. Memory could not be read at 0x00000000 it says.

    Based on what I've seen here I presume that it's another ATI problem. what the hell. Did these guys not test the game before they shipped it?

    That's all.. I'm just confirming it might be an ATI issue. I'll be checking the update patcher program daily till it comes out!

  10. Latoa

    Latoa TS Rookie Posts: 20

    Well you can't really blame LA for ATI's drivers, tested Omega's 4.11 beta and game works fine, I am sure ATI will have a few emails to read up on. But what your saying about memory is rather odd not seen that error reported (yet) but sit tight patch shouldn't be much longer
  11. arkangel

    arkangel TS Rookie

    I too am having the problem and am currently downloading the latest ati catalyst drivers to se eif that fixes it. But I'm curious about the tech requirements for the game. I have a:
    Mobile AMD Athlon(tm) 64 2800+
    Mobile ATI Radeon 9700 w/ 128 RAM
    plenty of HD space.

    Now I've had this laptop for about 6 months and it has run alot fo other high end games rather well. I ran Far Cry, Doom 3, Half Life 2, and Prince of Persia: Warrior Within really well. But with this game and Prince of Persia, it saidm y processor is inadequate, but PoP still ran without problems. Why is this?

    Oh and I have windows XP w/ sp2
  12. Latoa

    Latoa TS Rookie Posts: 20

    lol ok first off, what you need are Omega's drivers and not ATI's now on the left will be a floating menu, select archieves then look for the catalyst 4.11 beta drivers those are what you need, now before you install them you will need to uninstall all current graphics card drivers and ATI's control panel, good tool for that would be driver cleaner not sure where you would get that from to be honest, but then reboot then install the omega 4.11 beta drivers and it will work, i have tested it and all is fine with mine (Radeon mobility 9000) even running it at 32mb still works.

    Now why won't the new ATI drivers work, simple they are untested and useless never expect anything good from ATI I am already looking at getting a laptop with nvidia built in.

    But if your unsure or stuck email me on my aol email address and I will get back to you asap
  13. Latoa

    Latoa TS Rookie Posts: 20

    Well they must of took it to NASA and let them beta test it on those uber machines there and forgot to test it on us poor mortals with our less powerful machines... but the patch will (from what i heard so please don't use me as a scape goat) sort alot of graphical issues out along with gameplay, 2 many bugs to post here but check out LA's tech forum for info. I will update here when the patch finally is released
  14. nullboy

    nullboy TS Rookie

    OKies... while I am new here, I am an old hand with Windows. I also know a bit about the Windows XP (2000, NT) architecture. I also know that computers are supposed to be predictable (if you do the same thing they respond the same way (given the same starting point).

    None of these however explains why I was able to play KOTOR just fine until I managed to complete it for the first time, after which I uninstalled it to make room for other stuff. I decided to get a hold of KOTOR II and that's when the problems started...

    Now, having installed KOTOR II, not only is it producing the above problem (see below for the exact error message) but also reinstalling KOTOR I produces the exact same error.

    I did update DirectX to 9.0c from the KOTOR II disc. Is it possible this version of DX could have a problem with my ATI card (9200SE IIRC)? I've updated to the latest driver set with no change.

    Can I back out of DX 9.0c and replace it with 9.0b? As I understand it DX installs with version checking which would mean an earlier version of a library would be unable to overwrite a newer one...

    And one more leetle point I have noticed... Windows XP contains a compatibility feature where you can pretend to a particular executable that a particular version of Windows is running. KOTOR I and II will both *start* if I set this (Properties|Compatibility tab) to Windows 95 or Windows 98/ME. It fails predictably for Windows NT4 but also more surprisingly for Windows 2000. Of course this isn't a full solution as with one of the 9x's selected the sound is charitably described as "choppy" and the game crashes with the original error after character creation...

    Ho hum. This one has me at my wits end... I feel that it has to be graphics oriented but I seem to have run out of things to mess with.

    For reference, my KOTOR I has been updated to version 1.03 with no change either.

    The error message that I am getting is the following:

    The instruction at "0x0000000" referenced memory at "0x0000000". The memory could not be "read".

    Of course this is the standard Windows "someone tried to jump to address 0" error - probably the most common way of getting an access violation. Interestingly, this is a "user mode" message whereas the graphics driver runs in kernel mode so it's not _directly_ a problem with the graphics drivers...

    Dunno if this will help anyone else move it on another step...


  15. Latoa

    Latoa TS Rookie Posts: 20

    the more people talk about the graphics problems the more it makes me think DX 9.0c is the culprit, but what just does not make sense is that an old catalyst driver works with the game more than the most recent one, I have tried the compatability setting for the game and all it did was take me back to my desktop but all version 98 and upwards are compatable. I have tested the game on the following system with the omega 4.11 beta drivers and it now works

    Windows XP Home (SP1)
    P4 3.08ghz (although system says 2.8ghz but who's counting)
    512mb DDR
    Radeon mobility 9000 (currently running 64mb)
    Omega 4.11 beta graphics driver
    Bog standard sound card (Realtek lol)
    DirectX 9.0c

    I get a little bit of system lag when moving in large areas but its a vast imporvement from not moving at all from the med bay at the very start. oh just so you know I mailed the lovely people at Lucas and Lackofvision and both told me to update my drivers although I told them the updated drivers do not work £29.99 to some company that must use bots that use random reply scripts phoning them did not help much, the guy on the phone said he selects the problem from the list and tells the person what to do... I could of done that via the net and not spent a fortune on the call but at least it keeps them off the dole. Anyway to cut a long story short all I can say is, if Omega does not work for you just sit back and wait for the patch oh and don't touch Republic Commando due here in the UK soon but out in the states and already alot of bugs reported, seems Mr Lucas has switched to the dark side of the force (that and episode 3 is out soon so they are putting all hands to the pump for the game)
  16. dopefisher

    dopefisher TS Rookie Posts: 444

    i have bfg geforce fx 5200 and Star Wars KOTR2 works PERFECT in 800 x 600. thats all.
  17. hotdog

    hotdog TS Rookie

    I have installed the new patch (I had to do it manually). It patched the game to 1.0a. Guess what? It still doesn't work!!!!!!!!!! I guess I will just have to wait it out for a patch that does work.
  18. Latoa

    Latoa TS Rookie Posts: 20

    Thats a patch to fix a language problem, they are still working on the bug fix patch
  19. antron

    antron TS Rookie

    exactly nullboy
  20. husypb

    husypb TS Rookie Posts: 22

    hi im back, and with bad news...
    i tried out this 4.11 beta driver and it didnt work!! arrrgh...
    my patience is running out, i tried the game with an old ati driver(this is what i have got to my card), it crashes, then with te 5.1 driver, it crashes, then i tried the omega 4.1, 4.11beta, and the 4.12 but it also crashes... oh, and before i forget, i tried an older winxp with sp1...
    ...the game started smoothly i played with it for about 5-6 hours, then i went sleeping.What a beautiful evening i had, but then the next day was the horror: the game crashes the first time i start it.
    :dead: help, i need help and a patch!!!

    ps: the omega driver -i think- is only good for the mobility cards, so please send me money, because i want to buy a laptop
    thx guys
  21. Latoa

    Latoa TS Rookie Posts: 20

    ok Husy whats your system specs and what drivers are you currently using on the machine.
  22. husypb

    husypb TS Rookie Posts: 22

    hmm, let's see:
    AMD Athlon 2400+ (2.0~)
    512 MB RAM
    ATi Radeon 9550 256MB RAM -> omega dr 4.12
    the other parts are integrated (or sthg like that)
    DX 9.0c, win xp pro sp1 (because i thought that the game isnt working with the sp2)
    what do you think, are they testing the patch or is it just a rumor??

    ps: the game config is f*cking around with my vid card: it says that it need an "ati 9200 or better", and i have an ati 9550
    maybe it is nt supported... :(
  23. Latoa

    Latoa TS Rookie Posts: 20

    it does work with that machine and card, mine is not supported but i just completed it, and all i am gonna say is what a waste.....

    i will see if anyone i know has that sort of computer config and what they can suggest, as for the patch it is due out by the end of the week so not much more waiting
  24. nullboy

    nullboy TS Rookie


    Heh. I didn't know about the Omega drivers. They work fine - both KOTOR I and II are now working just fine with DX 9.0c and the other games I've tried seem to be speedier too (ofc that's just an opinion...).

    Nice one.


  25. CyberTarek

    CyberTarek TS Rookie

    A temporary solution...


    I have an ATI card too and I wallowed for three days trying to get this fixed and tried nearly everything. Finally, I found this interesting response on Lucas Arts' website that solved all my problems:

    I was about to resign to my fate and just forget about the game until Lucas Arts issues a patch, but this works for my ATI X300.

    I thought I would post this here because I read this forum when I was searching for an answer and your tips helped me a lot and I thiink you deserve to know that this works.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...