Problems installing .NET 2.0

By zpfield
Nov 10, 2008
  1. Hey guys, could someone help me please?
    I tried to download the Sky player software so I could watch something I'd missed.
    The installer then told me I had to download and install Microsoft .NET 2.0 Framework for the player to be installed. It downloaded the installation exe and ran it. It gets halfway through and I get this error :

    Error 25015. Failed to install assembly 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\mscorlib.dll' because of system error: The process cannot access the file because it is being used by another process.

    It then uninstalls everything it just did and quits. The sky player won't install without this. I then tried downloading the .NET 2.0 software directly from Microsoft and installing it, and get the same message. I tried to rename the file it mentions so that it wouldn't be used but this didn't work either.
    I then downloaded and tried to install the windows installer 3.0 from the website (apparently this would help install .NET). This then told me that the installer that I was trying to install was an earlier version than the one I already had and wouldn't install!
    How do I sort this out?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...