Problems running cfdisk on Knoppix in attempt to fix NTFS error

By Jason_Charity
Sep 29, 2007
  1. I have a problem related to Knoppix, in regards to my problems trying to solve a stop: 0x00000024 error on my PC. This is my first ever post on TechSpot, and I believe that this is the proper forum to post this on, as I think that Knoppix is related to Linux, correct? Normally I try to solve computer problems myself (despite the fact that I'm not really a technological genius or anything) but this thing is just too big for me and I'm throwing in the towel. I was impressed with some of the responses I saw in another thread on this site related to this particular stop error, so I figured I'd post my problem on here and see if that helped. Any assistance given to me I would be very grateful for.

    The problem began about two weeks ago. What would happen is that I would go onto the Internet and go about my business when suddenly the computer would just restart for no apparent reason, with no warning at all. When it would eventually start back up again, the same problem would happen again, just after the second restart, I would get a box that told me that Windows had recovered from a serious system error, and after that I would have no restarting problems for the rest of my computer session (until I turned the power off at least, which would restart the cycle). This went on for a few days and at first I thought it was a problem related to the Internet (because my computer seemed to always restart when I was online) but then I noticed it would also restart when I was offline. Last Thursday, a new problem manifested: sometimes the screen would just freeze up and there was nothing I could do to unfreeze it, other than turning the computer off manually by holding down the power switch (even CTRL+ALT+DeL did nothing). But it was last Friday, a week ago, that I hit a major snag. My computer would just not load up at all, unable to get past the initial blue HP intro screen or the Windows XP loading screen... the thing would just keep restarting! After restarting it would take me to a screen that gave me five options, such as start windows normally, start at last good configuration, and three safe mode options, none of which worked at all, just more restarts. Finally, I hit F8 on the first loading screen and disabled auto-restart. But when I tried to boot in any format, I got sent to a blue screen and saw that the culprit was the dreaded stop: 0x00000024, related to the NTFS.sys.

    Using one of my younger brother's computers, I began googling this problem, trying to find a solution, and I found a thread on this TechSpot site that seemed to give a lot of good advice. It seems that the two most often used tricks to beating this stop error is either using a Windows XP instillation disk or by using Knoppix. Problem is, I don't even have a Windows XP instillation disk, as when I purchased my computer it had already come installed with it. I DO have ten recovery CDs which I made the first day I set up the computer, and I tried using those to do a standard recovery (didn't want to do a full recovery as I didn't want to loose all my data) but that didn't work as I just kept getting the blue error screen. So I decided to go the Knoppix route, even though I don't know a single thing about Linux. The downloading instructions to get it online seemed obtuse, so I decided to just order a copy and wait for it to arrive in the mail.

    I got the Knoppix CD yesterday. I booted up with that, and after a few tries it loaded up fine (by it, I mean the Knoppix desktop). Next, I opened up Konsole, which is the Terminal program, started a new shell, and it gave me this: Knoppix@Knoppix:`$. So at the prompt I hit "su" and pressed enter, which opened some kind of a root, like this: root@knoppix:/ramdisk/home/Knoppix#. So I typed "cfdisk" and hit enter. Now, from what I gather, what it should do is show me all of my partitions, and I'm supposed to write down where the NTFS files are located, then exit cfdisk and run ntfsfix to fix the problem. Problem is, it wouldn't let me get onto cfdisk. After I hit enter, I got this message: "-opened disk read-only- you have no permission to write."

    So, I guess my main question right now would be, how can I get past this to get cfdisk to work? I feel like I've finally almost fixed this problem, and that I'm getting closer and closer to the last steps. I may have more questions on this matter as I go forward, but right now I just need to find a way to activate the cfdisk. Any information you can give me would be greatly appreciated.

    I purchased my computer about 2 1/2 years ago so it's not like it's an antique or anything. It's a HP Media Center PC, with a 530J Intel Pentium 4 Processor, 250 GB 7200RPM Serial ATA hard drive, ATI Radeon X300 SE PCI-E graphics card (whose driver I updated in August in a pathetic attempt to get "Bioshock" to work on my system... no dice there). I can't imagine what caused this stop error to appear in the first place. I have installed some computer games over the course of this month, but two of them have been on my system in the past with no problems so I don't know. I've also tried dusting my computer, and I should add that the fans appear to be working correctly and that the temperature seems to be stable (starts at around 45, usually peaks at 66-67 before the fans activate and take it back down to 56 degrees).

    Oh yeah, the Knoppix I'm using is Knoppix 5.1 1.1, released 2007-01-04. If you need anymore information to provide assistance, please let me know and I'll see if I can answer it.
  2. Jason_Charity

    Jason_Charity TS Rookie Topic Starter

    Never mind, I figured it out late yesterday. I managed to unmount the second sda, and run ntfsfix on sda2, which corrected the error. Computer seems to be working fine now (knock on wood).
  3. jobeard

    jobeard TS Ambassador Posts: 11,166   +986

    well done! good learning experience too :)
  4. Ron_knopf

    Ron_knopf TS Rookie

    Knoppix Helped ME!!!

    I read this post about fixing NTFS with Knoppix since I had tried everything I could think of I gave the Knoppix a shot and it worked! Thanks very much for posting !!!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...