Problems with SiS Video Card Drivers!

By rwnewson ยท 15 replies
Jul 13, 2003
  1. Hello guys...

    I have a problem with my video card and/or drivers.

    I had this same problem a few weeks ago but my computer was a big mess crashing all the time, so I upgraded from Windows ME to Windows XP. Now my computer runs great otherwise but here's my problem...

    I installed Age of Empires 2 (AOE) and Rise of Nations (RON) on XP fresh and initially AOE worked perfectly but RON claimed my video card drivers needed to be updated. So I went online and got this whole driver and utility package, latest version 2003. My video card is an SiS integrated chipset 630/730. Now after the big upgrade, neither AOE or RON works!!

    AOE says "Could not initialize graphics system. Make sure video card and drivers are compatable with DirectDraw."
    RON says "Graphics services failed to initialize. Please make sure video card and drivers are correctly installed and compatible with Rise of Nations."

    Haven't noticed any other problems... Can anyone help me plleaase??? I dont get it. Thanks.
  2. XtR-X

    XtR-X TS Rookie Posts: 863

    You may have downloaded an incorrect set of drivers. I'm not too sure about integrated video cards on motherboards, but maybe that's not the way it is to be done.

    I'm just taking a shot in the dark here.... but maybe you've got to flash it.
  3. rwnewson

    rwnewson TS Rookie Topic Starter Posts: 44

    Hello. Thanks for the help.

    I'm sure these are the right drivers... I went to SiS website and downloaded integrated chipset 630 WinXP driver and thats exactly what I have.

    Get this... I reinstalled DirectX 9a and typed dxdiag to open the diagnostics toolbox. There it said my DirectDraw and Acceleration options were ENABLED... and it had an option to test both of them. I performed the test and it passed with flying colours! DirectDraw and 3D accelerations all worked!! So then I click on AOE again and same problem... "make sure vid card and drivers are compatible with DirectDraw"...

    What the hell...
  4. cromrell

    cromrell TS Rookie Posts: 41

    I know I had to upgrade my video card in order to play Age of Mythology. It doesn't sound like that is your problem (based on the other games you are playing).

    You indicated you downloaded the drivers from the SIS site... have you tried to download the drivers from your MB manufacturer?

    What is your make/model of your MB? Have you looked at their site for known bugs with the integrated video? Maybe someone else is able to sucessfully run these games with your same board.

    I assume you have un-installed, and re-installed the games, taking care to manually DEL the entire directory after un-installing and rebooting your machine.

    You might also try a fresh install of your operating system (instead of upgrading from winME).

  5. Crybabytek

    Crybabytek TS Rookie Posts: 28

    My 'puter has the SIS V.C. I upgraded my Win98 to WinXP. It took some time and efforrt to upgrade SIS drivers but I finally figured it out,

    Control Panel
    Device Manager
    Display Adapter

    Choose....from location

    I picked Choose from....

    With my DSL turned on I let Windows's download the correct driver which it will do if assuming of course that you registered XP.

    Periodically I run Device Manager and update from Microsoft's own website as SIS is, mercifully, one of the mfg. who has registered their drivers with Microsoft.

    BTW I have Broderbund's Myst and a few other little goodies in that vein.

    My O/S is running Direct X9a

    Don't know if this helps any. :)
  6. Sarim

    Sarim TS Rookie

    Age of Empires and DirectDraw compatibility

    Regarding the AOE Error message saying to check your video card and display adaptors for compatibility with DirectDraw...

    I had this error (Win 2000) and after a frustrating search and replacement of video settings, devices drivers and the whole shebang, the problem still remained.

    The solution (in my case) turned out to be incredibly simple...

    I have a Gravis Experience game pad / joystick that loads on startup and runs in the background. (The annoyance of this is another issue altogether).

    When I "End Process" the game pad (which I rarely use anyhow, and never for AOE), the so-called "video" problem disappears.

    Hope that helps.
  7. sguthrie

    sguthrie TS Rookie

    Rise of Nation video problems

    I ran into this exact problem.

    Try the following:

    1) Use the RUN command to load DXDIAG.

    2) Click on the DISPLAY Tab.

    3) If Direct3D Acceleration is disabled, enable it. If Direct3D Acceleration is enabled, disable it, then enable it.

    4) Click the TEST DIRECT3D button and test all three interfaces (7, 8, and 9).

    Sometimes Direct3D Acceleration will say it is enabled, when in fact it is disabled. Disabling, then enabling clears the problem.
  8. gravity3479

    gravity3479 TS Rookie

    I am looking in your profile and you state that you have a NVidia RIVA TNT2 64 Video Card.
    If this is the case, what are you using your onboard SIS video for???
    you need to set your bios to be pointing at your card not the onboard.
    Assuming I am correct, the RON website for compatible video cards does say that it supports NVidea, but im thinking that TNT cards are not compatible.
    You may have to upgrade your card to GeForce!
    Also, My experience is that SIS chipsets are not compatible with RON anyway :(

    If my assumtion based on the above is correct you would be better to try upgrading your NVidea drivers also.

    I am no expert but its worth a try. :)

  9. d3fay3

    d3fay3 TS Rookie

    Re: Rise of Nation video problems

    dude Above ^

    I've got that card in my old pc and its good for the age.
    You will find the right drivers for it if you search on google and keep and eye on the card drivers u downloading FOR, and what OS the version of the driver is!! Dont make a 2nd mistake downloading the wrong drivers, go to BIOS most likely by pressing DEL on numpad on startup and find the gfx settings and point it at AGP so that ur card is default, cos mobo cards are usually crap.
  10. gravity3479

    gravity3479 TS Rookie

    I have just finished installing RoN with a friend to play online.
    She is running:-
    Windows 2000
    Onboard SiS 730 using 64MB-RAM AGP4X
    DirectX 9.0a

    Her system also exceeds minimum expectations for the specifications.

    It is also running original drivers supplied with motherboard for the SiS video chipset.

    All I can suggest is that your PC meet all specs for the game, then check your 'dxdiag' that you have support for all Direct 3D, Direct Draw and AGP Texture Acc. at no less than 4X.

    I am running XP, 256MB RAM, Onboard VIA chipset using 64MB AGP4X, DirectX 9.0b and it runs fine with some change to settings within the game.
    Although it does get a bit jerky towards the end of a game with lots of stuff happening.
    I have noticed that my system at the desktop after booting only has around 80MB Physical RAM Free, and it is already using a huge chunk of Virtual RAM. I am sure that RoN when playing would use a lot more than that.

    I cant say anymore
  11. Ozz

    Ozz TS Rookie

    You could Try this....For some reason My graphic acceleration settings were on low....but not for long....Worked for me!
    good luck

    1. Open Display Properties in Control Panel.
    2. On the Settings tab, click Advanced.
    3. On the Troubleshoot tab, make sure the Hardware acceleration slider is all the way to the right.
    4. Clear the Enable write combining check box, and then click OK.
    5. Click OK, and then restart your computer when you are prompted to do so.
  12. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Also, update DirectX to version 9.0b, 9.0a is buggy.
  13. hollo

    hollo TS Rookie

    i have the same problem.I already downloaded the latest driver (sis630),and installed,but always get a message from games,that update your driver.sombody help plsssss.
  14. rwnewson

    rwnewson TS Rookie Topic Starter Posts: 44

    Well... it's been 16 months since I started this thread and frankly I can't believe it's still here! I actually don't remember what I ended up doing, but I was able to get AOE running but RON still doesn't work. (By the way, I said this was "my" computer for simplicity, but it is actually my girlfriend's computer). Gotta have somebody to play WITH eh...

    At any rate, I will try those suggestions listed above. Sorry I couldn't be more helpful and thank you everyone for the advice! I love these tech support forums... they're so helpful!

  15. hollo

    hollo TS Rookie

    so do i like these tech forums, are so helpfuls.. :unch:
  16. Sinking_moose

    Sinking_moose TS Rookie

    My problem is solved!!!!!!!!!!!

    Im french so my windows is in french so i may not using proper term sorry
    First go to the control panel,install/uninstall program icon and uninstall any sis program (they do not work properly with directdraw) NOT AUDIO
    second go this site
    go to archives(left column)then go to A901(2.0)
    go to the very bottom VGA and DOWNLOAD IT (vga sis 630 2.8)
    third right click on workstation icon(computer like)and properties
    select material(hardware gestion)panel
    Select graphic card(double click on it)
    select driver panel and click on update driver
    then slect NO(do not let windows look for it)
    select install from a spcified emplacement yourself
    select do not research i will choose it myself
    Then a new page appear
    go to the disk icon and click it
    browse where u put it and install it
    i hope this post will help
    it work for me and i can play AOE now
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...