Puzzling Vista RAM trouble

By ChrisTL ยท 11 replies
Mar 21, 2008
  1. Hello all, I am new to this site so i would appreciate any help. Last week I installed Vista64 in dual boot with XP32. I have the common issue of BSOD whenever I attempt to boot Vista with my fourth stick of RAM installed, but none of the remedies I could find have helped. I have run Windows Memory Diagnostic, which found no errors. I also attempted to install the kb929777 patch which is said to fix this issue. When i try to run it, i get the message "this patch does not apply to your system" ?? I also tried increasing the DDR2 voltage from 1.8V to 2.0V which allowed Vista to boot successfully and confirm 4.0 GB RAM one time, but never worked again. I would appreciate any new ideas; here is my setup:

    AMD AthlonX2 5200+
    Gigabyte GA-M61P-S3 MB
    4x1GB OCZ Gold DDR2 800
    HIS Radeon 3870 X2
    30GB seagate 2x 500GB WD caviar
  2. CCT

    CCT TS Evangelist Posts: 2,653   +6

  3. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Does XP work with all four sticks?
  4. ChrisTL

    ChrisTL TS Rookie Topic Starter

    XP runs fine... has for months. The one time Vista did boot it correctly showed all 4 gigs and ran Windows Experience Benchmark fine... gave me a 5.9 for memory.
  5. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    have you tested your ram with memtest 86+ booted from a floppy or CD?
  6. Aolish

    Aolish TS Enthusiast Posts: 171

    if ur system is stable with xp with 4gb then there's probably no issue with the ram itself. Might be a specific vista problem. vista sp1 just came out, might want to try that and see if that fixes your issues.
  7. ChrisTL

    ChrisTL TS Rookie Topic Starter

    I agree with N!Sung at this point... It was completely stable under XP and with Windows Mem Diagnostic showing clean I'm pretty sure the RAM is not the problem. Unfortunately, I have already installed SP1 and nothing has changed, so i better give memtest a shot.
  8. ChrisTL

    ChrisTL TS Rookie Topic Starter

    I will give Memtest a shot
  9. Starcruiser322

    Starcruiser322 TS Rookie


    I've heard alot of bad stuff about Vista. Until recently, I thought it was just ahead of it's time, but the various issues I've heard of, several mem. problems, a few install problems, so now I think I'll hold off buying and installing Vista on my XP SP2 until it can imrove. alot. I think your problem is just a classic issue of a bad OS.
  10. ChrisTL

    ChrisTL TS Rookie Topic Starter

    Well, I ran Memtest86 and as I suspected, it returned no errors. Any more ideas?
  11. jonisaksson

    jonisaksson TS Enthusiast Posts: 83

    Reading up on this, some people seems to be reporting that changing the ACPI version resolves this issue.

    Check in bios and try both v2 and v3 and see if either of them resolves it.

    Looking on the microsoft site, there are loads of people reporting the same issue with no solution.

    Looks like a bios/MS issue. Here is a copy from MS forum.

    "On that note, I've been in contact with Microsoft Support and at first the lower level techs weren't aware of this issue, nor could find a resolution. I was then escalated to their research team, which got back to me a day later and i've been told that it's an issue with Vista, and the resolution will either come from a BIOS update and/or a hotfix. The specific tech told me that his team gets about 10 people a week with the same issue and they are working with motherboard manufacturers to resolve the issue. He suggested that I keep checking in every 3 weeks with them until the issue is resolved. So we just have to keep an eye out for hotfixes and keep our BIOS up to date. He also mentioned this is a high priority problem, so it shouldn't be too long considering that 64-bit Vista was designed for use w/ more than 2GB of ram but it's not supporting it on a lot of motherboards."
  12. ChrisTL

    ChrisTL TS Rookie Topic Starter

    The Resolution

    Well, here it is... when i swapped my Gigabyte GA-M61P-S3 mainboard for an MSI K9A2 Platinum it just worked. Vista posted fine the first time and has run fine through a few quick stability tests... I will update if any more issues arise but all seems well!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...