Radeon x1950Pro + Vista no aero :(

By samo.ice ยท 10 replies
Feb 11, 2007
  1. Ive searched the board and cant seem to find a simular thread so thought i make my own as ive had troubles with this the past week

    I currently have a Sapphiire Atlantis Radeon x1950Pro graphics card ona Asus ATI CrossFire Xpress 3200 A8R32-MVP Series motherboard and im having a slight problem trying to get the graphics card driver to reconise the card properly so i can use my highest res 1440*900 ( i have a hanns-g HW191D Widescreen TFT dont know if i need to install the driver for that ? )
    I've noticed that in my device manager it says unkown device about 3 times , ive tried pointing those to the ati folder but no avial .

    This Gfx card should be Vista ready, it said so on the box . so i duno y it doesnt work :(
    atm i have full 32bit colour so thats all good its just getting it up to the 1440*900 im bothered about and gtting the card reconised in the device maanger .

    found this which i think could be the key to my problems , and could be linked to the pci-e bridge on my graphics card thus it not reconising fully ?
    it says free more resources.. but ive got 3gb ram and 250gb hdd space ? :?


    any takers on helping ? would really like to get the aero activated.
    ive tried the 7.2 drivers but it says there is no card aviliable ?
    It works fine in my other drive with windows xp 64bit, im using vista home premium 64bit.
    So im lost here
    Been struggling with this for a good 5 days so any help would be great!
    Ive tried reinstall , reinstall manually ( it doesnt like to be reinstalled manually.. says it hasnt found the right driver ?)
    thanks :D
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Do you have the motherboard drivers installed properly?
  3. samo.ice

    samo.ice TS Rookie Topic Starter

    There isnt really any dirvers for this asus boad as far as im aware :S which ones should i look out for ?
    Becuse ive tried the auto update thing on that pci-e device and it says its fully uptodate
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Your motherboard may not be compatible with Vista... Have you tried a fresh install of Vista on the Asus system?
  5. samo.ice

    samo.ice TS Rookie Topic Starter

    hmm it is a pretty new board .
    i tried the gfx card in the second pci-e 16X slot of my crossfire board and it didnt show any of those pci errors at all just couldnt get the res high enougth, and it reconised as a radeonx1950pro in the device manager instead of unkown device. just wouldnt go higher than 4bits .
    ive searched various forums and seems to bea common problem but ive not seen any solutions of yet..
    hopefully asus will bring something out soon
  6. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Well I have nothing else to add. These issues will be common for a while, but I am sure they will be addressed eventually. Good luck :)
  7. samo.ice

    samo.ice TS Rookie Topic Starter

    can anybody else help with this ? are there vita drivers for this motherboard i sould use ?
  8. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Vista is brand new... You didn't realize this? Many of us computer gurus will not install Vista for some time. Why? Because there will be a lot of issues with hardware and software using Vista. You are beginning to suffer from installing Vista aren't you. I am going to build a "special" Vista system next month. I am not going to install Vista on this system... That would be a foolish thing to do. Do you feel foolish?
  9. nickc

    nickc TechSpot Paladin Posts: 923   +11


    I bet if u go to the maker of the motherboard's site and quiz them they will have drivers and no board is going to work right without the propper drivers.
  10. NFSFAN

    NFSFAN TS Rookie Posts: 245

    Try putting the card in another PCI-E slot on your mobo. Then you said that the card was recognized if you changed the slot it was in. Now that Vista reads it a x1950 PRO, do a google search on Driver Cleaner Pro 1.5, download and install. After run it and in the drop down box select, ATI, and Press Clean.
    Now go to ATI's website and download the VISTA drivers Catalyst 7.1, and install them. It should work perfectly
  11. samo.ice

    samo.ice TS Rookie Topic Starter

    got this sorted a ouple days ago with a updated bios flash.

    thx for ur advice
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...