RAID controller kills HDDs?

By ProFowler ยท 14 replies
Jun 14, 2010
  1. Hello,

    So I've been using this site extensively for at least a year, and since I haven't found an article specifically for this anywhere, I figured I'd contribute. I realize it might not help me in time for delivery, but it might help someone else later. So heregoes...

    I finished this build last week for a customer, had everything setup and working except the raid 10 storage array. I'll list the parts here...

    Relevant components:
    - ABS DARK BERET seriesDB1000-M-BRZ 1000W PSU
    - AMD Phenom II X4 955 Black Edition Deneb 3.2GHz
    - G.SKILL ECO Series 4GB (2 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600
    - A-DATA 500 Series AS592S-32GM-C 2.5" 32GB SATA II SSD (x 2 - raid 0)
    - HIS H577FM1GD Radeon HD 5770
    - SAMSUNG Spinpoint F3EG HD203WI 2TB 5400 RPM SATA (x 5 - raid 10 + 1 native)
    - OS: Win7 64bit pro

    Anyway, Friday, 3 days before delivery, I get artifacting. On desktop, not in game. Immediately turned off aero, which fixed it mostly. Checked CCC for overheating, kept an eye on card. Nothing abnormal, EXCEPT that with the artifacting came massive system slowdown, errors and BSODs.

    Checked PSU for overheating or irregularity, but mm readings were normal. Tried several backlogged CCC versions thinking "must be drivers." But that didn't fix anything, so I decided it was just bad mem on card, and took it out. Integrated VGA works fine for now. I'll explain to end-user, no big deal. But problems persisted...

    Almost immediately after, the system would halt whilst booting Win7 (in the middle of the color-swirl) and repair startup function always led to a BSOD where the CPU fan would gradually climb to 100% velocity. I read about CPU compatibility issues with the F1 BIOS of my board which apparently was the source of a lot of other issues, so I just q-flashed BIOS to F2, which fixed it. To make sure, I performed a 10 round extended RAM diagnostic which took forever and resulted in "no errors." Sweet, it's all fixed. If only...

    Now I have disk trouble. Yesterday, I enable onboard raid for SATA ports 0-3 (the Samsung drives), reboot, and there's immediately knocking from all of them in sequence. They don't post either. I let it go through the process just to be thorough: raid function doesn't detect drives, BIOS doesn't detect drives, "Computer" sees no drives, "Disk Management" sees no drives.

    I set them back to Native IDE. They still don't show anywhere. I notice the abnormal sounds continue only until I leave the computer off for a minute or so, then on bootup they sound normal, but still won't post. I pull all drives and check them one-by-one in the dock. All but one work fine. I replace the one bad Samsung with the hot-swap extra I had bought. Partitioned/formatted each drive, checked each with Active@ and wrote/read a few files. They were fine. Put back in case, but they still wouldn't read as native IDE drives. Replaced SATA data and power cables. Still no go.

    This morning, I turn the computer on and.... voila, they post! I can read them natively and everything. We now have 8TB of storage, ladies and gents. But here's where I make my mistake. After awhile of working on software, I decide to retry the onboard controller to get the raid 10 storage the customer had requested. Again, upon rebooting, all drives knock in sequence and refuse to post from there forward. I am now back to where I was last night.

    So here's the only explanations my ill-equipped brain can think up:
    1. I've missed a step along the way;
    2. I got a whole batch of bad disks;
    3. Onboard raid is somehow f'ing up these disks:
    --a. Perhaps the board is delegating a function/parameter the drives don't support?
    --b. Perhaps I am overlooking a BIOS setting that is disabling these drives?

    I'm at a loss. What do you think?
  2. LinkedKube

    LinkedKube TechSpot Project Baby Posts: 3,485   +45

    Could be a defective controller. Only thing I can think of since you posted just about everything else. 99% of people wouldnt notice your issue because raid of any kind is rarely used. Even for system builders.
  3. mailpup

    mailpup TS Special Forces Posts: 7,185   +469

    I don't believe you can switch in the BIOS the controller mode from IDE to SATA to RAID without reinstalling Windows each time.
  4. LinkedKube

    LinkedKube TechSpot Project Baby Posts: 3,485   +45

    You cant, you have to do it during the install, unless you have a stand alone raid controller.
  5. ProFowler

    ProFowler TS Rookie Topic Starter

    Thank you guys for your replies! I could be entirely mistaken on this one.

    Would this apply in the case of multiple raid controllers? This rig has three, specifically, and the one in question is the onboard SB chipset (AMDSB850) managing 4 Samsungs. The controller managing the SSDs for OS, on the other hand, is the onboard GSATA2 chip.

    For instance, since I flashed the BIOS, we know that I did already change these settings for both onboard controllers in order to maintain the OS raid 0 array. I'm in Win7 on the rig now.

    So, would changing the mode of [controller A] without reinstall of OS on [controller B] be the cause of SATA disks not posting on [controller A]? I'm open to this possibility.

    Really appreciate the help!
  6. LinkedKube

    LinkedKube TechSpot Project Baby Posts: 3,485   +45

    YES, sounds like you may have the solution. Through your attempts of trial and error you could have done, what I call, "an alligator move." Installing so much at once you barrel rolled(death rolled) yourself into something you cant deal with. If you can plug in the drives into sata ports w/o raid and they still work it can very well mean your onboard controller is blown. Just another issue.
  7. ProFowler

    ProFowler TS Rookie Topic Starter

    Hmm, Interesting. I've not yet heard of this phenomenon. Well, since it sounds as if proposed solution #1 is to reinstall OS, and that won't take long at all, I will do this and post results.

    In the meantime, however, any other takers?
  8. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    sadly, i agree. It's very tempting to 'just add one more thing while I'm here', but it complicates the problem resolution process.
    Frequently the thought process goes, "it takes too long to do a step-by-step install, reboot, test sequence so I'll take the 'shortcut'".
    As you can now attest, you could have saved significant time and effort with a controlled alteration process.

    Get your raid drivers available
    • do a clean install of the OS.
    • Reboot and verify operational status.
    • If it is a viable system, take a 'system state backup' before you change anything else.
    • If not, start over with a different configuration OR debug why this configuration is failing.
  9. ProFowler

    ProFowler TS Rookie Topic Starter

    This is the procedure I followed for every installation. The last thing to install was the SEPARATE raid controller for storage. Be aware, the computer had passed all my standard tests with flying colors and had been working fine for a week.

    Right now, we're ostensibly looking at a single issue. We're trying to diagnose a technological problem, not a methodology.

    Okay reinstalling the operating system had the logical effect. That is, it had no effect at all.

    I say this would be the logical effect, supersmashbrada, because we are currently talking about an abnormality in what I like to call the "Power-On Self-Test" or POST and not in the OS.

    We could, perhaps, form an explanation as to why the P.O.S.T. would reach into 2 hard-drives (it had yet to account for) in order to "check" whether the OP had reinstalled his OS on them, before deciding to post the other 4. But this might be counter-productive.

    In other words, there is very little reason to think this would have much to do with software. Thanks for your attempt, however.

    More than likely, mailpup assumed (for unknown reasons) that we were talking about a system with one controller.

    I know the original post is a lot to read, but it's important to do so if we're to get anywhere in this thread.

    Anything can be dealt with. Saying "you didn't do it right" without explaining or trying to figure out specifically what was "done," or "not done," and what specifically was not "right" about it, much less attempting to provide a solution, is really just masturbation after all.
  10. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    yes, that was understood.
    the comment was aimed at the question, 'how many variables were changed between condition A and the current status B'.
    The more varibles, the more difficult the analysis.

    Best wishes.
  11. ProFowler

    ProFowler TS Rookie Topic Starter

    Ah, okay. I misunderstood the original intent of your post. You're very right about it too. More variables = more work. Thanks for your input, jobeard. Regards.
  12. LinkedKube

    LinkedKube TechSpot Project Baby Posts: 3,485   +45

    Not to say you cant deal with it, or it "can't be done." It was a generalization as well, not directed at you, well maybe during this thread. I think we have all barrel rolled, circle jerked or masturbated ourselves into a very repetitive process of trial and error. The key is find the hole you mistakenly fell into in this build.
  13. ProFowler

    ProFowler TS Rookie Topic Starter

    Thanks for the clarification, super. I appreciate your help.


    The solution fell out of the sky this afternoon. Actually, it was delivered to my front door. A new batch of Seagate drives had arrived for another build and I decided to try them on this system, since it didn't appear that the onboard controller was killing the Sammy drives after all.

    The new drives posted immediately, showed in BIOS, initialized in "Computer Management" and read/wrote perfectly in "Computer." What's more, when I enabled raid in the BIOS, the controller config allowed me to set up the raid storage array, which subsequently initialized in CM and read/wrote speedily.

    The system is now fully operational (though I'm still running a battery of tests), ready for delivery, lacking only the VGA card that should arrive later this week. It appears all along the problem was compatibility b/w the 2tb Sammys and the SB850 controller.

    Hopefully this thread will be of some help to another system builder. Always be logical, and don't be afraid to try something new... in this case a different brand of drive.

    Thanks everyone.
  14. mailpup

    mailpup TS Special Forces Posts: 7,185   +469

    Yes, I overlooked the part where you said it wouldn't post so you were right about that but you only spoke of the onboard SATA ports 0-3. Those are under one controller. By what you wrote in your first post to which I responded, it wasn't very clear to me that you were concerned with multiple controllers. Those were my "unknown reasons" and that was an unfair rebuke. I was only trying to help you. If I failed, then that's yet another mistake.
  15. ProFowler

    ProFowler TS Rookie Topic Starter

    Hey man, sorry for the "rebuke." I know you meant well, and I focused the confrontation of a general annoyance to a specific person (you), which is usually a mistake and in this case unfair. Thank you for your help! All the best.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...