Realtek RTL8168

By tommy2k8 · 13 replies
Sep 1, 2008
  1. My client has got a RealTek RTL8168 10/100 PCI Express card in his computer, but in the Device Manager there is a yellow exclamation mark next to the entry 'Microsoft 6to4 Adaptor', which is disabling internet access. How can I solve this problem?
  2. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

  3. tommy2k8

    tommy2k8 TS Rookie Topic Starter Posts: 70

    Thankyou. I think that may make it work as the Vista driver only came out last week

    My client told me today this only happened since he left Pipex (they cut him off, I don't know why) and changed to Sky BB last week, they checked the line, the software is installed, here is a list of what I did:

    I updated the network card driver to the current version
    I deleted the 6to4 adaptor
    I disabled IPv6 - I enabled it again when it wouldn't connect
    I tried all 3, 'Never Dial a connectioin', Dial A Connection when a network is not present' and 'Always dial my default connection' which is 'Broadband Connection'
    I uninstalled the network adaptor, rebooted, and got Windows to autodetect, that didn't work

    When I click on Diagnose and Repair, it says there's a problem with the network card, but it doesn't tell me what! But then when I try to connect normally and diagnose, it says everything is working fine.

    If it's helpful, it's error 814: The underlying Ethernet Connectivity required for the broadband connection was not found
  4. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    Does he still have the software for his current connection (the one that isn't working)?

    If so I'd delete everything you can find related to it, as well as the ethernet card in the device manager. Then reboot, and only install the card drivers. Then try that without the special software. I don't know if it will work, but I've had problems with wireless cards and connections because XP and the wireless card software are trying to do the same thing sometimes and if everything wasn't done 100% by the book issues can arise.
  5. tommy2k8

    tommy2k8 TS Rookie Topic Starter Posts: 70

    Before Error 814, it said 'connecting via WAN miniport (PPPoE). This may be a silly question, but is this the right way to connect.

    I think he's still got the software.
    The trouble with this job is that he lives in Tonbridge and I live in Otford, and everytime it doesn't work, I have to come back here as I don't have the net (it doesn't really matter, but it is a bit repetitive!)!

    Shall I do the same thing for Vista?
  6. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    That's a DSL connection and the modem needs to be properly setup with the
    user-id/password and isp parms.
  7. tommy2k8

    tommy2k8 TS Rookie Topic Starter Posts: 70


    I can't access the router to get to it!
  8. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    plug the equipment like this
    modem --- your system
    notice the Router is removed (just for now)

    You need the account info from the DSL provider, so call them first :)
  9. tommy2k8

    tommy2k8 TS Rookie Topic Starter Posts: 70

    Even though I put a network card in, it still didn't work. When I go into the corresponding LAN connection, the problem lies in the fact that ipv4 and ipv6 connectivity say they're not connected. How do I enable both of these?

    I tried repairing TCP/IP as well but to no avail.
    When I did an ipconfig /release (and ipconfig /renew) it comes up with the error message 'An error occured while releasing interdaxe Loopback Pseudo - Interface 1 - The system cannot find the file specified.
    The operation failed as no adapter is in the state permissible for this operation.'
    I have flushed the DNS, made sure Winsock wasn't corrupted, disabled IPv6 in the LAN properties and the Registry, but it still reports that ipv4 and ipv6 (even though disabled) has no connectivity. The problem is definitely with the new protocol (there is a bug with Vista and newer devices). Anybiody know how to solve this problem.
    If it helps I have attached a ipconfig /all
  10. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    my my! You have a ton of pseudo connections performing tunneling but NO REAL adaptor!

    Try booting into SAFE MODE (ie keep hitting F8) and when you get the prompt
    for Safe Mode, select ... With Networking

    when you get the chance, run cmd /k ipconfig /all again
  11. tommy2k8

    tommy2k8 TS Rookie Topic Starter Posts: 70

    Bl***y Microsoft!

    That didn't work either!

    The problem lies with ipv4. On the properties page for the LAN connection, it says ipv4 connectivity: not connected; I need to know how to connect.

    This is a common fault with Vista, well documented on the web, but guess what? Microsoft won't help because Vista came preinstalled with the computer, and they want to charge £40 for support!
  12. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

  13. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    A quick and dirty fix for this sort of thing that works 9 times in 10 is to uninstall the network card (NIC) in device manager and then reboot, This forces a reinstallation of the NIC and should reset all the various network protocols to default.
    If you have not changed the settings in the router, the connection to the net and the LAN should work without any further setting up;
    Worth a try perhaps?
  14. tommy2k8

    tommy2k8 TS Rookie Topic Starter Posts: 70

    ZA and SP1

    I solved it! Apparently, unbeknown to me, there were fragments of ZoneAlarm on the system (he said he hadn't installed it though) and, together with SP1, they both were blocking the net
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...