Removable IDE MS HD must be inserted and on for SL to be accessible

By TeeTime
Jan 13, 2006
  1. My removable IDE HD and another IDE HD are installed on my primary IDE cable. My boot drive is a SATA. Everything works great except no matter what I try, the computer won't recognize this stationary HD UNLESS THE REMOVABLE DRIVE IS INSERTED AND TURNED ON. I suspect this is the way IDE works, but would appreciate it if anyone can tell me a way to use my stationary drive even when the removable is turned off.

    Here is how my drives are set up:

    SATA1 boot and programs drive
    SATA2 video capture drive
    IDE1 Master - removable IDE drive
    IDE1 Slave - stationary IDE drive
    IDE2 Master - DVD Burner
    IDE2 Slave - CD Burner

    1. If I remove the cable from the removable IDE drive and start the PC it DOES recognize the 2nd (stationary) drive.

    2. If I turn the removable drive off (via the switch in the drive rack), or remove the drive from the rack and start the PC it DOESN'T recognize either of the IDE1 drives.

    3. All drives are set to CS (cable select). I've also tried them jumpered to their position, and have switched drives between Master and Slave, to no avail.

  2. zephead

    zephead TechSpot Paladin Posts: 1,569

    removable IDE? the IDE bus is not hot-swappable. the power needs to be off to change/add/remove an IDE drive. you're probably referring to an IDE drive in an external encolsure, using USB or firewire to interface with the computer itself.

    what si your boot order in BIOS? try messing around with the settings allowing boot to USB devices.
  3. TeeTime

    TeeTime TS Rookie Topic Starter

    Zephead, thanks for the reply. I'm using a mobile rack attached internally as an IDE device. I plug a standard IDE drive into this rack. As you stated, it is NOT hot-swappable so I always power down before swapping drives. BTW, I also use USB and Firewire external drives so I am familiar with how they work.

    My boot order is correct, and I have tried switching positions on the IDE cable, and configuring via jumpers, but no matter how it is configured the PC is unable to find the 2nd drive on the IDE cable the removable drive is on if the drive is removed or even turned off. If I detach the IDE cable from the removable drive, the PC then will find the other drive on that cable.


  4. zephead

    zephead TechSpot Paladin Posts: 1,569

    this could be caused by a bent pin or faulty cable. i'd take a moment to inspect the drives and controller socket. alos, try swapping out with a known good cable.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...