Samsung Writemaster Problem

By Zira
Oct 10, 2007
  1. In the beginning all worked fine until one day it stopped recognizing blank DVD's and the tray would not open with the button. I downloaded the latest firmware and that solved the tray problem. Now, I try to burn, with the correct blank in the tray, tray slides open and a window pops up saying Please insert empty disc to write to: The drive does not recognize any type of media I put into it.

    The sticker on the bottom of the drive says it is a SE-S184M. That is the firmware that I downloaded from Samsung. Now it says it is a SH-S182M. Did I mess up? Thanks.
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    "Did I mess up? Thanks"...

    No, but you wasted a little time. Replace the CD drive
  3. Zira

    Zira TS Rookie Topic Starter

    I only burned like 5 DVD's with it so far. Are you saying it is junk? I can't find the receipt for it either.
  4. Cinders

    Cinders TechSpot Chancellor Posts: 872   +12

    Sounds like the drive is dead! Ejecting all good media when it shouldn't usually means dead drive. :( sorry
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...