SATA HD Unformatable, Hardware conflict?

By greeny12m
Jan 9, 2005
  1. i think i must have a hardware conflict somewhere on my system, i just got a new 250 Gb hitachi SATA HD and a Silicon Image SATA PCI card to run it on.the only problem is when i try to format it it gets to 100% and then says "Windows could not complete the format" even if ionly try to format a 512Mb partition on it. i downloaded the diagnostic utility and it showed no errors with the disk and it works perfectly on other PCs. i have tried to format it using another PC and then transfering it into the problem PC but it seems to corrupt some files on it and makes it totaly unreliable, the strange thing is that every boot up different files are corrupted and sometimes the whole disk is unreadable it isnt a problem with windows either, i tried formating it using a totaly fresh windows install on a seperate HD and it still didnt work.

    Here are My Specs:
    2.8Ghz P4m (but only running at 1.6 cos its a laptop chip)
    ASUS P4S800
    2x512Mb Pc3200 ADATA Ram
    SATA Pci Card (Silicon Image chipset 3512)
    KY-500ATX 400w PSU

    Also any help getting my 2.8 laptop chip to actualy run at 2.8 would be great
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...