Setup did not find hard disks (2 WD SATAs)

By Rothko · 8 replies
Sep 23, 2007
  1. AMD Athlon 2.0Ghz
    ABit AV8 Motherboard with ABit uGuru BIOS
    1Gb RAM
    Drive 0: Western Digital Raptor 36Gb WD360GD
    Drive 1: Western Digital Caviar 160Gb WD1600JD
    Running Windows XP on Drive 0

    I have read this topic (link below) and seem to be having a similar problem, however mine is on 2 separate hard drives.

    It started when I tried logging onto windows, when logging in the system started the process then immediately logged me off.

    My first thought was that Windows had been damaged and proceeded to re-install.
    When re-installing the following warning came up…
    “Setup did not find any hard disk drives installed in your computer.”
    (Please note I have two different hard dives, although both made by WD)
    When I boot up however, it is clear that the hard disks are recognised.

    I followed the instructions of ‘RealBlackStuff’ and searched for the correct drivers on the WD website and copied them to floppy disks.

    I went through setup and pressed F6 and installed the drivers from the disks, then when these had been loaded the setup went back to installing Windows.
    When I went back to the install screen I was met by the same warning…
    “Setup did not find any hard disk drives installed in your computer.”

    I have checked all connections inside my computer and even swapped them round to see if any cables or ports were faulty, nothing made any difference.
    I have checked my BIOS and there does not seem to be any settings for SATA drives only IDE connections, the only one being the DVD drive on primary master (I am using BIOS for ABit AV8 motherboard).
    The setup also shows the hard disks on the RAID array menu, however no arrays have been set.
    I don’t even know at this point whether the problem is hardware or software, is it a faulty hard disk that is bringing the other one down too? These hard drives are both on their own port, neither is a slave. Is it my BIOS settings? Is it my motherboard? Or is it a virus?
  2. tipstir

    tipstir TS Ambassador Posts: 2,475   +126

    Disable the 360GB unplug the cable/power reboot the system. Go into the BiOS does it see the 36GB? If it doesn't try reversing the steps. If the RAID controller is damage this could be the problem? What where you doing prior to this. You had said all was working fine then what happen? Do you have any IDE drives you can connect to the MOBO then put OS on that drive. Boot up the system, then shutdown. Add the 36GB SATA only. Bootup the sytsem see if you can access the drive under XP. Repeat the process for the 360GB. If that works then the RAID controller is faulty on MOBO. If both can't be access then something happen to them.
  3. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    I think you're using the wrong drivers. Do you have a separate SIIG brand PCI SATA/RAID controller card installed on your Abit motherboard? PCI controller card being the key phrase. If not and the SATA hard drives are connected directly to the motherboard, you should go to the motherboard manufacturer, in this case Abit, to download the appropriate SATA/RAID drivers.

    Put these on a floppy and install at F6 and that should solve the setup problem.
  4. Fragrant Coit

    Fragrant Coit TS Guru Posts: 363

    Some VIA chipsets wont handle SATA2 HDD's.
    It caused me a lot of grief until I worked it out.

    You need to jumper them to run at 150, not 300.

    The BIOS will find them then, and you are 1/2 way there.

    I THINK it's pins 5 & 6 (They're numbered right to left).
  5. Rothko

    Rothko TS Rookie Topic Starter

    To Tipstir: I dont have any IDE drives just 2 SATAs, I have tried booting up with just the 36gb and I have tried with just the caviar, both are recognised by BIOS when booted up on their own but they are not recognised by windows setup. I do have a number of USB external disks and have heard about them being used to boot up windows but have never tried it. Is it possible?

    To Mailpup: The only revision of the SATA/RAID drivers are in windows format and I am not sure if it is possible to install them.

    To Fragrant Coit: I'm not sure if my disks are SATA2 but i tried jumpering like you said and there was no difference at all.

    I'm starting to get slightly worried about this now.
  6. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    Yes, Revision v4.30g for Microsoft Windows 9x/Me/2000/XP/2003. Anyway, I don't understand your point. You are installing Windows, correct? You need Windows supported SATA/RAID drivers. Those are Revision v4.30g. Download them from the motherboard site, put them on a floppy and install them as third party drivers at F6.
  7. Fragrant Coit

    Fragrant Coit TS Guru Posts: 363

  8. tipstir

    tipstir TS Ambassador Posts: 2,475   +126

    Best bet is burn a CD with a bootable FDD feature (floppy disc) onto a CD allow with your SATA drivers. This way is easier and you can get your items in stalled if you have more than one CD/DVD and don't have FDD. This problem you have is all too common.


    The main devices should be C: D: for SATA drives.
    If you have CD, DVDs make sure you assign them drive letters like R: W:. If you have USB HDDs you can force XP to load them in order that would be E: G: an etc..
  9. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    where do you see the drives while in bios
    under drives and or under boot priority
    you may also see listed as master slave 1st or 2nd position
    important positions are hard drives and boot
    for now ,the one you want to install the OS to should be 2nd boot to the optical drive.
    try to do the install of oem drives twice see what it says
    it easy to make corrupt install best to use a new floppy
    I've had many of floppy seem OK but would not load right
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...