Strange FPS drop

  1. First things first. Specs.
    Processor: Intel Core i7-3610AM CPU @ 2.3 GHz
    Video Card: GeForce GT 650M
    RAM: 12 GB
    OS: Windows 7 Home Premium

    I've been getting a strange FPS drop across all my games recently. I would start out fine, and then my FPS drops and stays low. When I Alt+Tab out of the game, wait a while, and return, FPS jumps back to normal before once again dropping and staying low. Right now, I'm using Dishonored (on high settings) to test my FPS because it doesn't demand much. I would start out at around 80 FPS; after a few minutes, it drops to around 20. When I Alt+Tab out, wait a while, and go back, FPS jumps back to 80 before again dropping and staying around 20.

    I'm monitoring my temperatures with CoreTemp and MSI Afterburner. My temps never exceed 75C/167F. MSI Afterburner shows that my CPU usage goes to 100%, but Task Manager does not show the same. My Memory usage stays low. Task Manager does show my Disk usage sometimes spiking.

    Things I've tried:
    - Uninstalling all Windows Updates since April.
    - System Reboot
    - Defragmentation
    - Virus Scan
    - Various methods found in other forums.

    No luck.

    The strange thing is this has never happened before. About two weeks ago, everything was fine. Then, a few days ago, *BAM*, low FPS. I don't know what to make of this.

    Plz halp.

    UPDATE to things I've tried:
    - Made sure my graphics driver is up to date for my specific card (nVIDIA 335.23)
    - Unplug my mouse

    UPDATE to things I've tried:
    - Clean install graphics driver
    Last edited by a moderator: May 24, 2014
  2. Roger Williams

    Roger Williams TS Rookie Topic Starter


    Well now I just feel silly. I've identified the problem to be a throttling issue that plagues many M14x R2 users. If GPU temp exceeds 67C, it throttles and FPS tanks. Strange thing is: this has never happened before. I would be playing at 80+ temps and my FPS would be fine.

    Anyway, I've identified my problem. Gonna try to find a fix. I'll post here if I find one in case future users have the same problem.

    K peace out.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...