1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Streaming video problem

By StormBringer ยท 14 replies
Aug 30, 2003
  1. I have had a problem for some time now with WMP9 and streaming video. the problem is with all formats EXCEPT .asf and .wmv. those two work fine, all others crash WMP9 with an "unknown error". After this had happened a few times I decided to send an error report on it to see if it might find a fix. It came up witth an article that said I needed to update my copy of MPEG Encoder. I do not have that application(yes it was refering to an application, had a link for me to dl it)
    I did at one time attempt to install Adobe Premiere but it did not install correctly and I uninstalled it. it included a version of MPEG Encoder in it, so gave that app a shot, it did not fix the problem.

    I can play all media formats if they are on my machine. I can also stream these files using Quicktime or RealOne(but I don't like those apps) :confused:
    The problem also seems to occur in K++(Kazaa) If I try to preview any video types other than wmv or asf, I get the same error as when streaming.

    As I said, this has been going on for a while now, I've looked around, asked around and searched old threads here. I can come up with nothing and no one seems to want to help me other than suggesting a format. I do not subscribe to the theory that a format is a fix for anything, so that is not an option. I need to fix this, it has gone from being a slight annoyance, to being a huge headache. :mad:
  2. Nodsu

    Nodsu TS Rookie Posts: 5,452   +6

    Adobe Premiere is known not to uninstall the codecs it has installed and I personally have had problems with this. IIRC all i had to do was to delete the offending files from windows system folder.. I'm sure you can find the exact instructions how to do this if you search the web (that's how i got them).
  3. Nic

    Nic TechSpot Paladin Posts: 1,519

    You can also download Nimo Codec Pack from here ...

    Nimo Codec Pack

    It will install a large number of useful codecs to allow WMP9, and other players, to play just about any video/audio file format available.
  4. StormBringer

    StormBringer TS Maniac Topic Starter Posts: 2,218

    I've already tried Nimo, as there have been a few update of it since I first encountered the problem.

    As for looking for the offending codecs, I looked for about a month for something on the web, found nothing that helped.

    I have no idea what codecs to even look for. At one point I thought about just trashing them all then reinstalling the latest Nimo Pack to hopefully replace most if not all of them. Problem is that I can't seem to locate any info about where these codecs are stored.
  5. Nodsu

    Nodsu TS Rookie Posts: 5,452   +6

    I had some trouble finding it, but I think this was it:

    You do
    regsvr32 /u mcspmpeg.ax
    regsvr32 /u mcdsmpeg.ax
    and then delete/rename those files (In the windows\system32 folder IIRC)
  6. StormBringer

    StormBringer TS Maniac Topic Starter Posts: 2,218

    First off, thanks Nodsu, that fixed .mpg and .mpeg, they will now stream in WMP9.

    Still having the same problem with .avi though. I went to a site and found an avi to test it and when I clicked on it, WMP9 opened as normal, then told me it needed a codec and began to dl it. After it installed the codec it crashed just as the clip was about to start playing. Same thing it was doing before.

    I have not yet tested any of the other formats that are less used(as I've yet to find any to test)
  7. StormBringer

    StormBringer TS Maniac Topic Starter Posts: 2,218

    The mpg error seems to have returned, though not the same error now. I now get a crash and if I submit it, the analysis recommends I download StreamSwitcher. I tried that but it didn't help and I still get the same recommendation.
  8. Nic

    Nic TechSpot Paladin Posts: 1,519

    Looks like your best bet is to format and reinstall the lot, maybe on a second hard drive, so you still have your original setup if you wish to use it again.
  9. StormBringer

    StormBringer TS Maniac Topic Starter Posts: 2,218

    Thanks to Goalie in the IRC channel, I was able to fix the new problem by, get this, reinstalling WMP9 over itself.

    BTW, formatting was NEVER an option.
  10. Nic

    Nic TechSpot Paladin Posts: 1,519

    I'm surprised that you didn't already try reinstalling WMP9, as that is the first thing to do with any software problem. I guess we all assumed you would have already done this, but it doesn't matter much now anyway. Glad you got it fixed. :)
  11. StormBringer

    StormBringer TS Maniac Topic Starter Posts: 2,218

    I didn't try it because I had already tried it with the problem mentioned earlier in this thread, it didn't help, so it had not occured to me to try it when the second problem showed up.
  12. Kojichan

    Kojichan TS Rookie

    I don't mean to bump this old topic... But this has been exactally what I've been looking for to fix my problem! It seems to be a problem with Adobe Premiere, and it's MPEG codecs. Rather odd...

    I had just finished spending 30 minutes rummaging through my Registry, to manually remove the Add/Remove dialog option from there, because I couldn't uninstall WMP7.1, as it would always crash... and when I streamed anything except for WMP's own files, it crashed taking out the mcspmpeg.ax with it. I manually deleted that file myself, thinking it was a Microsoft file, and manually removed WMP. Then I reinstalled, thinking the file would be fixed. Little did I know, it wasn't a WMP file.

    Did a filesearch on the net, found this topic... It helped so much! Thanks StormBringer, and Nodsu! (I registered, just to convey my heartfilled thanks for help fixing this problem!)
  13. rsfnatik

    rsfnatik TS Rookie

    This problem started on my system over the last few days. I'm running W2K SP4 and use the machine for DV editing (Vegas 4.0 and DivX 5.1 Pro). I had installed WMP9 last and everything was fine until a few days ago - nearly every attempt to play streaming content failed. After some testing the problem appeared to be limited to MPEG/MPG clips - WMP9 would simply generate an error report when attempting playback.

    After reading this thread I looked into the files mentioned above:


    I found these files in Sonic Foundry's "Shared Plug-Ins\File Formats" folder. I renamed both with a .old extension and the problem was resolved. With some trial and error I have determined that "mcspmpeg.ax" must remain renamed in order for WMP9 to stream MPEG content. I did not have to keep "mcdsmpeg.ax" renamed.

    Now I have to look into how renaming "mcspmpeg.ax" will affect Vegas. :)

    I'm very glad to have found this forum. Thanks for tip!
  14. rsfnatik

    rsfnatik TS Rookie

    Just found this snip on Sony's site (they own some of the Sonic Foundry products now... such as Vegas Video):

    Problems playing MPEG files after installation of Sony Pictures Digital software.

    Problems playing MPEG files in Windows Media Player after installation of Sony Pictures Digital software. After installing a Sony Pictures Digital application that hosts the MainConcept MPEG plugin, Windows Media Player stops playing back MPEG video encoded with third party software.

    ACID 3.0, ACID 4.0, Sound Forge XP Studio 5.0, Sound Forge Studio 6.0, Sound Forge 5.0, Sound Forge 6.0, VideoFactory 2.0c, Batch Converter 5.0b and Vegas Video 3.0 all install the MainConcept MPEG plugin. Even though this plugin may not be registered or unlocked, it can still be used as an MPEG2 DirectShow decoder by programs like Windows Media Player. Most of the time this works great, but with certain MPEG2 streams encoded with third party software (like VirtualDub or TMPGEnc) Windows Media Player may become unresponsive, or not play the audio and video streams in sync. Here are the steps to fix the problem:

    Find the files mcdsmpeg.ax and mcspmpeg.ax.
    Rename these files to mcdsmpeg.ax.hide and mcspmpeg.ax.hide.
    Reboot the PC and try playing back your media again.
  15. DrThorsen

    DrThorsen TS Rookie


    I had the same problem after installing Acid 4.0. Renaming the files resolved the issue. They are located in acid 4.0\shared plug-ins\file formats\mcmpeg. Thanks for the info.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...