Svchost.exe Hogging CPU. Again, can't fix it

By EXCellR8 ยท 12 replies
Sep 19, 2008
  1. So like usual nothing can just work like it's supposed to and I'm having problems with my new setup. The "svchost.exe" process is severely hampering the performance of my system by hogging as much as 60% CPU on all four cores! Last time this happened I reinstalled the nVidia Ethernet drivers which fixed the problem and everything was fine. Now, no matter what I do the process continues to hog res and is becoming quite the nuisance.

    I just recently uninstalled the nVidia Display drivers I was using in order to install my new Radeon card, which I haven't even been able to play with yet because of this nonsense. It seems that the problem all started when I turned the system on after the new card was installed. I've now reinstalled the chipset drivers which has also NOT solved the problem. I noticed that there is one Unknown Device (Location 65535 (Internal High Definition Audio Bus) in Device Manager again along with the new video card which I have not yet installed drivers for. I cannot stop the process from hogging res; I don't know what to do.

    The only other info I have on the "Unknown Device" is this below:

  2. EXCellR8

    EXCellR8 The Conservative Topic Starter Posts: 1,835

    Alright so I figured out what the "Unknown Device" was; I feel kinda retarded. I forgot that the 4870 features HDMI audio output and I never installed the appropriate drivers from the cdrom. Once they were installed, the Device Manager checked out clean; there is now an ATI audio device listed under Sound.

    So now, I have all of the appropriate drivers installed but for whatever reason the "svchost.exe" continues to hog CPU resources. It doesn't appear to be quite as hampering as before but it's still noticeable. I ran Process Explorer and the "wuauclt.exe" was listed under the offending process but I don't know how to go about fixing the problem. All I know about this EXE file is that it has something to do with Windows Automatic Updates. I tried disabling this feature but the process did not stop hogging res. If anyone has any information that could help me I would greatly appreciate the assistance. I'd really like to get this straightened out as soon as I can! Thanks in advance!

    [EDIT]: Just wanted to throw in some extra info that may relate to this problem, figured it might help anyone that's looking to help out... here are some of the more recent changes to my system.

    - Recently installed AVG Anti-Virus 8 (auto updates turned ON)*
    - Installed ATI Catalyst Control Center & 8.8 drivers
    - Installed RivaTuner 2.10
    - CPU cycles are not hogged in Safe Mode

    *could this, in any way, be affiliated with the "svchost.exe" or "wuauclt.exe" processes?
  3. EXCellR8

    EXCellR8 The Conservative Topic Starter Posts: 1,835

    Haven't made much progress but I have noticed a few things that are... not right. I've noticed that Control Panel takes an unreasonable amount of time to load up and I can't access the "Network Connections" without it freezing up on me. I've tried disabling auto updates on AVG which, among other things, did absolutely nothing. No matter what I do the "svchost.exe" SYSTEM process hogs 15-25% of CPU on all four cores. I'm officially out of things to try and now I'm thinking of just reinstalling Windows cuz I've just about had it with this.
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    well, what the heck is svchosts being used for?

    Sounds like you're using Task Manager? Use Process Explorer. Highlight the svchost process causing problems and right click Properties. See its startup arguments
  5. Rage_3K_Moiz

    Rage_3K_Moiz Sith Lord Posts: 5,443   +38

    It happens to me when I connect to the Internet and CPU usage hits 95%. I usually end the process without any problems. Maybe you need to disconnect from the Internet and see if it has any effect?
  6. HillJack

    HillJack TS Rookie Posts: 19

    If svchost.exe is eating CPU resources for an extended period, it's probably Windows automatic updates; the wuauclt.exe process is the Windows Update Automatic Update Client...

    I had this same problem and it drove me crazy. I fixed it by manually updating my WSUS 3.0 client -- download the updated client from the KB-link below and install it. Even if automatic updates doesn't show an update for it (which it probably won't), get and install it anyway. Also make note of the "you must install update 927891 and the new WSUS 3.0 client" part.

    Issue and instructions for fixing are here:
  7. EXCellR8

    EXCellR8 The Conservative Topic Starter Posts: 1,835

    I did use Process Explorer to try and figure out why svchost was running up CPU time. That's when I found that the wuaclt.exe was tied to the process but I didn't really see anything else. Where do I find the startup arguments?

    I recently disconnected from the internet and I noticed that the ethernet port on the back of my computer, on the mobo, was flashing rapidly. Even when I reconnected the cat cable it was still blinking. I had to power the system down completely to get it to stop... do you think this could have anything to do with it? I've installed the latest Ethernet drivers for the mobo.

    I will give that a try, thanks. As far as updates are concerned... there weren't any available from Microsoft Windows Update so I don't know if that has anything to do with Auto Updates enabled.

    EDIT: On second thought, it doesn't look like the article you posted applies to Windows XP Home Edition, just Pro...
  8. EXCellR8

    EXCellR8 The Conservative Topic Starter Posts: 1,835

    Alright this must be a network-related issue because I found that booting into Safe Mode without Networking does not produce the problem (no cpu is hogged by an svchost process). On the other hand, booting into Safe Mode WITH networking produced the problem and an svchost process hogged a stable 25% cpu on all four cores. I have made a few screenshots displaying exactly what I saw when in Safe Mode.

    Safe Mode without Networking - Image

    Safe Mode with Networking - Image
  9. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Rt click the pesky process and choose Properties. The command line shows how the full command (including startup args) that started it
  10. EXCellR8

    EXCellR8 The Conservative Topic Starter Posts: 1,835

    The problem still appears to be tied to the nVidia Ethernet driver. I uninstalled the current driver, disconnected my Ethernet connection from the motherboard port and the system was fine; the process did not hog any cpu after I restarted. I ran a spyware check just for kicks and the system turned up clear. I also ran Process Manager and found the startup args on the same process, though it was not hogging res at the time.

    Command Line read:
    C:\WINDOWS\system32\svchost.exe -k netsvcs... -seemed pretty normal to me

    On a side note that Windows Update Manger manual installation didn't work. I got a message stating that it was already installed... So I guess I will try reinstalling the older driver I originally had no issues with. I probably should have known that all my troubles were being caused by nVidia's shoddy driver programming.
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    1. I wasn't necessarily thinking of abnormal startup but rather
    - Being certain of whatever kind of startup it was (normal or otherwise)
    - Understanding what's running within the problem svchost.exe cuz one or more things in it are causing the CPU issue and good to narrow it to those things!

    2. If you do it's properties again, you can also click on the Services tab to see all the services running in that particular svchost. Consistent with suspecting a network driver you'll note various network services within that particular svchost process (you got to driver before i got you to get me to the services :) )

    3. Have you double checked your driver version (AND firmware level for adapter). This all sounds vaguely familiar but not for sure.
  12. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    btw.. and just fyi.. where i was trying via short route (but i think you got there the long route!)

    On Services tab for the svchost, note it lists the dlls for the service.

    Now click the Threads tab, then click the CSwitch column to numerical sort high->low. These are threads WITHIN the svchost process and you can see which threads are busiest and hopefully tie the thread address back to a particular service

    *** Edit ****
    This is like seeing the processes listed for computer (you're used to seeing). Now u're looking at a listing of the "threads" for a process (like zooming into sub-processes in the process)
  13. EXCellR8

    EXCellR8 The Conservative Topic Starter Posts: 1,835

    I have confirmed that the problem is directly related to the Ethernet driver because I booted up Windows normally and there are no svchost processes hogging any CPU :) I had the New Hardware dialog box appear on the desktop stating that drivers were needed for the oboard LAN so as far as the culprit goes, I'm 99.9% sure it's this. I guess I just need to reinstall the driver I wasn't having any issues with and hope everything works correctly after the restart. Anyways, thanks for the support and I will update the thread if I have any further problems.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...