System no longer works after Silverlight install

By wcroz99 ยท 20 replies
Feb 22, 2008
  1. Hi,

    I have a bit of a problem, and would really appreciate any help you can offer.

    I recently uninstalled Silverlight from my pc and shortly after my computer switched itself off. Since then i have spent about an hour and a half trying to restart my computer. The computer does not appear to be reading my hard drive. I eventually managed to successfully start my computer and i had the following message appear:

    GIANT Antispyware Data Service: gcasdtserv.exe- Corrupt file
    The File or directory \ProgramFiles\MicrosoftAntispyware/gsuserdata-gcd is corrupt and unreadable. Please run the Chkdsk utility.

    I then tried to scan my computer using my antispyware program, and my computer crashed and since then I havent been able to start my computer up again.

    Any advice on how I can fix this problem will be greatly appreciated.

    Thanks in advance
  2. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    I would first try booting into Safe mode by tapping F8 before windows tries to load. then select Safe Mode.

    Go to start -> control panel -> add/remove programs and see if you can remove silverlight and Microsoft Antispyware

    Close control panel

    Go to Start -> run -> type chkdsk /f

    *Note the space between chkdsk and /f
  3. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    When you say you aren't able to start your computer up again do you mean it won't even power up or that the Windows splash screen won't load?
  4. wcroz99

    wcroz99 TS Rookie Topic Starter

    Well basically i get to the blue screen where it says "windows is starting up" and then shortly after it crashes
  5. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    When you reboot immediately start pressing F8 to enter Safe Mode. Then follow BlindDragon's instructions step by step. Let us know if that works.
  6. wcroz99

    wcroz99 TS Rookie Topic Starter

    Thanks for the replies so far.

    I managed to start up my computer again this morning and also managed to completely remove both Silverlight and Microsoft Anitspyware, and the error message disappeared. I then uninstalled another program which then prompted me restart the computer, I did this but once again my computer crashed at the blue screen, where it says 'windows is starting up...'. Since then I havent managed to start my computer and it keeps crashing at the same point. Obviously there is still a problem with my pc, and any advice on what the problem might be will be greatly appreciated.
  7. wcroz99

    wcroz99 TS Rookie Topic Starter

    Some additional information which may or may not help or be relevant:

    When first switching on my computer it searches for 'IDE Devices' of which 'none' are found

    I have tried starting up XP using the cd and using safe mode, but whenever I press F8 or use the up and down keys to navigate using the CD, nothing happens. So im not sure if it recognises my keyboard. Although on a couple of startups I have got as far as typing in my password, pressing enter then the computer freezes, so it seems a bit hit and miss as to whether or not it recognises my keyboard.
  8. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    What other program did you remove? IDE drives are things like your harddrive. It isn't reading your harddrive.
  9. wcroz99

    wcroz99 TS Rookie Topic Starter

    Adobe Photoshop was the other program I removed
  10. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Actually this no keyboard reponse or system lockup, can be a sign of faulty Ram (this can also be a CPU overheating fault)
    It may be a good idea to run Memtest on your Ram.

    Also when you did get to Safe mode before, did you end up doing the checkdisk command ?
  11. wcroz99

    wcroz99 TS Rookie Topic Starter

    Yes I did manage to do the checkdisk command, well at least i think so. I typed it in as instructed above, and a black box appeared and then disappeared quickly after.
  12. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    A few things -> you may need an old ps/2 keyboard or a ps/2 to usb adapter when using the recovery console through your XP CD

    If you can get back to windows in safe mode. -> Go to start -> all programs -> accessories -> command prompt -> try typing chkdsk /f
  13. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    No not done!

    Actually the real issue was that:
    Go to Start -> run -> type chkdsk /f
    Should have read:
    Go to Start -> run ->CMD then type chkdsk /f on the command line.

    Oh well, mind you the system froze on startup, so it probably wouldn't have done it anyway.

    But just in case try: Safe Mode Command Prompt (from the F8 startup again)
    And then on the command line type:
    chkdsk /f

    Wow spooky, posted at the same time
  14. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    yea I can't believe nobody caught that before
  15. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Good point I posted after your original post too, so I'm just to blame.

    Anyway the XP CD boot to recovery console select 1 (by hitting 1 on the keyboard) and then enter (to get into the Safe mode Administrator account recovery console (that's a mouth full)
    And then doing the chkdsk /f is looking good.

    Memtest after that (if it still fails)
  16. wcroz99

    wcroz99 TS Rookie Topic Starter

    Thanks for all your help.

    Well im managing to get to the screen where you need to select safe mode but it wont let me use the arrow keys to select safe mode. Suppose I will just have to keep restarting the computer and hoping that I can get in using safe mode.

    How exactly do I perform a memtest?
  17. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Forget all the restarts, chkdsk probably won't even run

    Go here: and download Memtest ISO and then use your burning program (I use Nero) to burn the bootable disc.
    Then boot off it.
  18. wcroz99

    wcroz99 TS Rookie Topic Starter

    Have managed to start the computer today, and tried to run the check disk utility, but this message appeared:

    The type of the file system is RAW
    Cannot lock current drive
    CHKDSK is not available for RAW drives

    Any advise on what i need to do now?
  19. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    We have found the reason for the restarts!

    Raw: The volume filesystem type information is unavailable
    Simple terms
    This means that the partition is not recognized any longer by Windows
    Simpler Terms
    Windows requires a new clean install (with new partition)
    Even Simpler Terms
    The entire of Windows and all your data is lost !

    What to do?

    Well, you can just put the Windows CD in and start a new install
    You will also need to select remove the old partition(s) first

    What about all your data?

    Hmm, that one gets a bit tricky. You will need to mount your Hard Drive in another machine as Slave, then use a recovery tool, like Zar (but there are many) To recover all your data (Documents; pics so forth) This must be done, before deciding to Install Windows (and the partition) clean !

    What do I mean?

    If you are unsure of how to proceed, regarding recovery of data you may need to contact a computer professional, to help you.

    Or just put the Windows CD in and remove the partition, and all your data, and continue on.

    Your Reply?
  20. wcroz99

    wcroz99 TS Rookie Topic Starter

    Thanks for the reply kimsland. Well i had pretty much come to the conclusion that I would have to reinstall windows, its very frustrating really.

    Will save all my important documents to my USB stick so wont bother with trying to save whats on the hard drive, but how do I go about removing the partition?

    Just out of interest is there any reason why this has happened, could it be a virus of some sort?

    Also I forgot to mention that I got this error message upon upstarting windows:

    Corrupt File: The file or directory \windows\prefetch\mmtask.exe- is corrupt and unreadable. Please run the Chkdsk utility.

  21. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Could actually have been ( or still is) a physical harddrive issue.
    There are many drive diagnostic utilities HERE
    Just select the one that matches your harddrive (you may need to read the cover on the harddrive itself.

    This can also happen when you upgrad Windows and your system cracks a wobbly (why, no one knows - maybe it was not set up with the correct cluster size originally)

    As there may be many reasons (including virus/malware) it may be better to just continue on.

    When you first put the Windows Xp CD in and boot from it, it will first load all the Windows drivers to start the setup.
    It will then display a screen to start Windows setup
    It will ask you to Repair or do a fresh install...
    At this point, reading the screen, you will be able to select your old partitions and select remove (followed by some Delete L Yes OK type prompts)
    Once all partitions are removed, you can continue loading Windows (ie you do not need to manually create the partition (Windows setup does that)
    Follow the screen prompts from there.
    Also confirm your language settings (usually adjusted in 3 places) during the install.

    Once Windows is fully set up (half an hour)
    You will need to load all your motherboard drivers (either by your motherboard CD, or ideally downloaded updated drivers from the web)
    At last you may be able to reply back on your own machine.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...