The computer has rebooted from a bugcheck. The bugcheck was: 0x100000d1

By shawns122 · 16 replies
Jan 28, 2006
  1. Hi all,

    I've been having quite a problem with my computer rebooting itself ever since I built it from the ground up. It doesn't reboot often, but at least once a day. No hardware errors that I see in the event systems log. I've done a memtest86+ on my ram - no errors found. I've re-seated the RAM as well. Case is clean, no dust currently. I've checked the device manager to ensure that all the drivers are installed properly. I've attached a some dump files for anyone who knows how to read these. Can someone please look into helping me find what's wrong? I'm running the following:

    Windows XP SP2
    Intel Pentium D: 830 3.0 GHz
    2x 512 MB OCZ RAM modules
    256MB ATI Radeon X850XT (PCI Express)
    Maxtor 200GB SATA
    Sound Blaster Audigy Gamer PCI
    P5N32-SLI Deluxe ASUS Motherboard
    16x Emprex DVD+-RW
    1.44 MB Floppy Disk Drive



    Attached Files:

  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    2 minidumps crash with memory corruption. They have bugchecks of D1, and 0A respectively.

    1 minidump crashes at ati2cqag.dll. Video card drivers. It has a bugcheck of 8E.

    1 minidump crashes at ntkrpamp.exe. Windows nt and kernel system file. It has a bugcheck of 7F.


    The system attempted to access pageable memory using a kernel process IRQL that was too high. The most typical cause is a bad device driver (one that uses improper addresses). It can also be caused by caused by faulty or mismatched RAM, or a damaged pagefile.

    0x0000000A: IRQL_NOT_LESS_OR_EQUAL

    Typically due to a bad driver, or faulty or incompatible hardware or software. Technically, this error condition means that a kernel-mode process or driver tried to access a memory location to which it did not have permission, or at a kernel Interrupt ReQuest Level (IRQL) that was too high. (A kernel-mode process can access only other processes that have an IRQL lower than, or equal to, its own.)


    A kernel mode program generated an exception which the error handler didn’t catch. These are nearly always hardware compatibility issues (which sometimes means a driver issue or a need for a BIOS upgrade).


    One of three types of problems occurred in kernel-mode: (1) Hardware failures. (2) Software problems. (3) A bound trap (i.e., a condition that the kernel is not allowed to have or intercept). Hardware failures are the most common cause (many dozen KB articles exist for this error referencing specific hardware failures) and, of these, memory hardware failures are the most common.

    It looks like you have a ram problem.

    Please be aware that some faulty ram can pass Memtest86+.

    Try running your system with just one stick of ram.

    Make sure your ram is compatible with your mobo.

    Try putting your ram into a different dimm slot.

    Update your video card drivers.

    Regards Howard :wave: :wave:
  3. shawns122

    shawns122 TS Rookie Topic Starter

    Thanks for your assistance Howard!

    You hit the mark on this! I've updated my video card drivers and took a close look at the RAM. I re-seated a RAM module in a different DIMM slot in channel A - next to the other - instead of channel B. No reboots so far after a good day of intense stress testing.

    Thanks again!

  4. freddy

    freddy TS Rookie

    Same error , help needed

    Hi ,
    i have the same problem as shawn. The events log give me this : The computer has rebooted from a bugcheck. The bugcheck was: 0x100000d1 (0x00000134, 0x00000002, 0x00000001, 0xf8678d9b). A dump was saved in: C:\WINDOWS\Minidump\Mini052706-03.dmp.

    Can someone help me with this? thanks.

    Attached Files:

  5. shawns122

    shawns122 TS Rookie Topic Starter

    Minidump Analyze

    Hi Freddy,

    I checked this out on my own. I became interested in analyzing dump files after I experienced my own crashes. The crash points to a wanarp.sys. In red, I've highlited the probable cause, which faults around a driver for this device. The possible fix might be to upgrade the drivers for this device, which is probably a network device such as a NIC card (from what I can see here). I would almost pinpoint this to a NIC card because the description of wanarp reads: "MS Remote Access and Routing ARP Driver." ARP stands for address resolution protocol. So when you encounter something like a "Routing ARP Driver," you can almost guarantee this is related to a network/NIC card problem. The information for the wanarp is also below. You might also get some others to analyze this and elaborate/add to what I've found.

    All the best,


    An attempt was made to access a pageable (or completely invalid) address at an
    interrupt request level (IRQL) that is too high. This is usually
    caused by drivers using improper addresses.
    If kernel debugger is available get stack backtrace.
    Arg1: 00000134, memory referenced
    Arg2: 00000002, IRQL
    Arg3: 00000001, value 0 = read operation, 1 = write operation
    Arg4: f8678d9b, address which referenced memory

    Debugging Details:

    WRITE_ADDRESS: 00000134


    f8678d9b ff4610 inc dword ptr [esi+0x10]



    LAST_CONTROL_TRANSFER: from f867c824 to f8678d9b

    80548af8 f867c824 f867cf80 02cb8124 00000001 wanarp!FreeBufferToPoolEx+0x31
    80548b20 b81763e5 00000000 81d33b38 00000000 wanarp!WanNdisSendComplete+0x3e
    WARNING: Stack unwind information not available. Following frames may be wrong.
    80548b40 b8176418 00000000 00000000 0000002f tm_cfw+0x193e5
    80548b54 b8194e51 828c8528 b81882a0 825ae188 tm_cfw+0x19418
    80548c20 b8196194 8263c128 825ae008 b81961f2 tm_cfw+0x37e51
    80548c38 b818c4e1 825ae008 2e323232 2e313131 tm_cfw+0x39194
    80548cc8 b818c772 827766f8 80548ce4 b81882b7 tm_cfw+0x2f4e1
    80548cd4 b81882b7 825ae008 80548d0c 80548e00 tm_cfw+0x2f772
    80548ce4 804ff234 82776720 827766f8 01957988 tm_cfw+0x2b2b7
    80548e00 804ff34b 80551b80 80551920 ffdff000 nt!KiTimerListExpire+0x122
    80548e2c 80540d5d 80551f80 00000000 0004cbb7 nt!KiTimerExpiration+0xaf
    80548e50 80540cd6 00000000 0000000e 00000000 nt!KiRetireDpcList+0x46
    80548e54 00000000 0000000e 00000000 00000000 nt!KiIdleLoop+0x26

    STACK_COMMAND: .bugcheck ; kb

    f8678d9b ff4610 inc dword ptr [esi+0x10]



    FOLLOWUP_NAME: MachineOwner

    SYMBOL_NAME: wanarp!FreeBufferToPoolEx+31

    MODULE_NAME: wanarp

    IMAGE_NAME: wanarp.sys


    FAILURE_BUCKET_ID: 0xD1_W_wanarp!FreeBufferToPoolEx+31

    BUCKET_ID: 0xD1_W_wanarp!FreeBufferToPoolEx+31

    Followup: MachineOwner

    f8677000 f867f700 wanarp (pdb symbols) c:\symbols\wanarp.pdb\FDB397B5509448699BDFDF4E2214A5D61\wanarp.pdb
    Loaded symbol image file: wanarp.sys
    Mapped memory image file: c:\symbols\wanarp.sys\41107C898700\wanarp.sys
    Image path: wanarp.sys
    Image name: wanarp.sys
    Timestamp: Tue Aug 03 23:04:57 2004 (41107C89)
    CheckSum: 0000EFA7
    ImageSize: 00008700
    File version: 5.1.2600.2180
    Product version: 5.1.2600.2180
    File flags: 0 (Mask 3F)
    File OS: 40004 NT Win32
    File type: 3.6 Driver
    File date: 00000000.00000000
    Translations: 0409.04b0
    CompanyName: Microsoft Corporation
    ProductName: Microsoft® Windows® Operating System
    InternalName: WANARP.SYS
    OriginalFilename: WANARP.SYS
    ProductVersion: 5.1.2600.2180
    FileVersion: 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)
    FileDescription: MS Remote Access and Routing ARP Driver
    LegalCopyright: © Microsoft Corporation. All rights reserved.
  6. freddy

    freddy TS Rookie

    Thanks alot for your help shawn . Updated the drivers but i still get the same error =(
  7. altheman

    altheman TS Rookie Posts: 425

    the named driver is part of Windows "Routing and Remote Access" service. if you don't use this, then disable this service via "Run"->services.msc->find service and disable it, and see if the problems stop.
    make sure your windows is up to date via windows update service.
  8. freddy

    freddy TS Rookie

    yup. my windows is updated and "Routing and Remote Access" is disabled when i
    had this error
  9. allsigns

    allsigns TS Rookie Posts: 36

    Hi freddy

    did ya resolve this problem? im having a similer problem
  10. xsboredom

    xsboredom TS Rookie

    hey im new to techspot and i was wondering if u guys can provide some assistnace for me... for that past couple of days ive been getting BSODs with IRQL_NOT_LESS_OR_EQUAL and the stop code is like STOP: 0x0000000A(0x00000004, 0x00000002, 0x00000001, 0xC04ED24E) i think. i cant really read my hand writing. ive already posted my dmp in
    and it wont let me upload again. sorry =\
  11. freddy

    freddy TS Rookie

    i still get it but not as often. updating the network adapter driver helps i think =\
  12. Tarkus

    Tarkus TechSpot Ambassador Posts: 621

  13. bhupalan

    bhupalan TS Rookie

    hi all,
    i am facing this new problem of machine rebooting at least once in 2 or 3 days.
    Earlier i formatted my machine which had windows 2000 in it and later installed the WinXP OS using Ghost software. The newly installed WindowsXP is causing reboot problems. I am finding hard to locate the problems in it. below is the log which i took it from the "event manager".

    The computer has rebooted from a bugcheck. The bugcheck was: 0x1000000a (0x00000004, 0x00000002, 0x00000001, 0x804dc65b). A dump was saved in: C:\WINDOWS\Minidump\Mini080806-02.dmp.
    For more information, see Help and Support Center at

    I will be satisfied if i know which part is creating problem in my machine...
    Thanks in Advance
  14. zhougu

    zhougu TS Rookie

    my computer reboots by itself randomly

    Hi all,

    I am facing a similar problem on my PC installed Windows XP that will reboot one or two times a day. It happens most of time while I am closing the internet browser. I got the error message box after it rebooted as following:

    Error Report Content:
    C:\Documents and Settings\Joe\LocalSettings\Temp\WER19.tmp.dir00\sysdata.xml

    Error message:
    BCCode: d1 BCP1: F8184F59 BCP2: 00000002 BCP3: 00000000
    BCP4: F8184F59 OSVer: 5_1_2600 SP: 0_0 product: 256_1

    I used to believe that there is something wrong with my internet explorer. Therefore, I switch to Mozilla Firefox. I still have the same reboot issue, but I get no more error message after my computer rebooted. I also re-seated a RAM module in a different DIMM slot. The problem still happens. My computer is WindowsXP and can't update. The reboot problem just happened since last three months. I haven't set system restore before that.

    I am so annoyed by my computer's reboot. Everyone's help will be so appreciated.

    Thank you very much in advance!

  15. HelpAppreciated

    HelpAppreciated TS Rookie

    Random Reboots : The bugcheck was: 0x0000009c

    Hi Folks,

    Having the same scenario and its driving me crazy, random reboots once every day or two and application hangs and freezeouts to add to my misery. Last reboot left me the following message. I attach the dump file also.

    "The computer has rebooted from a bugcheck. The bugcheck was: 0x0000009c (0x00000000, 0x8054d370, 0xa2000000, 0x84010400). A dump was saved in: C:\WINDOWS\Minidump\Mini030907-01.dmp."

    All help very gratefully received.
  16. mms

    mms TS Rookie

    help! help ! please -system reboots abruptly

    Hi everybody,

    I have purchased a new emachines system. Just after 10 days of purchase, my system starts rebooting abruptly. The latest error code given today is "error Code 1000008e, parameter1 c0000005, parameter 2 407ff7c5 parameter 3 eb57dcb8 parameter 4 00000000". I tried contacting emachines also. But their solutions like run sfc /scannow does not work at all. Can anybody help me analyse the dumps and solve the problem? I am attaching the dump files for the last ten days.

    View attachment

    View attachment 14535

    View attachment 14536
  17. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    HelpAppreciated and mms.

    Go and read this thread HERE and see if it helps.

    If it doesn`t, please start new threads for your problems in our Windows OS forum. Thanks.

    Thread closed.

    Regards Howard :wave: :wave:
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...