1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Ubuntu dualbooted with windows (USB error)

By prashik ยท 4 replies
May 9, 2017
Post New Reply
  1. Recently I installed some apps and deleted some drivers in ubuntu (as I wanted to troubleshoot some other problems) and after shifting to windows, my USB device is showing - {A driver (service) for this device has been disabled. An alternate driver may be providing this functionality. (Code 32) } this error message. I have tried these 3 steps which I found on the web but none of them worked. 1. Deleting the upperfilter and lower-filter values in the registry key. 2. Uninstalling the USB mass storage device drivers from device manager and rebooting. 3. Installed new drivers for USB 3.0
     
  2. prashik

    prashik TS Rookie Topic Starter

    Please suggest some solution for this problem.
     
  3. Cycloid Torus

    Cycloid Torus TS Evangelist Posts: 2,541   +473

    I'll take a stab at it..just opinion...first, the dual boot in ubuntu..you changed things there, but that should only stick to ubuntu operations since you wouldn't be changing windows files. Then you rebooted into windows and discovered a driver issue with your USB mounted external HDD. You changed things in registry... then you tried some other things which might get you proper drivers.

    Thorough article with many ideas: https://www.lifewire.com/how-to-fix-code-32-errors-2619236

    In my own experience, removing (yes, remove - not update) all USB devices includes those which are 'hidden' - be sure to un-hide using the the View tab in Device Manager. Windows is kind of stupid about this and needs to be served a colonic.
     
  4. prashik

    prashik TS Rookie Topic Starter

    Thank you for your precious time, in the link you suggested, I found that the actual problem is in the registry key, my laptop shows the start type as 0x00000004(which assures that my problem would be solved if I change the value) but when I tried to modify that(I read that the value must be changed to 0x00000001 for usb devices ), it modifies but after refreshing the registry editor, the same value I.e. 0x00000004 is shown in the start type. I read in some forums,
    "Note: You can not rename registry hives, the top-level keys in the Windows Registry." is that the case.
     
  5. Cycloid Torus

    Cycloid Torus TS Evangelist Posts: 2,541   +473

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...