Unacceptably high disk usage/performance lag Windows 8

By SNGX1275 · 91 replies
Feb 28, 2013
Post New Reply
  1. MtHarrySuze

    MtHarrySuze TS Rookie

    That's an interesting take too Darth Shiv because about a week before I had the problem I installed BioShock Inifinite for a bit of a play. That's a very large game 16GB. It wasn't a simple link between playing the game and experiencing the problem as the problem was present in regular usage, in fact the problem only occurred in regular usage but still "somewhat" coincidental given Darths insights. Who knows what these "optimizers" are actually "optimizing"..... if they get the profiling even slightly wrong it may have significant effect. And for about 2-3 days I guess my usage patterns would have differed quite dramatically while I played in spare time.

    Then 3-4 days later I had problems. Probably nothing. possibly something.

    Will also note that the disk in this machine is a seagate hybrid with small SSD and larger magnetic drive.
  2. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,742   +418

    After further consideration, I am certain superfetch is not the cause of my problem that inspired this thread. Go back to look at my screenshots throughout the early stages of this thread. Superfetch wouldn't do that.
  3. MtHarrySuze

    MtHarrySuze TS Rookie

    I'm not certain either way but I had the same graphs as yourself. 100% disk usage in blocks for as long as I cared to look at it. Topped out in green all the way. CPU only usage 10-15%.

    I could only copy files from one disk to another at 100KB/s because of that (was doing this to try and back up before I played around trying to figure the problem out).

    I discovered Superfetch by clicking on the Open Resource Monitor link at the bottom of your first graphic then looking at processes with disk activity. None of them had anything like the kinds of numbers beside them (as per another post) you'd expect to see in order to cause 100% disk usage.

    So I just moved through them killing them off one by one, wait and see. After I had killed off all my user processes, still at 100% I begin to look into System processes. One of the system processes was a parent process for multiple child processes, one of which was superfetch. It wasn't until I killed Superfetch off that all disk activity fell away.

    Since it's been disabled I haven't the problem but whether symptom or cause I dunno.
  4. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,742   +418

    I could copy at 10 megs a sec, so far faster than you were, yet still way under what it should be. I could also get a few to 5 second 'burst' at normal speeds before they'd drop down to 10.

    Maybe I'm wrong and it is related. But I just can't fathom how superfetch, which deals with pre-loading programs into RAM has anything to do with sustained HD transfer speed.
  5. Darth Shiv

    Darth Shiv TS Evangelist Posts: 1,797   +459

    To load things into RAM, it loads them from the HDD. Since it speculatively loads things, and I imagine many of them, they are likely to be scattered around your HDD. What is a HDD not good at? Random seek. So if Superfetch is caching when you are trying to do anything HDD intensive, it could reduce HDD speeds to the order of 4K random read/write speeds.

    Having said that, that is theoretical...
  6. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,742   +418

    I know what you are saying dude, I understand how it works, at least enough to be able to comment on it. With Superfetch though, that preloads programs you frequently load into RAM, in the background. Once it is satisfied with what is there, and you aren't opening and closing anything, it is done loading. Big transfers could be initiated at any time after boot, many times I did this after having the computer on overnight and doing nothing, and then starting a transfer - a steady 10meg a sec transfer is not consistent with how a superfetch loading programs into RAM would behave, the transfer would be much more variable in speed.
  7. dgarciad

    dgarciad TS Rookie

    Dear all

    I have been suffering the same problem on my acer aspireone 725.

    I have reinstalled the latest version of the bios firmware (v. 2.12, from the acer support webpage), even though I think it was the same version that was already installed in the system.

    And it seems to be fine now.

    Hope it helps

    Best regards
  8. jobeard

    jobeard TS Ambassador Posts: 10,840   +896

    this is far more likely to be the cause as it runs with every program launched and against every DLL loaded.

    Superfetch is a caching mechanism and the whole purpose of a cache is to improve performance.

    I take the approach that if my A/V is good enough to purify email and block bad web links, then SpywareBlaster will block bad ActiveX and the firewall stops direct attacks, a monthly HD scan is sufficent to ensure my programs are still sanitary - - thus NO need for real-time scanning on every launch.

    Oh yeah, worth mentioning, I never login using an admin login so that system files can't be attacked (easily at least).

    Just my $0.02
  9. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,742   +418

    ^ That wasn't the problem in my case. File transfers would begin initially as fast as they can reasonably be expected to be (on par with the slowest HD's read or write speed), and then after several seconds the speed would drop off, then maintain the ~10MB/sec.
  10. jobeard

    jobeard TS Ambassador Posts: 10,840   +896

    :grin: then clearly it wasn't either :0
  11. May not help, but it certainly won't hurt.
    Google (or whatever) "Intel Driver Update Utility" It checks all Intel drivers on your system, thinking chipset drivers might be important if they are not latest
    Your mileage may vary.
  12. Darth Shiv

    Darth Shiv TS Evangelist Posts: 1,797   +459

    The intel driver update utility is a useless piece of junk. It won't report out of date versions if your current version is considered "stable" but is missing features like TRIM on RAID.
  13. Does Intel have that? For instance I have an Asus Maximus IV Extreme-Z mobo. Intel Z68 chipset. Extra 2 sata ports use a Marvell 9182 controller while raid options are provided by a JMicron 362 controller. My USB 3.0 controllers are also NEC. So if it isn't Intel, it's not going to be updated. But it does update chipset, processor, and my lan drivers as they are all Intel. But as I said your mileage may vary. Useless piece of junk seems a little strong statement.
  14. Darth Shiv

    Darth Shiv TS Evangelist Posts: 1,797   +459

    Yes sorry the SSD support in drivers from Intel has had a lot of problems. And they redesigned the download page to make it more difficult to get to the latest chipset drivers and the auto-detect utility then doesn't link you to the latest drivers. So I find the end user experience, as an SSD user, as "rubbish"!

    Intel also disable TRIM on RAID on older chipsets when they have the exact same SATA controller on many of the older boards. TRIM on RAID-1 is trivial. TRIM on RAID-0 is next to trivial. I could go on but I think my frustration with it is clear.
    Raoul Duke likes this.
  15. Thank you for the info., never can learn too much.
  16. Darth Shiv

    Darth Shiv TS Evangelist Posts: 1,797   +459

    Yeah pace of change in IT is just relentless. Turn around and everything has changed. Hope AMD makes a bit of a come-back in this space to up the pace of innovation in some areas like SATA. SATA Express, which would have been handy 2 years ago when SandForce-based SSDs were saturating SATA 3, is not due until the end of 2015 on Intel platforms!
  17. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,742   +418

    I did check for chipset drivers and I think I did something along that route.. If I did it, it is noted earlier in the thread, I tried to be as meticulous as possible in troubleshooting this problem, but I know I didn't do everything perfect.

    How bad is it of me to be considering re-attempting with 8.1 on the same hardware :D
  18. trananh239

    trananh239 TS Rookie

    I have the exact same problem with you.
  19. Diogo Barreto

    Diogo Barreto TS Rookie

    Thank you so much, I had been experiencing the same problem for ages and that finally did it! Even registered just to be able to thank you.
  20. chorong761

    chorong761 TS Rookie

    I have experienced this problem before. It is due to the page file. To solve this, turn page file off for all drives.
  21. tipstir

    tipstir TS Ambassador Posts: 2,426   +112

    Can't turn off the page file, the system requires it memory can fill up then you have issue. VRM is still required with RRM. Memory needs to swap with the HD. I had ran a movie and the metro movie app locked. I use VLC issue gone.
  22. FernandoGomesPT

    FernandoGomesPT TS Rookie


    I've been hving this problem in one of of servers. Server 2012, so it fits this "Windows 8 bug" theory.
    Beeing an old entry level server, it makes use of intel's onboard ICH7 controller. It is set up as AHCI, and recently I noticed that any relevent file access would bring the server to a desperating crawl.

    Symptoms: I want to copy some 30 large files, total amount around 500GB. Copying between two pysicals drives, 3 TB WD "RED Nas" series. Decent drivers, I presume.
    When file copy starts, I get the expected performance (around 120MB/sec and ~20% cpu usage), then after a few seconds havoc wreaks: performance drops to 9 or 10 MB/s, CPU at around 100%, and all in all an unusable server while the file copy is running.
    This is a Quad Core Xeon at 2.4Ghz (Core 2 generation), mind you! 100% cpu usage during a simple file copy between two fast local hard drives is unacceptable, IMO.
    Then I noticed that anytime I paused the copy, when resuming, I'd get yet again decent performance for some 10 secs, and then hell brakes loose again.

    Based on this weird sympton, I thought "what if I removed Windows Explorer out of the equation".
    So I tried using xcopy, copy and move from CMD. CPU usage is a bit lower (~70%), while transfer speed hovers around 40MB/s (as per Resource Monitor).

    So while xcopy is not as fast (it only uses one CPU thread, for starters, maybe there's something more to it that keeps file copying well under the theoretical maximum speed), it is much more coherent.

    I've tried both AHCI and compatible mode in BIOS settings, no distuinguishable difference whatsoever.

    I've just ordered an used 3ware 9650SE controller (30£ off eBay), so I'll be able to tell you whether using a true HW controller makes for a more reliable hdd usage. Right now, I'm guessing that either driver or OS related issues keep this old ICH7 chipset from achieving acceptable speeds on this recent OS.
    SNGX1275 likes this.
  23. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,742   +418

    I don't have 8 anymore. Can you try to kill Superfetch like above posters mentioned for fixing their issues? I didn't have the opportunity to do that because those posts came after I had already given up.
  24. FernandoGomesPT

    FernandoGomesPT TS Rookie

    Well, instead of just waiting for the controllers to arrive, I just went ahead and rebuilt the server. This time I built it with Server 2008R2 instead of Server 2012.

    CPU usage is now completely normal (a bit higher than what I'd like, but nowhere close to 100%), and transfer rates are now sustained at 100MB/s for the entire filecopy.

    This is my production backup server, and backup times now take less than a third of the time to complete. This means that I can now have incremental backups running during lunch time, which is critical for me.

    I will miss Server 2012, I really will, it is a server system that grows on you, and coming back to 2008r2 everything feels outdated. Managing is harder, I won't have deduplication on my backup repository (meaning I'll have to purchase a couple of hdds to ensure designed retention policy), but all in all I just couldn't cope with the unreasonable cpu overhead created by each and every file access.

    I still have the 2012 build stored in a separate hdd, and I will give it a chance once the controllers arrive.

    I'll keep this thread posted, but for now all I can tell is that something in 2012 (possible win 8 aswell) gets broken after a while and hdd access begins to cost an unbearable amount of cpu resources.
  25. BRAD3TH

    BRAD3TH TS Rookie

    Hello there, perhaps try setting your CPU to 'sync all cores' in UEFI if it isn't set that way already. It should stop your PC from dragging it's feet.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...