1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Upgrading BIOS on ASUS A7V8X

By JonB · 8 replies
Sep 12, 2008
  1. Hi,

    This is my daughters machine.

    Prob: no sound coming from onboard outlet. (speakers fine).

    Bios installed is v.1007 (most recent version available, according to ASUS website is ' Beta Version 1015.003' .. bit concerned with the words 'Beta version', so maybe i should upgrade with 2nd most recent version, namely 'Version 1014'?

    It appears that 'version 1013' "Fixed audio/modem codec ID problem" ! but unsure if this will resolve the sound issue i have. Anyway, it may be good to get the latest version anyway and possible just try and get the correct driver - nb no sound drivers are shown at all to be installed!?

    Q2. Back to the BIOS upgrading. ASUS website's inx do not seem to be compatible with XP, ie saying create a bootable system floppy (without config and autoexec) + AFLASH.exe software + boot.ini + the BIOS upgrade.
    My problem/confusion is not with the software or bios upgrade version on the floppy, but with the boot.ini and the type of 'boot files' i should have on the floppy, in order to get to the aflash menu option and not straight into win xp (as seems to happen).

    Be grateful for your help

  2. kimsland

    kimsland Ex-TechSpotter Posts: 13,810

    The command.com is the boot part
    The autoexec.bat and config.sys files are for autoloading drivers and commands (not required)

    Quote from here: http://support.asus.com/technicaldocuments/technicaldocuments.aspx?root=198&SLanguage=en-us
    Here's your Drivers page (and bios too) again: http://support.asus.com/download/download.aspx?modelname=A7V8X&SLanguage=en-us

    Or use this way (preferred, in case you have mx and you don't know it)
    Please press the green button, and select your drivers

    Sorry, it seems you must do this twice, once here, then when you get to Asus support, click it again. This button uses JavaScript (which is enabled by default on most browsers)
  3. JonB

    JonB TS Rookie Topic Starter

    Cheers Kimsland,

    only just seen your reply, but many thanks anyway.

    BIOS updated successfully whey hey first BIOS update, so that's good. Simply created MSDOS Start up FLOPPY disk from my XP home PC. Removed the autoexec and config files. Added the new BIOS file + the flash utility. loaded up to a: when inserted the floppy and thus ran the flash utility from there. had bit of trouble saving the existing bios (ie just in case it went wrong), but then simply inserted another floppy saved it on that and quickly put the 'boot floppy' back in before proceeding.
    All done in 5 mins.

    But has it solved the sound issue, has it heck!

    Still, at least the mobo can now take an AMD 2700!

    ***** Re ASUS website for driver - i have logged an issue with them as after downloading from 'global site' option, clicking on the unzipped application file: 'Soundman' does absolutely nothing! so, i'm going to try and get the package from their other site option in 'China'! ***
  4. CCT

    CCT TS Evangelist Posts: 2,610   +6

  5. kimsland

    kimsland Ex-TechSpotter Posts: 13,810

  6. JonB

    JonB TS Rookie Topic Starter

    Think i'm losing the plot erm!!!!! (prob already have)...

    of course nothing happens when clicking on the 'soundman' appl file. doh!

    I simply had to read the 'setup info files' and copy the following files per unzipped download;

    1/SYSTEM file for 'Avance AC'97 Audio driver (WDM)' into windows\system32\drivers
    2/WAV AUDIO File into windows
    3/SOUNDMAN for 'Avance Sound Manager' into windows\system32

    But, alas still no joy and not showing any sound devices as would be expected? in device manager? the problem obviously lies elswhere?
  7. kimsland

    kimsland Ex-TechSpotter Posts: 13,810

    1. Uninstall the drivers from Add/Remove programs in the Control Panel of Windows.
    2. Restart the computer.
    3. Run Driver Sweeper*, select the drivers that you have uninstalled and click Clean button.
    4. Install the new drivers.

    * For Windows Vista users, please run Driver Sweeper in administrator mode.
    Right mouse click Driver Sweeper shortcut and click Run as administrator.

    To download and install Driver Sweeper, please click HERE. (direct link)
    Save DriverSweeper_1.5.5-setup-[Guru3D.com].exe file on the hard disk.
    Run DriverSweeper_1.5.5-setup-[Guru3D.com].exe.
  8. JonB

    JonB TS Rookie Topic Starter

    Thanks, but went into Add/Remove programs and guess what there are no programs installed except Win XP Pro!

    Reason...quite simply as it's a re formatted HDD drive with another instance (diff copy) of win xp.

    I still have the old hdd that would have been working with this mobo, so its prob best to copy certain files over - not having the install disks ie for mobo etc doesn't help!

    Do you think its just as simple as copying over whats in the drivers folder in sys32?
  9. Tedster

    Tedster Techspot old timer..... Posts: 5,746   +14

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...