1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

USB device not recognized + unknown device

By ledaniels · 17 replies
Nov 18, 2005
  1. I have a Dell notebook, with what I believe is a USB 1.1 port on it. I recently bought a Microsoft wireless notebook optical mouse. There is no installation CD with it, you are just supposed to plug it in and it should work. Well when I do that, I get an error comes up saying USB device not recognized. When I look at the properties it says "no drivers are installed for this device", and I have the device usage as enabled. I've tried updating the driver and it says I have the most recent updates installed. It comes up as an unknown device as well.

    Other things like my printer work in this USB port, so I don't think the port itself is defective. I also plugged the mouse into another computer and it works with no problems. I am running on XP with SP2 installed.

    The product specs say it should work on USB 1.1 or 2.0, so I don't think that is the problem either. Any ideas? I've gone through all of the troubleshooting with no luck.
  2. iss

    iss TechSpot Chancellor Posts: 1,994

  3. ledaniels

    ledaniels TS Rookie Topic Starter

    I already tried installing Intellipoint, just forgot to mention...still no luck. Any other ideas?
  4. iss

    iss TechSpot Chancellor Posts: 1,994

    are you plugging in the mouse AFTER the computr is booted? have you tried booting up with the device allready plugged in?
  5. ledaniels

    ledaniels TS Rookie Topic Starter

    Yes, I've tried restarting with and without it plugged in...still no luck.
  6. iss

    iss TechSpot Chancellor Posts: 1,994

    Ok is this being plugged in directly to the laptop usb port or thru a usb hub?
  7. ledaniels

    ledaniels TS Rookie Topic Starter

    I have only one USB port on my laptop, and it is plugged directly into it. It just doesn't make sense b/c things like my printer works through it.
  8. iss

    iss TechSpot Chancellor Posts: 1,994

    if that is the case then I would suspect that the optical mouse is defective and it is the source of the problem.
  9. ledaniels

    ledaniels TS Rookie Topic Starter

    Well thats what I originally thought as well, but I tested it on another laptop and it works there, so I don't think its the mouse. But I've been having the same problem with plugging my IPod in as well.

    I'm welcome to any other suggestions...
  10. iss

    iss TechSpot Chancellor Posts: 1,994

    it is possible that the usb controller on the mobo is going bad they can often exhibit intermitent problems before they fail altogether. but if that were the case I would think that you would receive the same message at some point when you hooked hte printer into the port and you havnt had any problem with that.

    the only other thing I can think of is to try and run system file checker to see if any system files are damged or missing. us an XP disk and open a command prompt and type sfc /scannow system file checker will examine your system files and repair or replace any mussing or damaged ones.
  11. Vigilante

    Vigilante TechSpot Paladin Posts: 1,634

    To bad you only have one USB port. Just a little input. I have a USB Network Adapter that is "supposed" to work with XP as well. Which it does. But very often when I plug it in the first time, XP says it can't load it and shows unknown device. But I just unplug it and plug back in a different USB port, then XP finishes loading it just fine.

    But since you only have one port, that's a tough one. Are you using a user account with administrator privileges?

    Since it happens with your ipod as well, I can only think that maybe some other program or driver has the USB locked in some way where Windows only expects certain hardware? But that's pretty far fetched.

    You could try unplugging it, go in Device Manager and click one of the menus and check Show Hidden Devices. Then check for your mouse in the list and delete it. Then try plugging it in again.

    good luck
  12. Ethel

    Ethel TS Rookie

    I've got the same problem man. I have an older USB port and I plug in my MS optical mouse. The mouse has been working for quite some time just fine, and this is a fairly new development. Now, when I turn on the laptop, it works for a while, then it suddenly lets me know that the USB device is no longer recognized. I even have a USB 2.0 adapter which will give me the same results with the mouse. I have other devices which work fine through all of my USB ports. I'm looking for the cure too man!

  13. kmatwill

    kmatwill TS Rookie

    Ethel, I have the exact same problem on my IBM T30. It worked perfectly for about a week, then suddenly it would only work for a couple of minutes after I would power the laptop on. Have you found a solution?
  14. Sunil Gupta

    Sunil Gupta TS Rookie

  15. neosolipsism

    neosolipsism TS Rookie

    Yeah that didn't fix it for me. I've restarted, shutdown, unplugged, disected, and even kicked my comp at least a dozen times trying to resolve my USB problems, and I assure you its not static electricity. I have a similar problem as those described above... I have an nForce4 Intel SLI board running XP SP2. Older USB devices work just fine, but newer devices like cameras and all-in-ones won't work properly. XP recognizes them "Found New Hardware", but can't install the drivers for them properly. If I install the drivers myself (i.e. supplied disc rather than the Found New Hardware Wizard) the devices simply don't work correctly, even though XP sees them just fine. I assume its just a USB 2.0 problem, but I don't know. I've tried all sorts of fixes, including updating mobo drivers, trying alternative USB drivers, flashing my BIOS, reassigning shared IRQ's, and even buying a PCI/USB hub (it gives me the same problem regardless of which 1 of 14 ports I plug it into).

    I've been all over the damn internet trying to fix this, but the only fix I've found so far is a clean XP install. No thanks.
  16. martola

    martola TS Rookie

    Solution for Dell laptop unknown device for Microsoft Wireless Notebook Optical Mouse

    I had the same issue and reinstalling the software did not fix the problem.

    -plugged the USB wireless connector
    -plugged it
    -uninstalled the driver
    -then selected to install and chose to select from a list of items.
    -Then Select USB device -USB Root HUB

    and it is working again!!!

    Attached Files:

  17. reallybigkid

    reallybigkid TS Rookie

    I had that problem win vista

    When promted for drivers , i specified the path c:\windows\system32.
  18. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    I can’t offer a fix for your specific USB problem but I can offer some freeware tools I find very helpful troubleshooting USB (and other) device problems.
    • USBDeview - Provides extended info for each USB device currently (or recently) connected. (Check Connected flag in output to see if is a currently connected device)
    • USBView – Also provides USB device info (including hierachical relationship between USB devices)
    • DriverView - Provides detailed list of each driver file installed
    • DriverMax – Provides several functions including
      • Exporting all or selected subset of drivers to a compressed file or folder
      • Importing driver files (great to help you restore previously exporting driver environments)
      • Identifying unknown devices
      One warning: it’s not always accurate in finding driver updates. Verify whether any updates it finds are suitable for your environment
Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...