USB dive not detected in my computer!?

By resu ยท 18 replies
May 25, 2006
  1. After a recent reinstall of windows my computer was back to normal ^_^
    but when i tried to plug in my Mp3 player (creative MuVo) i could not see it in My computer i checked the hardware in control panel and it was there and "device working fine" but still i couldnt see it in my computer!.. it is all very well having "device working fine" but when you cant actually use it then it clearly isnt working fine!

    could anyone please help
    thanks for your time

    Ive checked again and I've found the actuall drive section in device manager rather than the USB section and its listed there as well the stupid thing is that i can see what it is and whats on it as well as what firmware it has got installed on it!! soe why cant i see it in my computer?
    is there something i have to do to enable it to show up in My Computer??
  2. N3051M

    N3051M TS Evangelist Posts: 2,115

    right click [my computer>manage>disk management]
    find your USB drive/mp3 player and right click
    Assign a letter to it if it doesnt already have one.

    tried updating the drivers? including motherboard chipset drivers and the USB2.0 (if needed)
  3. resu

    resu TS Rookie Topic Starter Posts: 172

    yea i've done all that :S
    the strange thing is that when i assign my player a letter it shows in disk managment but still doesnt show in My computer... i managed to open the drive through using disk managment but when i looked at its address in explorer it didnt even exist and the letter had vsanished so i decided to add the letter again but now E has dissappeared, so im guessing that my computer still thinks that drive E (my player) still exists some where!!
    I have since reinstalled windows but nothing has changed so im guessing that it could be a configuration error?

    I decided to create a new user profile as well, just to see if that would make any difference but i get another error:
    CiceriUIWndFrame : mshta.exe
    and then goes on to talk about referenced memory, the last time i had this problem was when a stick of RAM didnt work !! i hope its not that again!

    anyway thanks for your help so far and i hope you will be able to help me some more!
  4. N3051M

    N3051M TS Evangelist Posts: 2,115

    i guess you've tried using a different usb port i'd imagine?

    mshta.exe is a critical windows system process, relating to script, especialy html or something.. and windows desktop/explorer runs off a html type interface? (correct me if im wrong) so maybe its corrupted somehow..

    try doing a system file check goto [start>run] type in cmd then sfc /scannow
    You will need your Winxp cd to do this...

    maybe wise to run memtest just to clear ram off the list....
  5. golfing22

    golfing22 TS Rookie Posts: 22

    yeah, I just did a upgrade to XP pro and I'm having the excat same thing happen to me.
  6. resu

    resu TS Rookie Topic Starter Posts: 172

    it sucks... and even more annoying is the fact that the player shows in the task bar and everything!!!
    some ppl have said that its my HDD because its nearly 3 years old !!? could it be the HDD?
  7. N3051M

    N3051M TS Evangelist Posts: 2,115

    i really doubt it is the hdd... a corruption on the hdd on a system file would be more better answer.. but that requires you to check it with chkdsk /f to check general files and hdd health and the sfc /scannow to check critical windows system files.. have you attempted to run them??

    oh yeh.. one thing i have forgotten that may fix your problem (duh.. silly answer if it did...). Goto your device manager in [control panel>system], scroll down to your usb tree, remove everything there and restart the computer. it will automaticaly reinstall usb drivers...
  8. jobeard

    jobeard TS Ambassador Posts: 11,173   +989

    see mshta description
    The letters HTA are meant to stand for HTML Application. The technology was developed by Microsoft, so is a proprietary concept, and only works in conjunction with Internet Explorer (specifically version 5 and above).
    qed: HTA support is non-essential! I just verifed that I have no such process running to prove it.
  9. WinDoWsMoNoPoLy

    WinDoWsMoNoPoLy TS Rookie Posts: 252

    Just remove everything and anything that has to do with your mp3 player. That is to where it no longer is in disk management. Then plug the mp3 player in, reboot, and let it autodetect.

    It's like when you do a repair install. The profiles you had are still there in Documents and Settings but you can't load them. Exactly the same idea here.
  10. resu

    resu TS Rookie Topic Starter Posts: 172

    ok ill give all your suggestions ago and i hope at least oneof them will work!!

    i havent done the chkdisc and scannow things just yet as i havent had time as i was fixing a mates laptop :D and watching B-list horror movies (always a joy to watch and takes your mind off things lol)
    thx for all your help so far everyone
  11. resu

    resu TS Rookie Topic Starter Posts: 172

    Right i did the chkdsk and it found nothing.. the memory error has been sorted by installing Sp1a :D

    but the USB drive error remains!!
    I have tried other USB drives on my computer and they dont show up.. so i can only think that my computer has an issue with USB storage devices, as i can use my web cam and mouse perfectly! I tried to find out if the USB 2.0 drivers were installed on my system but unfortunatly i dont know where to look?? could anyone tell me where i can find out if they are installed or not!?

    The only solution at the moment seems to be a fresh install of XP (which im am reluctant to do) as this will allow the registry to be reset to a standard user format i.e first time use. as well as my other user configerations as i belive that it is a problem in the actuall registry/config area of the computer! but then again when a new user is created the problem still persists,, but im not sure if all users share the same registry?!?

    let me know what you think..
    - could it be something to do with the registry or user settings?
    - Is a fresh install the only way?

    thanks for your time
  12. jobeard

    jobeard TS Ambassador Posts: 11,173   +989

    you are aware that there are USB 1.0 & 2.0 spec cables? The latter can be
    used anywere, but the 1.0 cable will degrade or fail a USB 2.0 device.
  13. resu

    resu TS Rookie Topic Starter Posts: 172

    Im sry but your gonna have to explain in more detail as i dont have a clue what you mean :D

    Another thing that i have found is that if i assign a letter to the USB drive i still cannot see it in My computer but if i then restart explorer (Task manager > end process [explorer] > new task > explorer) i can see the drive but it is listed as a HDD but when i take the drive out of the system it still shows in My computer and cannot be removed unless windows is restarted!!
    At first this problem was fun as i enjoy trying to fix them but this is insane and is really starting to ware me down!! unless i manage to fix it before hand a friend should be getting a new HDD soon so i hope hell let me borrow so i can clear my system hdd and do a complete fresh install of windows!

    thx again
  14. jobeard

    jobeard TS Ambassador Posts: 11,173   +989

    OK, simple: buy ONLY USB 2.0 cables :)
  15. resu

    resu TS Rookie Topic Starter Posts: 172

    oh right lol
    Ill try and get some :D
  16. resu

    resu TS Rookie Topic Starter Posts: 172

    yea i got some but still no change :s
    i really dnt have a clue whats wrong with it!!
    the drivers are sis 7001 (i think) and i found that they are really bad for usb 2.0
    i guess ill juts have to ask azt PC World or somethin and see if they can suggest anything! but they'll prolly ask for a million pounds just too tell me whats wrong with it!!!

    thx for all the help so far anyway :D
  17. resu

    resu TS Rookie Topic Starter Posts: 172

    yea i got some but still no change :s
    i really dnt have a clue whats wrong with it!!
    the drivers are sis 7001 (i think) and i found that they are really bad for usb 2.0
    i guess ill juts have to ask azt PC World or somethin and see if they can suggest anything! but they'll prolly ask for a million pounds just too tell me whats wrong with it!!!

    thx for all the help so far anyway :D
  18. N3051M

    N3051M TS Evangelist Posts: 2,115

    do you by any chance have a PCI USB2.0 card? maybe try that.. just one spare spot on your mobo is needed...
  19. jobeard

    jobeard TS Ambassador Posts: 11,173   +989

    USB Drivers under \i386

    here's the list of USB support on XP:


    the files in \windows\i386 are normally 'installed' into \windows\system32 by
    the installer; were going to do it manually for ourself!

    notice the i386 stuff all ends in '_' that character gets altered to L,S,F as

    be sure your on an ADMIN account and then:

    1) use your device manager to DISABLE ALL USB ENTRIES
    2) COPY the i386\usb* stuff into your system32\drivers
    2) COPY the i386\usb*.in_ to windows\inf
    3) view the system32\drivers folder BY NAME

    each '_' file will appear directly above the file we will replace

    rename the existing file with a last letter 'Z'
    usbuhci.sys becomes usbuhci.syz
    and change the '_' to 's'
    usbuhci.sy_ becomes usbuhci.sys
    and delete the *.syz file (just let them sit in the recycle bin)

    do this for EVERY file ending in '_'
    Now you may notice that some of them do not have a matching file below it
    eg I have both usb8023.sy_ and usb8023x.sy_ but only system32\dirivers\usb8023.sys
    DELETE any file left over with the '_' and no matching file below it!

    4) view the windows\inf folder BY NAME and repeat the same process as above

    leave the drivers disabled for now and REBOOT

    5) once you have logged in again as ADMIN,
    get to the device manager and ENABLE each USB device.

    shutdown when complete

    6) attach ALL the USB devices that you're having problems with and
    then RESTART.

    hopefully, life will be good again :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...