USB FLash Drive Problem

By brdy59701 ยท 6 replies
Apr 16, 2005
  1. I have a SanDisk Cruser mini 1.0 GB flash drive that was working perfectly for three months. Now when I plug it into any computer a message comes up saying the usb divice is not recognized and has malfunctioned. The light on the flash drive turns on but the drive does not work. How can I fix this problem?
  2. zephead

    zephead TechSpot Paladin Posts: 1,569

    most likely a static charge or something else has damaged the drive and rendered it inoperable. if true, the drive is useless and cannot be repaired.
  3. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +422

    Mine did a similar thing, I had tried it in different computers with different OSes. At one point I had more luck with Win98 than I did XP (you need drivers for 98). In 98 I was able to get all my files off of it, and reformat it. 98 could still read it but XP still had problems (remove hardware knew what drive it was, but windows explorer didn't). Then I tried to fdisk from the dos prompt in 98, and I don't even know if you can do that, but it locked up the computer when I tried to change to the drive letter. Anyway what eventually happened was I kept trying it occationally on an XP machine, when I finally got it recognised I tried to format it again - When I did this, I noticed it had defaulted to FAT rather than FAT32. I changed it to FAT32 and its been working fine again now. I've used it pretty hard for about 2 weeks since and probably transfered over 15 gigs of data with it.

    Edit - People may try and tell you to go to disk management and delete the partitions and re-create. I'm not sure if other pendrives could do it like that, or whether mine couldn't because it was messed up. But in any case that option was greyed out on my drive (Cruzer mini 1.0GB).
  4. jcsmith

    jcsmith TS Rookie

    can i recover files from a flash drive?

    I have tried the tips members have graciously posted; however, I still cannot get into my flash drive. It comes up in the USB port, but when I click on it to open or format it, the computer says to insert "a disk into drive f." I have tried this flash on several computers so I'm assuming it is toast, but would love to find a way to recover files. Any ideas???
  5. nickc

    nickc TechSpot Paladin Posts: 923   +11

    read the f************ thread it was preatty wel said ure drive is toast and I know u are not the one that started this thread.
  6. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    More english and less alcohol, my friend.... :)
  7. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +422

    There is a READ thread at the top of this forum. Thats about all that can be said about the drives.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...