usb hdd xp problems!

By neon256
Apr 10, 2005
  1. hey i have been searching the net for 2 days now for a solution to my problem and i started reading some stuff on this board, u sound intelligent so ill give u a bash and see if u can help me!!

    i got a usb 2.0 external hdd case and have put in a 20Gb maxtor drive but windows xp pro on my laptop does not recognise it! sometimes when i change my usb port it blips and says device found only to say it failed to install :knock:
    i tryed it on my home pc xp home and it worked fine anyone help i have tried everythingbar touching the bios could that be the cause i have 1 60Gb hdd in my comp formatted into 2 sections.

    any help will save me from baldness as i havent stopped pulling hair out for days

    thanks neon :blackeye:
  2. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    Are their Drivers for that HDD case?Most come with a disk and you install the drivers than boot with the USB connected. If you don't have Drivers try the Web for the Manufacturer, they usually have a download.
    Native USB support in Windows does not always recognize that there is a HDD insde the case(especially if it is unformatted.
    Make sure there are not yellow eclamation marks next to USB controller in Device Manager.
    Also you should check the BIOS in case USB is disabled. I have also seen a drive not detected in Device Manager ,but is seen in Disk manager in Computer management .If it is there ,format the Disk there and windows will recognize after a reboot.
  3. kol_indian

    kol_indian TS Rookie Posts: 316

    have u installed the lates patch

    Have u installed windows xp service pack 1, for usb 2.0 devices to work u have to install service pack 1 atleast. check it out
  4. luxus72

    luxus72 TS Rookie

    External USB Hard Disk problems

    I have to tell you that I got some problems with my external hard disk too, which was inside a USB 2.0 enclosure. The disk spontaneously turned off and on and windows xp tried to recognise it every time (ruining every job I did at that moment). I tried everything to no effect, I changed performance settings and drivers, I rearranged the drive-enclosure connection and cables, but nothing seemed to work.
    Happily, after some thinking, I found the solution and now everything is going OK for a long time.
    The problem was due to my USB cable. The one I used was an 1.1 cable. But Hi-speed USB devices need another type of cable, which is identical to 1.1 but has extra shielding. The 1.1 cables are subject to interference. Try to find a 2.0 cable and I am sure many of your problems will vanish automatically...
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...