1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Usb Ports Not Working Properly

By anthonyd46 Ā· 46 replies
May 24, 2006
  1. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    Possibilities (in order of likeliness):
    Bad USB port connections to motherboard.
    Bad USB drivers, (or not loaded at all)
    Bad PSU giving bad voltage to USB lines
  2. nork

    nork TS Maniac Posts: 306

    I think we may be at the point where its likely something more serious.
    However, i also think it would be good to hear from someone with another reasonable suggestion.
    Failing which, here are a few suggestions:
    What is the make and model of your power supply? If its a generic that came with the case it could be that the power line (rail) supplying the usb is too weak to allow the usb to work. You would need a multimeter for that and i can show you a good tutorial on how to do this. You can buy one at an auto store for about $10, either digital or analog would do fine.

    Or, you could borrow a power supply from a friend or from work and try a different power supply. Or simply buy one from, say, newegg. You can get a decent one for under $40 there.

    Also you could remove and uninstall all non-essential hardware and see if that helps.
    If all that failed i would suggest trying a complete fresh as-new install, complete with a "zero fill" of the hard drive. Of course, you would want to back up your data before doing that.
    If all that failed i would consider that the motherboard may be defective in the usb area.
  3. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    Let's get back to some basic info;
    what kind of system do you have (make/model memory) and what kind of
    USB ports do you have? (suggest you add all this to your online user profile)
    eg: my Toshiba/s161 has both USB 1.1 and 2.0 devices and
    the 1.1 is on the side; useful for slow speed devices (eg mouse).
    I attach my ext HD, printer and camera to the 2.0 ports on the back panel.

    Wierd that you didn't get good results from uninstalling all USB devices and
    rebooting to get auto discovery to reinstall them.

    Also major disappointment to see your constant reinfection :blackeye:
  4. anthonyd46

    anthonyd46 TS Rookie Topic Starter Posts: 26

    how do i tell if its 1.1 OR 2.0 i have an inspiron 9300 80gb i think no ext heard drive
  5. anthonyd46

    anthonyd46 TS Rookie Topic Starter Posts: 26

    ok ive put all my system properties in my profile
  6. nork

    nork TS Maniac Posts: 306

    Go to Dell website, product info, search for inspiron 9300 and get the product info, there you will find out which usb ports are 2.0 and\or 1.1.
  7. anthonyd46

    anthonyd46 TS Rookie Topic Starter Posts: 26

    512 MB of DDR2 dual-channel SDRAM standard, upgradable to 2 GB maximum
    2 SoDIMM sockets, both are user-accessible
    Up to 128MB of memory shared when 64MB ATI's MOBILITYTM RADEONĀ® X300 HyperMemoryTM is selected

    I/O Ports
    IEEE 1394 integrated port (1394 cable and software sold separately)
    6-USB 2.0 (Universal Serial Bus) compliant 4-pin connectors
    SD Memory Reader
    Video: 15-pin monitor connector
    Digital Video Interface (DVI)
    S-Video: 7-pin mini-DIN connector
    Audio jacks: Stereo headphones/speakers miniconnector (same as line-out), microphone miniconnector

    17-inch WXGA+ and WUXGA displays:
    Height: 1.6-inches (41.5 mm)
    Width: 15.5-inches (394 mm)
    Depth: 11.3-inches (287 mm)
    Weight: Starting at 7.85 lbs. (3.56 kg). Weight shown is with 17" WXGA+ display, optical drive and 53Whr 6-cell battery.1

    Learn More
    6 Cell 53 WHr Lithium Ion Primary battery. Approximate operating time: Up to 3.4 hours.2
    Optional: 9 Cell 80 WHr Li-Ion primary battery. Approximate operating time: Up to 5.2 hours.2

    AC Adapter:
    Input voltage: 90 to 264 VAC
    Input current (maximum): 1.7A
    Output current: 4.5A max at 4-second pulse, 3.5A continuous
    Output power: 90W standard
    Dimensions (H x W x D): 1.1-inch (28mm) x 2.3-inch (59mm) x 5.25-inch (134mm)
    Weight (with cables): 0.9 lbs. (0.4 kg)

    Power Management
    Suspend-to-RAM mode
    Suspend-to-disk mode
    Stand-by mode (turns off LED and HDD)

    Connectors: (1) Type I or Type II card
    3.3 and 5 V cards supported
  8. nork

    nork TS Maniac Posts: 306

    So you have 6 usb2.0 ports, right?
  9. anthonyd46

    anthonyd46 TS Rookie Topic Starter Posts: 26

    yes 6 usb 2.0
  10. anthonyd46

    anthonyd46 TS Rookie Topic Starter Posts: 26

    nobody yet?
  11. nork

    nork TS Maniac Posts: 306

    I'm sorry, but i didnt post as i am out of options.
    Have you been able to swap out the power supply? Like borrow one and install it to see if that was the problem.
    I mentioned the power supply and a few other suggestions and didnt get a response on that. For instance, i asked what make and model power supply you have.
    And how old is your pc?
  12. anthonyd46

    anthonyd46 TS Rookie Topic Starter Posts: 26

    the pc is 60 days old and the power supply is the standard dell one that comes with it i dobut thats the problem because the usb worked fine before but for a 2 month old computer this shouldnt be happening...
  13. nork

    nork TS Maniac Posts: 306

    If the usb can go bad, so can the power supply, you just never know.
    Its not like Dell puts better power supplies in their units, but some do differ from the norm, so first, since you have a Dell, you would want to check out if your pc is using a standard ps or not. And, if the pc is 60 days old, then you are under warranty anyway.
  14. anthonyd46

    anthonyd46 TS Rookie Topic Starter Posts: 26

    called dell they have no idea.....tried numerous registry fixes, removing the real player, theres something called autofix.exe butif i cant get the camera to show as a removable device as like an e f drive i cant use that any more suggestions?
  15. nork

    nork TS Maniac Posts: 306

    Why cant you send it in for repairs? Its only 2 months old you said, warranty is 1 yr minimum.
    Did you ask Dell about what kind of power supply you have if its standard atx or Dell atx?
    But again, they should be either be helpin you fix your usb ports for you or having you return the unit for repairs!
  16. anthonyd46

    anthonyd46 TS Rookie Topic Starter Posts: 26

    Guess i didnt tell the story of this laptop, bought an inspiron 5150 in june 2002 from then, it was def a defect because between that day and april of this yr it went to the factory 12 times 6 of those times being mother board replacements so yes it went thru 6 mother boards in 4 years, and everytime i would send it to the dell factory it would come back broken half the time..and i would have to send it back within a week like one time sent it in for a mother board then got it back only to find half the keys were missing off the keyboard and the finger mouse had a huge crack in it so fnally this yr the 7th mother board i was on blew and i complained and they gave me a replacement computer an inspiron 9300 which was working fine until my friend mistakenly gave me a virus cause he was showing me how to use remote access and went into msconfig and disabled a bunch of things in startup then ran a chkdsk scan y i dunno....but the scan failed in the middle and the thing never worked right since. So in all i dont trust mailing this thing to the depot because of the history ive had with them..
  17. nork

    nork TS Maniac Posts: 306

    I didnt realize its a laptop.
    Ya know, i have read quite a few bad reports lately in forums like this about Dell's support. Can Dell be that bad?
    I wont buy a laptop for fear of having issues with it, just like you are talking about. I built a tiny system for myself and that is my laptop, so to speak.
    Im sorry to hear about your problems with Dell. Too bad Dell gives themselves such a bad name, at least from what i have read lately.
  18. anthonyd46

    anthonyd46 TS Rookie Topic Starter Posts: 26

    Yea the support is horrible...they basically just google stuff i mean i can do that i dont need to waste my time talking to them to google, dunno how apple i books are but i recommended my friend into getting a compaq laptop it was orig 1400 bucks but with this rebate that rebate etc he paid 850 and got a free printer had it like 7 months now no problems what so ever but hey i got this inpiron 9300 for free so cant complain hopefully the usb gets fixed somehow
  19. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    my camera doesn't show up all and it doesn't need to. When the upload software is running, plugging in the camera
    activates the picture upload feature.
  20. nork

    nork TS Maniac Posts: 306

    Maybe its the same situtation with anthonyd46.
    What make and model cameras are you people using?
  21. anthonyd46

    anthonyd46 TS Rookie Topic Starter Posts: 26

    searched the internet like crazy finally found a letter that someone sent to microsoft and paid the support fee to get one of the techs to help them and they posted the log on this website thank god i didnt have to pay lol but here is the solution........

    Step 1: Remove Hidden Devices

    1. Click Start. Click Run. Type cmd and press OK.
    2. Type "set DEVMGR_SHOW_DETAILS=1" (without quotation marks) and press Enter.
    3. Type "set DEVMGR_SHOW_NONPRESENT_DEVICES=1" (without quotation marks) and Press Enter.
    4. Type "start devmgmt.msc" (without quotation marks) and click press Enter.
    5. Click View. Click Show hidden devices.
    6. Click "+" to expand Imaging devices, Unknown devices and USB devices.
    7. Are there any digital camera devices and unknown devices (including grayed out devices)? If so, please right click it and click Uninstall.

    Step 2: Remove all oem*.inf files


    1. Click start and click run then under the run line type in the command "cmd" (without the quotation marks)

    2. In the command line, type in the following (without the quotes) and press enter after each command:

    "cd \windows\inf"
    "ren infcache.1 *.old"
    "ren oem*.inf *.old"
    "del C:\windows\setupapi.log"

    Step 3: Removing all entries under HKEY_LOCAL_MACHINE/Enum/USB that start with VID


    Removing the VID entries from the registry will cause them to be redetected at restart.

    CAUTION: If you have a USB keyboard or mouse, do not remove the VID entry for these devices, otherwise, Windows may not restart correctly.

    1. Click Start and click Run. Type regedit and click OK. The Registry Editor window will open.

    2. Go to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Enum\USB.

    3. Highlight and delete all the VID_.... entries.

    Permissions may be set allowing the deletion of the VID_ entries by following the steps below:

    a) Right-click the key to be deleted, and then click Permissions. The VID_... Permissions window will open.
    b) With Everyone highlighted in the Group or User name section, select Full Control in the Permissions section.
    c) Click Apply, and then click OK.

    4. Turn off the computer.

    Step 4: Reconnect the digital camera to the computer system:


    1. With the computer system turned off, reconnect the device to the USB port.
    2. Restart the computer.
    3. After the Windows operating system has finished restarting, plug the digital camera into the electrical outlet.
    4. A New Hardware Detected window should open and reload the drivers.
  22. nork

    nork TS Maniac Posts: 306

    Terrific. How about posting the url(s) so we can see that as well.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...