usb ports not working!

By ae86trueno
Jun 28, 2007
  1. I just built my new computer and everything seemed fine untill i tried to plug in my ipod. The screen lit up and turned on but no charging icon (ipod owners will know what i'm talking about). I then tried my psp and did somthing similar(goes into usb mode an dsays the usb is connected but still doesn't show up under my computer). I then tried a different plug ( thinking i had plugged in the case usb ports wrong) but the usb ports that came attached to the mobo gave me the same results. I updated my mobo divers and i still have the same problem.

    My motherboard is a evga nvidia 680i

    and i'm running xp sp2.

    Any help would be appreciated.
    BTW, if this is in the wrong section forgive me as it is my first time posting here.

    NVM i figured it out...
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...