Using Knoppix To Recover Files Help

By tehBlizz · 7 replies
Jul 13, 2008
  1. Basically, I have a bad hard drive with some files on it that I need to get off. I read that Knoppix was a good way to browse the drive and get what I need....

    I downloaded Knoppix, burned it to disc, booted it with the bad hard drive as the only Hard drive connected, as master.

    I was under the impression that an icon would be there on the desktop that would take me to the root of each partition on the drive. However, there is no such icon...

    When knoppix was booting, the hard drive was detected and it was labeled 'hda' I beleive...

    I'm very new to the linux OS and am still trying to figure out how to browse the system...I'm looking in /media...but the drive doesn't show up...

    Please help me out, :). If there is another solution to this besides Knoppix...please let me know.
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

  3. tehBlizz

    tehBlizz TS Rookie Topic Starter

    Second paragraph of part 2 -

    There will be a series of icons down the left side of the screen. The ones labeled "Hard Disk Partition" are the hard drives in your computer. If you can, find one labeled "Hard Disk Partition [hda1]" or "[sda1]". If you can't, just pick the top one. This is probably the drive that is called "C:" in windows. Click on this icon. This will bring up a window that looks similar to the Windows Explorer File Manager. This window will have a directory tree view on the left, and an icon view on the right. If the drive you found is your C drive, the icon view on the right will have some icons called things like "Program Files", "winnt", "windows", "My Documents", "recycled", "Documents and Settings", etc. If you are disappointed by what is on this drive, or you get an error message, close the window and try another one. ​

    That is precisely what I'm trying to do...the only 3 icons on my desktop are...

    KNOPPIX - Some HTML file on the CD
    Floppy Disc - To browse the floppy drive, yes its connected.
    Trash Bin

    I don't see my Hard drive at all...which is the problem.
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    If it's also not found under the K Start button (programs) area, then I suspect the computer itself is not seeing the HardDrive. Does CMOS see your Hard Drive? It may be a failed HardDrive too.
  5. tehBlizz

    tehBlizz TS Rookie Topic Starter

    Yes, CMOS also detects it.
  6. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Is this an external harddrive (usb or firewire connection)

    There was also some discussion that knoppix cannot detect newer hardware than its revision (when it was brought out.)

    I'm thinkng go for another boot cd, or even better, plug the drive in as Slave to another computer, and recover your files there
  7. tehBlizz

    tehBlizz TS Rookie Topic Starter

    Its an internal...

    Here is what I did before going to Knoppix... (from another thread)

    Thanks alot for your replies kimsland, :). Your effort is much appreciated.

    I can't seem to get this to work....

    I have two HDDs...

    A.) ST380012A - Original
    B.) ST3160021A - New

    I'm trying to set A as the master, and B as the slave. I got the jumpers all correct, in the boot diagnostic both devices are recognized correctly as master and slave. of two things happens.

    Windows gets stuck on the boot load screen. Doesn't freeze, the bar keeps moving...and moving and moving and thats it...just stays there. This happens when I configure the jumpers as master and slave specified, as opposed to cable select.

    When the jumpers are set to cable select, I'm able to get into the Windows install on the master just fine...but can't browse any files or anything on the slave, B.

    I have gone to My Computer > Manage...nothing there. I have tried Add New Hardware...which picks up the new Disk Drive...but computer is running slow slow at this point for some reason, it either freezes or just...poops.

    Something I just noticed while writing this thread. On the boot diagnostic, the following message appears. So far only noticed when jumpers are not configured for cable select.

    IDE Channel 1 no 80 conductor cable installed

    On a side note...Drive A is the working main HDD for this machine with the Windows XP install.

    Drive B is one a friend gave me to see if I can get some files off of it.​
  8. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    I see

    So have you tried swapping the IDE Cables around ie Master and Slave (just to see if it's not that)

    The CS is the best option (you have already concluded)
    By the way you are using two different cables, not one (actually I'm sure you have)

    Do you hear the drive spin up? It's not just a power issue (try swapping the power plugs too

    It seems like a faulty drive to me (HardWare wise)
    Especially if it doesn't work as a slave (set as CS) or on its own

    You can download a Drive Diagnostic test for it too. Which may help discover if it's a faulty drive or not.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...