Video driver - amdagp.sys memory conflict

By monton ยท 4 replies
Dec 12, 2006
  1. Hopefully I am in the correct forum for this question

    I have installed XP Pro on a ASUS A7M266 with a 1200 T-Bird and 256MB RAM.
    The video card is a MSI GeForce MX4000 T-64. Regardless of drivers, MSI's or nVidia, I get a blank screen. In vga mode I have found in device manager that there is a memory conflict with the video card and amdagp.sys requiring some of the same resources.

    both want to use 03B0-03BB
    I/O ranges 03C0-03DF

    and memory range 000A0000 - 000BFFFF

    Is there any way to alter the resource use to avoid the conflicts?

    Thanks for any ideas
  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415


    Go into the BIOS and ensure "plug and play" is set to "yes", this happens because the BIOS is handling the IRQ resources and not the OS.

  3. monton

    monton TS Booster Topic Starter Posts: 113

    I tried that before without any luck. Gave it another shot and same problem. I have set everything in the BIOS to auto, and that it is a plug and play OS. Still the same problem. I have used 2 different video cards and 2 sets of drivers each. The first card was a ATI AIW AGP4x. I used the Microsoft driver version and the ATI version. I then removed all drivers, installed the MX4000 T64 AGP4x and have the same issue. It seems AMDAGP.SYS winds up using resources preferred by video cards.
    In the olden days I was able to change memory addresses under device manager->display->resources
    I think that was W95 or 98.
    Is there any way to assign or force amdagp.sys to a different memory location?
  4. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415


    Under Device manager, find the conflicting item, then go to the resouce tab, if you arent able to change one try changing what it is conflicting with.

    Also have you tried updating the BIOS to the latest version, and check the mobo website it may have a patch if its a known problem.

  5. monton

    monton TS Booster Topic Starter Posts: 113

    Ididmyc600, I have been around that road before. In safe mode I have no conflicts. In vga mode I have conflicts with video card and the amdagp bridge....

    I stepped back and started over. I reinstalled the VIA 4 in 1 drivers. Restarted. Same problem ONLY I had a an exclamation mark on the SCSI BIOS - didn't have that before. I uninstalled that from device manager and rebooted.
    System works normally!

    I suppose the SCSI Bios driver was forcing the video or AGP system drivers into evil memory allocations causing warps in the time/space continuum......

    ... or something like that. Anyway, thanks for your help. Your suggestions were right on and helpful. I'm relieved that I got it working.

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...