Win2K BSOD: shell32.dll corrupt?

By josbd ยท 5 replies
Aug 15, 2005
  1. I have a new MESH laptop running win2K. All was fine until I came to delete an audio file which had a name that was too long to be deleted. Couldn't rename it, so I used Advanced System Optimiser's option to "safely remove" said file, but various "could not access file" warnings etc came up. Then went for a reboot, and got the BSOD: shell32.dll may be corrupt.

    I cannot get the laptop to boot in safe mode at all. Tried using the repair option on the Win2K disk, but that was a no go. Tried replacing the dll by using the Recovery Console, but that didn't work either.

    Now we have some pretty irreplaceable stuff on that hard drive, so if anyone has any suggestions as to how I can repair this, get the thing into safe mode, or..... well anything! I would be more than grateful!

    Thanks for wading through this!
  2. thefighter

    thefighter TS Rookie Posts: 21

    Ah! You have the dreaded Mesh 2nd partition boot up menu, do you?

    I noticed this myself, and was highly frustrated at it indeed! It pissed me right off that I couldnt get into Safe Mode. The only way to do so was indeed through WinXp, which you cannot load.

    Anybody else have any ideas that we can boot the computer up using an old windows boot disk, and then use a cmd line to boot him into Safe Mode?

    I suggest you read all the way through before doing the first step, incase you get half way through, and realised you cant do it.

    Anyways, I suggest going over to our faithfull friend google, and put in "download shell32.dll Windows XP" or something like that. Once thats downloaded, and you've made sure the file is there, (it will probrably be in a ZIP, so unextract first) put the shell32.dll on a floppy or some sort of removable drive.

    Then head on over to and download the ISO file. Depending on your internet connection, it should download pretty swiftly, or if your on dial up, you might be there for a few days, because its a 700MB download.

    Then, burn the ISO to a CD-R and put it in your CD Drive of the broken computer, then boot it up.

    If it doesnt work, this means you need to configure the BIOS to load the CD then the Floppy Drive then the Hard Drive. (Something looking like SCSI/A/C or CD-ROM/A/C)

    Because Knoppix is a Live Linux Distro (Bootable Operating System basically) it will load up, and no problems will occur. You can then have a browse around your drives, on Linux.

    But you main task is to put in your removable drive or floppy, and copy that shell32.dll on over to where ever it belongs (probrably c:\windows\system32\)

    I am presuming many things in this miniture tutorial, because you didnt give much information to begin with. But I hope some of the information is some help!

    Good luck!


    Edit: Wow, here I am, signed up only today, so I could get some help with my computer building in the other hardware section, decided its not right taking peoples information without giving something back, and im helping a TechSpot Member with 148 posts!!! Cool! I feel partly helpfull! lol :D
  3. josbd

    josbd TS Booster Topic Starter Posts: 202

    heheh! Thanks a lot mate, and welcome to the Board!

    Only prob is, I have, in Reovery Console, replaced shell32.dll, and this made no difference.

    One thing that interests me tho is your comment about Mesh 2nd Partition boot up menu. Could you explain that? The thing did take an age to boot from the first time we used it. Could this have something to do with it?
  4. thefighter

    thefighter TS Rookie Posts: 21

    Well, the recovery console, might have just replaced the bad shell32.dll file?

    And also, have you tried booting up with MS-DOS and doing (I think its this) a sysrestore command. It will bring up and menu of your backed up registery and you can select a date. Im not sure if this will work though, because I have yet to have the need to fix my newish Mesh computer. But thats what I eventually did after 5days in Dos, on my old Mesh that had Win98.

    Yes, the recovery console you were talking about. It is when you press F10 at startup right? Yes, well, thats the 2nd Partition, called Recovery suprisingly. And it means you cant press F8 to bring up the boot up menu, or press and hold TAB to boot into Safe Mode (You could try them).

    I found this out, when trying to find out if I had a rootkit, because about 12GB of my memory had/has gone missing somewhere.

    Once again I found this out through Knoppix (I still recommend you download this so you can at least access your computer, and maybe try loading something onto it. Its good for PC Recovery tasks)

    You could always try, loading Knoppix up, and then getting a removable drive, like a USB pen, and go from one computer to another, transfering the data you want. Which might take a while.


    You could use Knoppix, to try and partition your drive again, and put Windows on it, make it your default partiton, and then it would load up.

    These are all theorys by the way.

  5. josbd

    josbd TS Booster Topic Starter Posts: 202

    All theories worth checking out.

    I have a copy of Ubuntu live, so might give that a go later.

    ok, well I have got it as far as Safe Mode, but now getting message: 0x77e32d70 ref memory at 0x00080e40 memory could not be read.

    Shall plug on!

    Thanks for your help mate :)
  6. thefighter

    thefighter TS Rookie Posts: 21

    Just search that on google, or on microsofts knowledge base! You will soon find your problem.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...