1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Win7 x64 BSOD Error 0x7A

By dknight · 14 replies
Mar 12, 2011
Post New Reply
  1. Greetings,

    For the past couple of weeks I've been having this strange BSOD. I've tried doing RAM tests and scannow/chkdsk, It found some corrupted files, but could not repair all of them. I tried to analyze the minidump file, but I can't quite figure it out myself. On the .dmp file it mentions CLASSPNP.SYS, but on the actuall BSOD it mentions NTFS.SYS. I thought about a bad page file, or drive controller issues, but I'm not sure.

    The BSOD is very random. I might get it today once, then not get it tomorrow or the next day, then get it again on the day after that. Hardware seems to work quite well with no slowdown until the sudden blue screen. I can play graphic-intensive games fine. I rather get an opinion from an expert before I make drastic changes that might mess up my system while troubleshooting.

    Thanks in advance!

    Asus P6X58D-E
    Intel i7 950
    Corsair Dominator 6GB
    GTX460 SLI
    Crucal SSD C300 SATA-III 6GB/s 64GB (OS)
    WD Velociraptor SATA-III 6GB/s 600GB
    Windows 7 64-bit


    Attached Files:

  2. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    It would be helpful if we could read the minidump files for ourselves.

    How to find and post your Minidump Files:

    My Computer > C Drive > Windows Folder > Minidump Folder > Minidump Files.

    It is these files that we need (not the folder). Attach to your next post the five most recent dumps. Notice the Manage Attachments button at the bottom when you go to post the next time. You can Zip up to five files per Zip; if you only have one or two you don’t need to zip them, just attach as is. Please do us a favor and don’t Zip each one individually.
  3. dknight

    dknight TS Rookie Topic Starter

    The file was over 200kb so I didn't include it initially. I had to zip it individually unfortunately. I would have more .dmp files but the BSOD often restarted my computer without finishing the process of creating the file. This one is the only one I have. Thanks!

    Attached Files:

  4. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Nothing definitive was cited. Have you been infected at all recently?

    What RAM tests did you do?
  5. dknight

    dknight TS Rookie Topic Starter

    I ran memtest v4.20 and after about 35mins it passed the test with no errors. I have COMODO Security Suite so as far as I know my system is clean. I ran a scan 2 days ago and the only thing I found was a adware item in the temp folder.

    There may be another way to check if I am infected, but I am unaware of it (if COMODO alone isn't enough).
  6. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Memtest needs to run for a minimum of 7 Passes and the more after 7 the better. Many people will start it and then go to bed checking it the next day.
  7. dknight

    dknight TS Rookie Topic Starter

    Hmmm, I might as well take advantage of the time and start memtest before going to bed right now. I will post the results tomorrow. Thanks. :)
  8. dknight

    dknight TS Rookie Topic Starter

    This morning after I woke up Memtest86+ was on its 11th pass. All previous passes showed no errors after a little more of 10hrs of testing. The weird thing now is the OS doesn't want to boot. After showing the Windows logo, a BSOD appears for probably less than half a second, too fast to actually read what it says, and then goes away and reboots the system.

    I could hear a small powering up sound followed by a clicking sound coming from the SSD. But when I checked the BIOS both the SSD and the Velociraptor show as "undetected" by the system. This is what's strange because I doubt both drives died at the same time by coincidence. I tried loading Acronis to see if I could backup some data and it said it could not detect any hard drives on my system. So I was thinking if it could be the motherboard, but then it wouldn't explain the strange sounds coming from the SSD.

    I bought all parts of my system back in August, so they still may be under warranty. But first I need to know the cause of the problem so I know what to RMA exactly.

    I'm so confused. o.O

    Edit: The Velociraptor was the one making the sound, not the SSD.
  9. dknight

    dknight TS Rookie Topic Starter

    I did further testing and Windows detects my drives when I load the Windows OS disc for a repair or new install. It took longer than usual to load, but it did after 2-3 mins. Right now it is "attempting to repair" since it said "no OS files found on drive" as the cause of the problems. But that is just plain strange since it even let me browse my C: drive and everything looked to be in order.

    Edit: After attempting to repair it says "Startup repair cannot repair this computer automatically." I'll try a new install and see it goes well. Still it would explain the strange sounds from earlier. How would the drive lose the OS files anyway? It was running fine yesterday.
  10. dknight

    dknight TS Rookie Topic Starter

    Before the new install I update the motherboard BIOS and it did boot fine, but didn't detect the Velociraptor. The BIOS still does not detect any drives. If I unplug the Raptor , the system boots fast and no problems. If it's plugged, sometimes it doesn't boot or boots very slow. I guess it's damaged, but still doesn't explain why the none can be detected by the BIOS, before of after the flash.
  11. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    The veliceraptor could be bad. Have you ever run a harddrive diagnostics before?
  12. dknight

    dknight TS Rookie Topic Starter

    I didn't before. I occasionally used the Windows error-checking tool but that's it. Right now I'm trying to use WD's hard drive diagnostic tool, but unfortunately does not find the drive. I can still hear the clicking sounds, so it's safe to safe it is damaged, just not entirely dead... yet.

    Trying to see if I can salvage the data as a last resort before sending it in for warranty. But if the OS doesn't see the disc, I'm not sure how I'm going to do that, if possible at all. :(
  13. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Slave that drive into another PC and see if you can access this drive through said system.

    You may be able to access your data.
  14. dknight

    dknight TS Rookie Topic Starter

    I will try tomorrow at work with another PC and and also with a IDE/SATA to USB enclosure to see if I have any luck. About the SSD not being recognized in the BIOS, I did some research and updated the Marvell drives and messed a little with the AHCI configuration. It's not displayed as a regular SATA device in the BIOS, but on the other settings and on the Marvell BIOS it is displayed.

    In any case, I appreciate your assistance. It is easier to troubleshoot with someone else than alone. Thanks. :D
  15. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    You're welcome and thanks for getting back to us. You are one of many that I have been reading about with issues pertaining to SSD and the Marvell drives.

    On the SSD I think I'll wait at least until the 5th generation before seriously considering to purchase. :D

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...