Windows 2000 has corrupted itself 13 times in 4 and half weeks, please help me.

By Ravinstorm ยท 46 replies
May 9, 2004
  1. Hi, it seems as if it's one problem after another, but I think this is serious. I want to thank anyone whose checking this thread out and give even more thanks to anyone out there who has some ideas about it.

    I'm going to try and give the short but detailed version of what happened.

    Here are my specs
    OS: Windows 2000 Pro (w/SP4)
    Processor: Athlon 64 3400+
    Motherboard: Asus K8V SE Deluxe
    Memory: 2x512Mb Corsair PC3200 XMS
    Hard Drive: Western Digital SE Caviar 250 gig HD
    Video Card: ATI Radeon 9800 Pro (128Mb)
    Optical Drive: Plextor px-708a DVD R/W & a Sony CRX230E CD R/W that reads but can't burn
    Soundcard: Soundblaster Audilogy 2 ZS

    Ok, so heres some more things that may or may not be relevant.

    Along time ago, about when I had re-installed Windows the second time, alot of my data was lost on my second WD 250 gig Hard Drive because the second Hard Drive was partitioned as a Dynamic Drive and when I re partitioned the main hard drive and Reinstalled Windows, the second hard drive was read as a Unreadable disk in disk management. ok I can deal with that, so I got GetDataBack for NTFS V 2.25 and it found the disk Windows said was unreadable and all the data is still there, yay!

    Now, heres the problem, when pulling the data off the unreadable disk, I was pulling some files and bam, a big red circle with an X pops up and says C:\ corrupted, please run chkdsk followed by many other messages like C:\$mft corrupt, please run chkdsk, just ALOT of messages saying they were corrupted and to run chkdsk, I restarted my computer to run chkdsk and it tells me error loading operating system, so ok, I have reformat the primary hard drive (C:\)and reinstal Windows for ANYTHING to work.

    I thought maybe that some files on the other hard drive caused this, BUT then I got some disks in the mail with some games, it was MAME .81 with 22 gigs of stuff on 6 DVD's, when I tried instaling that it started ok, but on the 3rd disk, same thing C:\ corrupted, run chkdsk followed by many others like it. So it seems to be happening when transfering large files

    Now, speed up to this point, I've had to delete my partition, reformat the drive, and reinstall Windows 2000 with SP4 like 13 times now, I'm pretty sick of it, what's causing my C:\ to corrupt itself when moving files either from the unreadable Hard drive to the good one or moving files from CD Rom files to my readable healthy drive Hard Drive?

    So any ideas would help,I think I should be able to have all the old files I had back from my AMD Athlon 1800XP days working on this new rig, but Windows keeps corrupting itself and I don't know why whenI try to move stuff over

    Some other messages I get are WindowsMedia Corrupt, run chkdsk, and the list goes on and on, nothing in Windows works after that first fatal red X message.

    I thought it might be a Memory issue, so I ran MemTest86 v3.1 and after passing all the test 3 times with no errors, I don't think it's that.
    by the way
    Mem86 stats
    Athlon 64 2203 Mhz
    L1 Cache 128k 18054 Mb/s
    L2 Cache 1024k 3990 Mb/s
    Memory 1023m 1433MB/s
    Testing 80k-1023m 1023m

    Error: 0

    I've also ran Western Digitals Lifegaurd Utility and my hard drive passed

    I've read something about having a 9800 Pro video card with Catylst drivers, having more than 512Mbs of Ram, and a Hard Drive bigger than 120 gigs causes something like this, but I'm still foggy on the whole thing and could use some more info, but I think that only applies to Win XP.

    There has to be a logical reason for this, any ideas?

  2. LNCPapa

    LNCPapa TS Special Forces Posts: 4,276   +461

    Not sure about your problem - but the last thing you said about RAM + HD + Pro + Catalyst is pretty hard for me to believe. I have two machines that meet those requirements and neither of those has had any problems at all.
  3. Ravinstorm

    Ravinstorm TS Rookie Topic Starter

    Well your right, it's probably not, I just read it on this board

    "this is sort of unrelated but if you have a radeon 9800 pro (i'm not sure about the other radeons) and 512mb or more of ram, then don't set your memory usage to a high system cache. i corrupted my hard drive because i failed to look at the catalyst installation notes when installing the drivers. a few reboots later, a mess. i had just finished installing windows so i did not loose anything important thankfully."

    sounded like something I thought I should concern myself with, but yeah, I'm pretty stumped on what could be causing this data corruption.
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Welcome to TechSpot

    I think it is a bad idea to have such big partitions. I run W2K/SP4 myself. My C-partition is 10GB, of which less than 1GB is taken up by W2K. The rest is a bunch of smaller utilities, that I always use anyway, such as Powerdesk, Acrobat etc..
    Larger programs, such as Office, CDRW-burning, Digital programs etc. go onto a separate Program-partition. Output from all those programs go on a separate Data-partition again.
    I use Drive Image for regular backups (whole partition). My original install dates from January 2003, updated with SP4 and MS-updates. It is still going as smooth as ever and I did not have to reinstall once since 2003.
    I also run a second instance of W2K to test out new programs.
    My HDs are only babies (2 x 80GB) compared to yours, and I am still using FAT32.

    Do away with those crazy-sized partitions, life will be much less complicated.
  5. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Have a look at this page -> K8V FAQ

    Maybe the capacitors on your board have gone bad. Another thing I've heard is that certain ASUS BIOSes for that board tend to do some overclocking without letting the user know. When the board detects Ram capable of higher then PC3200 speeds, it lowers the multiplier & increases the "FSB" ( or HT link ) in order to get better performance while maintaining the same CPU clock speed ( all to impress benchmarks I guess ).

    Launch CPUID or CPU-Z & see if everything is running at the proper speed. Your symptoms could be a ram problem after all.
  6. lukemh

    lukemh TS Rookie

    I am having the same problems as Ravinstorm.

    Every week or so I get c:\$mft is corrupt and I have to re-install windows.

    The problem seems to just happen on its own after a few days, but if I copy a large number of files (like the mamedvd that ravinstorm talked about) then the problem happens instantly!!!)

    It is not the hard drive thats the problem as every time i re-install windows I take out the primary hard drive, install windows on a spare drive and then try and recover files from the corrupt drive. Once I have recovered the files I reformat the corrupt drive and then put it in the spares cubard, when it happens again I do the same and swap the drive over.

    Here are my system specs

    Asus P5GD2 motherboard with latest bios
    P4 3.4Ghz (stock speed)
    1gig DDR2 (2x 512)
    ATI Radeon X600 Pro
    WD2000 200gig SATA
    Seagate 160gig SATA
    IBM GXP 120gig

    Oh and my OS is windows 2000

    Please help as this problem is a nightmare and I am sure I am not alone


  7. alphnumeric

    alphnumeric TS Rookie Posts: 173

    Bad ram will cause a lot of data error's and corrupt your system. Depending on how much ram you have and how high in the address range the bad spot is, you may only get errors when you transfer large files or have a lot of apps running at the same time.
  8. lukemh

    lukemh TS Rookie

    I'm going to leave a ram test running overnight and see what happens. I don't believe it is going to be the ram as none of my applications nor windows have crahsed at all, it only seems to be the hard drives that are corrupting.
  9. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    Check the settings for your page file.I had similar symptoms a couple of years back.
    I force my page file( with a specific size ) to reside in the same (freshly defragged )area of my HDD ,rather than allow it to dynamically change .

    Also I noticed Ravinstorm's CD writer does not write. I am curious as to why? What authoring software are you using?Could there be ASPI layer conflicts at work here?
  10. lukemh

    lukemh TS Rookie

    I too force my pagefile to a fixed size.

    I use perfect disk to do an offline defrag so that it can move the pagefile to one continuous block and then make it permenant
  11. lukemh

    lukemh TS Rookie

    Sorry forgot to also say, I ram Memcheck86 successfully for 350 passes with no errors so its definatly not the ram

    Kind Regards

  12. blah22

    blah22 TS Rookie Posts: 16

    Sorry to ressurrect this old post, but I am now having this exact issue and was just hoping that someone might have an answer at this point? =)

    I've had to reformat and reinstall win2k sp4 5 times in 1 weekend because every time about 3 hours after I install I get the corruption error. I have run virus scans, memory checks, hd test from several different companies, and find nothing. I am now running on winXP with seemingly no trouble (its been about 10 hours now.)

    A possible cause...For some reason after about 4 reformats I ran Maxtor's Low Level Format test, which writes 0's to the entire drive. After this I went to install w2k, to find that the cd only registered about 131 gigs of my 250gb drive. But the previous 4 or so installations had all recognized the full capacity...At this point I called maxtor, and we found that in the BIOS it listed max capacity as 251, but when you multiply the cylinders and heads and...sectors? which is supposed to give you the max capacity, it only gave 137...I dont know if this is a serious issue or not, but worth noting.

    So I decided that I would go ahead and try to install on the 137gb partition anyway, and see if there was a way to enable the larger one later, as you would on a pre SP3 installation. But I found that when I installed and checked my was on a 250gb partition...So I dont get it, but this might lend a clue.

    Specs are:

    amd 3200+ xp
    geforce 5950 ultra
    1 gig dual channel corsair ram
    asus A7N8X-E deluxe mobo
    maxline 250gig HD with a diamondback 200gig on an ata controller card
  13. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

  14. blah22

    blah22 TS Rookie Posts: 16

    Thanks for the links, but I'm not trying to import any HDs, im making new installations on a freshly formatted HD, and it keeps corrupting a few hours later. I dont want to have to keep recovering crap after it crashes id rather just figure out why its crashing =)
  15. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Oh, right sorry. I don't always get time to read all of the posts ;) !

    -Is there something common you are installing each time?

    -Do you try just clean installs with nothing else (i.e. no other software installed?)

    -How do things look in device manager? Any warnings?

    -Can you redetect your HDD in your BIOS?

    -Can you try a different HDD IDE cable?

    -Can you list changes made to the machine from stage of fresh install to stage of corruption? List them here.

    -Tell the truth - are you installing from pirated media?

    ...and....drum roll....!!!.... Have you COMPLETELY checked for viruses? You might be reinfecting your machine every time you recover the files, because there is an infected file, and your anti-virus software is out of date???
  16. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Keep posting back here with your investigations, keep this thread alive.

    We've had stuff like this before and we got to the bottom of it in the end (not this specific problem, but similar woes that at first seemed totally baffling...)
  17. blah22

    blah22 TS Rookie Posts: 16

    Well, the first corruption happened after updating from java 1.3 to java 1.5, installing bittorrent, and azureus, and running crap cleaner. So it was fine for about 3 months, then all of a sudden after this, it happened.

    Then I reformatted, installed usual drivers/windowsupdate, BlackIce, Norton and Counter Strike Source, then decided to install java 1.5 directly, then bittorrent and azureus, and it happened this point I thought it was java.

    So I reformat again and stay the hell away from Java and bit and azu. So I just install BlackIce, Norton and CS:S then I think I tried installing World of Warcraft, and on the last CD, I got the error and it crashed. So I guess it wasnt java after all.

    I think this was the point that I ran the Low Level Format from maxtor's boot disk, and win2k wouldnt recognize the full capacity of my drive. But I installed anyway, and when I got into the OS, it showed the full capacity anyway...But I thought the low level format may have fixed it...So I think I installed CS:S but on the last cd...I got the message again...

    After that I decided to try winXP to see if it was just a OS issue as maxtor told me they thought it was...And so far I've installed blackice and norton, run another full system scan, memory test, and updates and everything is running smoothly.

    -I havent tried just installing w2k and just leave it chilling without anything at all installed, it does seem that the problem is triggered by installing programs, but other posters have said that if they dont do such things the problem arises in a few weeks on its own.

    -I only get normal Device manager warnings for uninstalled drivers of things that i dont use

    -BIOS does re-detect my HD

    -I havent tried a new cable, I would have done that if it wasnt for the fact that XP has been fine so far.

    -I am installing from a burned disc that a friend made me with sp4 included, I'm not really sure if its pirated or if it was just a os he doesnt use anymore or what, but it isnt the original cd
  18. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    And you have swapped hard drives inbetween some of these installations??

    (I only ever had something like this happen to me once. I got the disk space detection issues and the Windows 98 equivalent of these error messages you describe when I repartitioned by drive using a linux partitioning tool. Obviously, this isn't the problem in this case. I did finally fix this issue by changing the drive geometry in the BIOS after removing all partitions.)

    This is pretty krypton factor, but there will be a logical reason for it. If its happening to lots of people it does suggest a viral infection of some kind, but you are running Norton and stuff and not finding this. Can you run alternative anti-virus, just in case? Sometimes they pick up different stuff. Try one of the alternative big names.
  19. blah22

    blah22 TS Rookie Posts: 16

    I have not swapped harddrives, but others that I've read have said that they swap harddrives every time and it still happens...what was this about reconfiguring the geometry in bios?

    And about the alternate virus detection, any reccommendations? I remember I once downloaded the sophos trial and it worked well, I'll go see if I can grab that now.
  20. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8"the+file+or+directory+c

    Are you using a 80wire/40pin cable?????
  21. blah22

    blah22 TS Rookie Posts: 16

    Sorry if this is a stupid question, but how would I check that? =)

    However, I dont get the delayed write error, and the problem seems to be absent with the install of xp rather than 2k.
  22. blah22

    blah22 TS Rookie Posts: 16

  23. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Sounds like you do, yes the ribs are finer, and the cable feels different to run your finger along.

    But I think you might have an error reading and writing to your hard drive, and its not the fault of the hard drive itself if you have been swapping drives around.

    Have you tried taking your hard drive that contains important data out, and just run with one drive? Maybe even think about moving things, so that one drive is master on one channel, and one drive is master on the other; make no drive a slave. Also, jumper the drives as masters and don't use cable select / auto setting. Have only optical drives as slaves. Jumper those as slaves too. Don't have any drive using cable select / auto setting. Use the new type of cable with both if possible.

    I am sure someone posted about this problem years ago and that was what they said. I think a number of steps helped to fix the problem in the end, the above were some of them.
  24. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    you're not using NTFS? why not?
  25. blah22

    blah22 TS Rookie Posts: 16

    What I have right now is my master drive connected to my mobo, and my secondary drive that I use for storage purposes connected as master on a PCI ATA controller card. Both are jumpered and detected as masters.

    I emailed the guy who started this thread, and he said

    "Ohh yea, What the problem was in my case was the IDE
    controllers on my motherboard were bad, and installing
    multiple programs and transferring large files
    (multiple gigs)between my two hard drives kept
    corrupting my hard drives, so I replaced my
    motherboard and i haven't seen that problem since."

    I hope this isnt the cause on my computer, but if it were, how could I tell this? And wouldnt this also affect my XP installation?

    And yes I am using NTFS, what made you think I wasnt?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...