Windows 2000 has corrupted itself 13 times in 4 and half weeks, please help me.

By Ravinstorm ยท 46 replies
May 9, 2004
  1. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Start changing cables and running with just the hard drive, etc before you start returning motherboards, you may well have a bad cable. But yes, you could have a bad IDE controller. Try taking the PCI ATA controller hard out, just run with the mobo IDE controllers, and see if the problems still persist with a clean windows install.
  2. blah22

    blah22 TS Rookie Posts: 16

    OK, so I removed my PCI ATA controller card, swapped cables out on my main HD, and reloaded win2k...and everything seems fine so far, I just installed WoW with no errors. I'm going to go try CS:S, and if that goes well, and its still up by tomorrow I may try reconnect my secondary HD tomorrow. But should I connect it on the controller card or on the slave cable to my mobo? Because my mobo only has 1 slot for a HD cable...But I'm also afraid if I have faulty IDE controller on my mobo that if my secondary drive get corrupted I'd lose a crapload of stuff that I'd rather not lose =P
  3. blah22

    blah22 TS Rookie Posts: 16 I installed CS:S and on the last cd I got the error again that was with a different ribbon, no ata control card...

    So now I'm back on XP, and going to try to see if I can get the error here. If I can't, I have no idea wth is going on.
  4. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    That is starting to sound like a motherboard fault. You've eliminated HDD, OS and cable, if you have used updated IDE controller drivers (get most up to date mobo drivers for this) then you have eliminated everything, I guess, apart from the mobo itself.

    Can you DISABLE the primary IDE controller, and attach a hard drive to the second controller, along with an optical drive (for installation purposes.) Try to install the OS with just the secondary controller being used, what happens now?
  5. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    like phantasm66 said, it's probably a MB fault. If you run straight off the motherboard, chances are your hard drives either won't work or they will run VERY slow. You have an ATA card there for a reason because your MB probably doesn't support faster IDE hard drives.

    If you suspect the MB IDE port is bad, don't connect it up. It isn't worth the risk.
  6. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Well, if its completely F@~@~@~@ed anyway, he can connect the drive that does not contain important information to the secondary controller, and have the primary controller disabled in the BIOS. Then, boot from CD (slave on secondary) and install a fresh XP. Do the problems go away???
  7. blah22

    blah22 TS Rookie Posts: 16

    Well, I still havent eliminated an OS issue, I have yet to crash when using XP.
  8. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Oh that's interesting. Have you tried the latest mobo drivers in Windows 2000???
  9. blah22

    blah22 TS Rookie Posts: 16

    Meaning updating the BIOS? I havent because they have a giant warning on the website saying only do it if you're sure it will fix the problem because it can just create more problems. =) Think I should try it?
  10. blah22

    blah22 TS Rookie Posts: 16

    Ooor, would that be "Silicon Image Serial ATA driver version V1.0.0.50 WHQL and Serial ATA Utility V1.1.3"?

    *edit* Nevermind, thats just serial the only thing I can find on the website that would be applicable would be the BIOS...*/edit*
  11. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    No, not the BIOS. The chipset drivers for your motherboard, which will be available from the motherboard manufacturer, and will support Windows 2000. These will contain IDE controller drivers. You should try to install these if they are available, rather than relying on the Windows 2000 stock drivers, which might be causing the problem.
  12. blah22

    blah22 TS Rookie Posts: 16 Deluxe&Type=Drivers&SLanguage=en-us is the driver download page for my mobo, only thing on there is SATA, video and LAN drivers, at least that I can see.

    *edit* On utilities tab I found "NVIDIA nForce all in one Drivers for 2000 WHQL package version 2.64." Which has an ide folder in the zip file. I'll try that later today, but do I need to install those somehow before I load 2k? Or just install 2k and then install them? */edit*
  13. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    No, you can go into device manager and update drivers for the device and point it to the IDE folder, or the IDE folder might have its own installer program. So, you can try these with your existing Win2k install.
  14. blah22

    blah22 TS Rookie Posts: 16 I download the driver, open the folder, double click IDE, even though its the 2000 version, theres a choice of 2000 and xp, when I double click the 2000 one, its empty...but the xp one has 4 files in it...

    So I checked the cd that comes with the mobo and its the same way.
  15. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Applies to all Windows operating systems older than XP Service Pack 1.

    My explanation to it is that when you have an operating system that can't access the sectors beyond 137 GB correctly, the 'access pointer' flips to zero and starts writing from the start of the drive when it should write to beyond 137 GB area.

    This has happened to me too, with Win2k SP4 and a 160 GB hdd.

    Everything was fine until during defragmentation it moved data to the last sectors of the disk, but in reality it overwrote data in the beginning, the data being $mft$, master file table.

    So, pretty much everything became unreadable, because there was no reliable information about where the files were stored on the partition.

    Here's how to fix it (at least that's what others say):

    # Start a registry editor (e.g., regedit.exe). In Windows, click on Start->Run, enter "regedit".

    # Navigate to the HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ atapi \ Parameters registry subkey.

    # From the Edit menu, select New, DWORD Value.

    # Enter the name EnableBigLba, then press Enter.

    # Double-click the new value, set it to 1, then click OK.

    # Restart the machine for the change to take effect.
  16. blah22

    blah22 TS Rookie Posts: 16

    That actually sounds promising, I'll try that as well, thanks.
  17. blah22

    blah22 TS Rookie Posts: 16

    It's been two days and so far everything is fine! I think that reg value did the trick, just comin back to report the findings and to thank you guys for helping me, thanks a lot =)
  18. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Well done to Mictlantecuhtli then!
  19. TuTmAsTeR

    TuTmAsTeR TS Rookie

    First off all i'm sorry to kick a 2 month old topic,

    I was googling around when i found this forum with almost the same problem i got, only i'm running Windows XP Media Center with SP2 and my SATA (200GB Driver Western DIGITAL) keeps giving $MFT Is corrupt and you know the deal.

    It started to act like that since i had it for about a month, i tried everything that was possible to find for me, and it was running fine! until an hour back i started to make a backup of the data on the drive so it started with the burn process but after 7% Completed it gave me that *peep* error again so first Nero crashed and after that also the HDD Disappeard i really don't understand a thing of it, i asked it at several PC Shops and they all told me they guess the HDD had his longest time (It's not even a year old)

    My PC Specs are this:

    CPU: P4 3.06 GHZ (HT)
    Vid: ATi Radeon 9600 128MB
    Mem: DRR 512 MB (Soon gonna be more)
    HDD1: Western Digital 160GB (ATA)
    HDD2: Maxtor 120GB (ATA)
    HDD3: Western Digital 200GB (SATA, the problem one)

    I hope some-one of you here is able to help me, because it's also damn hard to get the files of the HDD cause it seems to keep crashing, otherwise ill just return it to the shop and try to get a new one!

    Thanks in Advance!
  20. alphnumeric

    alphnumeric TS Rookie Posts: 173

    After a reboot my daughters PC came up with a ntoskrnl.exe is missing or corrupt error. I tried fixboot, fixmbr and booted from the XP cd and did a repair, but it did it again time after time. The drive in her PC was purchased less than a year ago. I downloaded the maxtor drive diagnostic and ran it on the drive. It failed the test and gave me a number to enter on the rma form. The rma was refused because the drive was more than a year old. Must be from date of manufacture? Anyway I had nothing to loose so I did a low level format with maxtor software. The drive then passed several repeated tests. :bounce: I formated it installed windows and my daughter has been using it for almost a month now with no problems. :) You should be able to download the programs to do this on your drive from the drive makers site. If it passes you will have ruled it out. If it doesn't then you can chck to see if you can RMA (return) it under warranty.
  21. gm0neyl0ve

    gm0neyl0ve TS Rookie

    me too... but here's the fix

    I had the same problems as well.

    for me it was the win2k inability to handle harddrives larger than 128GB (binary)

    1. Basically install win2k on a smaller partition and then grow it using something like partition magic
    2. slipstream 2k with SP4

    several fixes out there.

    here's from microsoft

    here's another good post.

    What kind of OS lets itself overwrite system files?

  22. lplp

    lplp TS Rookie

    i also have the same kind of problem :

    I have a seagate 7200.8 250g and W2K was installed this way :

    1. boot and install from CDROM (SP2) : i create a 50g partition at the begining then install W2KSP2 on it : that's system partition C
    2. i upgrade W2KSP2 to W2KSP4
    3. now W2K can handle the whole drive so i create a 200g partition for data on the rest of the disk : that's data partition D

    everything worked fine during 2 months. But a few days ago the whole system partition (C) went nuts : MFT corrupted, lost almost everything on it, refused to boot. But data partition (D) is just fine...
    Note : windows itself did not crashed : no BSOD, everything kept running but i could not access any file on the systme partition (it said : "file corrupted, run chkdsk, etc.)
    I had to reformat it, reinstalled, W2K (SP2 -> SP4 : same as above). And after a few hours it crashed again... and again.

    I tried all i could :
    - change IDE ribbon
    - don't use nVidia IDE drivers, just MS ones
    - test disk integrity with seatools (OK) and RAM with memtest (OK)
    - checked the whole system and data after reinstall with several antiviruses (Nod32 and AVG free) : nothing

    I was begining to think of some harware flaw in the MOBO IDE Controller or something that nasty...
    Now, i read what you say and i am thinking of something :
    the crash always happen while i am using emule which writes on the data partition (D) only.

    Could it be that i reached the 137g limit and because of some black magic, instead of writing on the D partion, it writes at the begining of the C partition and destroys the MFT ? That just sounds crazy but i feel so helpless right now :-(
    Moreover since the D partition was created with SP4 it should be ok but you never know...

    Any comments appreciated...



    Config :

    - Gigabyte K8N-F9 (upgraded to bios F11 with "optimal" (ie factory) settings)
    - Athlon 3200+
    - ASUS 6600 128Mo
    - 2x512 Mo RAM CORSAIR
    - IDE Controller 1 :
    - HDD Seagate 7200.8 250g UDMA100 master
    - HDD Seagate 5700.? 80g UDMA66 slave
    - IDE Controller 2 :
    - CDRW (can't remember the brand right now) master
    - DVDRW LG slave
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...