1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Windows 7 cannot detect the built-in webcam on my Asus laptop

By LoneSword · 50 replies
Oct 28, 2010
Post New Reply
  1. maria

    maria TS Rookie

    Thank You!

    oh @demetrdc, i have solved the problem.
    my laptop model is made for Windows 7.

    I tried using the Check Drive Error . . .
    and it seems to successfully configure itself.

    >thank you!
  2. Bishop208

    Bishop208 TS Rookie


    Im having same problem, Web cam shows in device manager as unknown usb device with no description. I got Id from system information in signed drivers tab. How can I force the drivers in, no matter what driver I try I get the "theres no camera installed message, please plug one up and try again.

  3. maria

    maria TS Rookie

    did you install correctly the CD (for drivers)?
  4. ivanlevy

    ivanlevy TS Rookie

    I have just worked out how to activate my inbuilt camera using windows 7. press the windows flag button between fn and alt together with V. its that easy and there is no need for any additional software.
  5. webcammer

    webcammer TS Rookie

    Intel(R) ICH9 Family USB Universal Host Controller - 2934PCI\VEN_8086&DEV_2934&SUBSYS_9035104D&REV_03\3&11583659&0&E8This device is working properly.
    Intel(R) ICH9 Family USB Universal Host Controller - 2935PCI\VEN_8086&DEV_2935&SUBSYS_9035104D&REV_03\3&11583659&0&E9This device is working properly.
    Intel(R) ICH9 Family USB Universal Host Controller - 2936PCI\VEN_8086&DEV_2936&SUBSYS_9035104D&REV_03\3&11583659&0&EAThis device is working properly.
    Intel(R) ICH9 Family USB Universal Host Controller - 2937PCI\VEN_8086&DEV_2937&SUBSYS_9035104D&REV_03\3&11583659&0&D0This device is working properly.
    Intel(R) ICH9 Family USB Universal Host Controller - 2938PCI\VEN_8086&DEV_2938&SUBSYS_9035104D&REV_03\3&11583659&0&D1This device is working properly.
    Intel(R) ICH9 Family USB Universal Host Controller - 2939PCI\VEN_8086&DEV_2939&SUBSYS_9035104D&REV_03\3&11583659&0&D2This device is working properly.
    Intel(R) ICH9 Family USB2 Enhanced Host Controller - 293APCI\VEN_8086&DEV_293A&SUBSYS_9035104D&REV_03\3&11583659&0&EFThis device is working properly.
    Intel(R) ICH9 Family USB2 Enhanced Host Controller - 293CPCI\VEN_8086&DEV_293C&SUBSYS_9035104D&REV_03\3&11583659&0&D7This device is working properly.
    So what do I do now?
    Adobe Flash says this:
    //Your Google Chrome browser already includes Adobe® Flash® Player built-in. Google Chrome will automatically update when new versions of Flash Player are available.//
    But I am told elsewhere that I do not have a camera, when my laptop computer has a laptop built inside it.
    By the way, this is a VAIO, not an ASUS.
  6. eddie137

    eddie137 TS Rookie

    Asus has great products. M51a laptop camera issue, got most of the drivers to load except this Azurewave camera. Got Windows 7 to see the device once and install the correct drivers using the PID #, using the PID number I did find the driver on Asus website. I think it's a dual problem, one the camera that Asus uses and Windows 7 unable to identify a device. On this model I got it to work once using Asus directions and drivers. The webcam was not seen by LifeFrame3 software so I uninstall the device to reinstall again with LifeFrame3 on my laptop. LifeFrame3 is application software to use the camera, not to load drivers. Didn't work so don't uninstall the device if your Windows 7 sees the device, all you need to do is find the correct driver using the PID number. Now I can't get back!

    I've seen the same issue on Everex laptop, HP laptop, Toshiba laptop. So my point is the camera device are not easy to install. The manufacture of the laptop goes by what the camera manufacture recommends as drivers. My case Azurewave camera device are not adequete enough for laptops, meaning product support. Bought the M51A from Ebay seller Complete-Laptops last month, great seller very proactive, super nice guy. Anyway we been working together via email to resolve this issue everyday, trying something Asus recommends. I know it's frustrating but as a technician this is the hardest device to get working on any PC.
  7. vernalsage

    vernalsage TS Rookie

    Ok I had this problem too...it took me days to solve and its extremely easy....this is what happened

    I tested an external webcam on my Asus A52j laptop
    After installing the driver for the ext cam, I changed my default cam to the external one
    When I confirmed it was working I unplugged it and uninstalled the driver that came with external webcam
    That was the beginning of my woes
    I ran msinfo32.exe
    Clicked on components.....problem devices
    The last entry was USB Composite devices and it was noted to be DISABLED
    I went back to device manager...
    USB device controllers......
    Right clicked on USB composite devices and ENABLED
    and VOILA!!! my webcam is back
    Sorry if that sounded pedantic....I'm totally miffed I got my webcam back
  8. ImaBrokeDude

    ImaBrokeDude TS Enthusiast Posts: 34

    Recommend Solution:

    Your system is running with an operating system that is incompatible with your integrated camera device. Devices CAN be installed in Windows Vista compatibility mode. In order to do this, before running the driver installation program, set the compatibility to Vista (This procedure also works for XP drivers by setting the compatibility mode to XP).

    Remember that missing chipset drivers can render internal component operation impossible.

    Now I would agree with that ffor you except you need the chipset drivers to be compatible with your OS before you can even think about trying to install drivers for its components.

    Also unless you were upgrading from Vista to a different version of 7 (I.e. Vista Home Premium x6 to 7 Professional x64) A Custom install (especially on a laptop) before confirming there are compatible drivers is a no-no. Because Windows 7 is capable of running drivers in Vista compatibility mode, your driver would have still be operation.

    No trying to call you out but in the future remember to do your homework FULLY before doing an upgrade.

    Also note this:

    A person should never upgrade the Operating System installed on their machine to a newer major version unless the following conditions are met:

    1. A piece of software requires that newer version of the Operating System
    2. A piece of hardware, or alternatively, it's hardware drivers, require that new version of the Operating System.
    3. All of the above.

    One can upgrade however they please, but to account for and allowing of such to establish compatibility to exist and to allow for major bugs to be removed, it is recommended you follow those guidelines.
  9. Adams35

    Adams35 TS Rookie

    My daughters computer is having a similar issue, although different as well. Her ASUS laptop camera works fine when opened thru a program Skype, but there is no other icon or any other way to access and turn on camera. She wants to be able to use the camera when not on or willing to go thru Skype. I to have founde the drivers and it all says its installed and operating normally, but where is the icon and how do we open the camera? Confused and any help would be appreciated. Thanks
  10. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 380   +8

    Best way would be to go to the Asus website, find the model of the laptop and download the Software for the camera. Generally it comes pre-installed but may have been removed at another point.

    There should be some type of software that is downloadable for the laptop on the Asus website for your model.
  11. petrove

    petrove TS Rookie

    Hi all

    This is the fix for your problem, I had the same problem with packard bell.

    Go to start and type cmd , but do it as administrator

    Type in cmd

    sfc /scannow

    it takes a few minutes .

    Then shut down your laptop , disconnect power , disconnect battery

    wait 30 minutes .

    Then boot your laptop now will the camera show in your device manager .

    And is your problem fixed.

    Then install your webcam software eventuallt update your driver if you find it.

    Now you can enjoy your webcam


  12. Alexndra-Asus

    Alexndra-Asus TS Rookie

    I have Asus laptop and have problems with detecting my built in laptop camera...I found the following: Intel(R) Flash Cache Logic Chip PCI\VEN_8086&DEV_444E&SUBSYS_444E8086&REV_01\4&145AC6E2&0&00E3 This device cannot start.
    Could you advise me on my next move?
  13. chriss72

    chriss72 TS Rookie

    I have problem with lexmark x422 I try to fix it but it isnt fixed
  14. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 380   +8

    Do not mean to sound rude in any way, but this Post was concerning a web cam issue, your issue is unrelated and could cause problems with other people looking for a fix if we reply here. Please create your own post and put in as much detail about the issue as you can.

    Include your operating system, when the problem started, has the printer ever worked? Does it work on another system? Have you tried reinstalling drivers? create a new post and put all this info in there. Thanks.
  15. SaveOurSystems

    SaveOurSystems TS Rookie

    I think Lexmark x422 is the model for the webcam on the Asus M51A
  16. watalee

    watalee Banned

    Try the vista driver.
  17. trlenz

    trlenz TS Rookie

    I am having an Issue with my webcam as well. I Had my screen replaced about 6 months ago and just recently tried using my webcam. My ex-wife claimed to have "closed the lid firmly" (which means she slammed it down), so I got it fixed. I was able to see it by using the command prompt to show "ghost" devices and saw the imaging devices on there. It does not detect the devices normally in the device manager. There is nothing shown under "problem devices" using the msinfo32 run command, but here is what I got when it showed up as a "ghost device" in device manager:

    USB 2.0 1.3M UVC webcam properties.JPG

    Does this mean that the webcam is internally disconnected? I went on youtube and found out how to remove the edge casing for my screen to see the webcam behind and wiggle the wires around and everything looks to be plugged in at the camera circuit card itself, but it runs down into the main art of the computer where I cannot see any connections.

    Oh. I have an Asus G73JH laptop

    Any suggestions?
  18. Biju Skaria

    Biju Skaria TS Rookie


    In Asus EEE Pc lapop, my web cam not working. updating driver, re-installing driver were done but not working web camera. Is it a hardware problem..?

    This is a get while check problem devices in msinfo32.

    Atheros AR8152/8158 PCI-E Fast Ethernet Controller (NDIS 6.20) PCI\VEN_1969&DEV_2062&SUBSYS_84681043&REV_C1\4&1506056A&0&00E3 This device is disabled.
    Bluetooth Peripheral Device BTHENUM\{00001132-0000-1000-8000-00805F9B34FB}_VID&00010075_PID&0100\7&1C52D56A&0&4CA56DB077F8_C00000000 The drivers for this device are not installed.

    Give a reply.......
  19. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 380   +8

    Did you try all the suggested fixes in this post??

    If so, I am not sure what to try next, but the two errors you reported are as follows:

    One is for your ETHERNET port (Atheros PCI-E Fast Ethernet Controller) which is for your internet wired connection.

    Second is Bluetooth Perihperal, this is for Blue Tooth in the laptop. Neither of these pertain to your webcam.
  20. tipstir

    tipstir TS Ambassador Posts: 2,425   +112

    Scan your system to make sure there is no malware on it. If there is most of the time these software pest shutdown hardware features or keep the system running when you hit shutdown. Also again drivers missing means something is going on your system. Check and make sure either pest or maybe HDD is not read/write correctly.

    One more thing try going to the ASUS hardware support and get the latest drivers for your WebCam also.
  21. Melly15

    Melly15 TS Rookie

    I followed the instructions and this is what I got in the problems area.

    ASUS USB2.0 WebCam USB\VID_058F&PID_A016&MI_00\6&1540F985&0&0000 This device is disabled.
    How can I enable it?
  22. learninmypc

    learninmypc TS Evangelist Posts: 7,292   +373

    Have you looked in the device manager for any yellow "!" exclamation marks?
  23. Melly15

    Melly15 TS Rookie

    I took a print screen no exclamation mark
  24. learninmypc

    learninmypc TS Evangelist Posts: 7,292   +373

    Ok, hopefully someone can help you further, good luck. :)
  25. Sam dGG

    Sam dGG TS Rookie

    Okay, I read through all of this, and I found out that I have an almost identical problem. The differences, however, are that I upgraded from Windows 8.1 to Windows 10, and I have a Toshiba Satellite C50-A-1CK Help!

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...