Windows 7 Explorer not responding

By bollemanneke ยท 6 replies
Sep 15, 2011
Post New Reply
  1. Hello.

    I'm new to this forum so I hope I posted this question in the right place.

    I recently bought a little netbook to go to school with - I'm blind and use a computer all the time - but I have an annoying problem. Windows 7 Starter is running fine, but there's really something wrong with the Explorer. Every time I'm browsing a file folder - no matter which one - Explorer freezes after a while, saying: Windows Explorer Not Responding. When I click 'Cancel' during the re-start process (it never works anyway) and try to open a new folder, I receive this error message:
    (I have to translate this literally from Dutch to English, so I don't know if the English message is the same):
    The RPC failed and cannot be executed.

    What in an RPC? How cn I solve this problem?
  2. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    RPC - remote procedure call. Failure here is one process is calling another to perform some task for it, and the called process failing to do the task, or returning the wrong result. In the case of Windows 7 starter and explorer, it would imply that something is very badly coded, right in the heart of the system.

    First note that RPC's all have at least two procedure handlers in Windows XP (I am sorry I know nothing about Windows 7 starter). One thing you can check would be to start the Windows service listing - try control panel - administration tools - services. Or run services.msc What appears with descriptions like Remote procedure Call (RPC) and Remote Procedure Call (RPC) Locator?

    Are both services running? If not right-click each line in turn and select properties. Then make sure the 'startup type' (drop-down listbox) is set to 'automatic' and then reboot.

    If this fails to help, you could try MS technet here call failure&ac=8 which is the result of querying 'RPC call failure' in techNet. where various RPC failures are discussed. Hope something rings bells in there. With a bit of luck you might find a Dutch language version of TechNet which would be easier for you, otherwise use Google translate.

    There are 25,500 references !!! Here is a more refined search windows 7 starter explorer&beta=0&ac=8 Still 17,700 references !!!
    Also Google the exact error message text and get 1,280,000, one of which is - almost an exact match for you, solved by restarting the RPC locator service manually
  3. bollemanneke

    bollemanneke TS Rookie Topic Starter

    Both services are running, I had to put both of them to 'automatical' though. I rebooted my computer, but the problem isn't solved; the only thing that changed is the error message, which contains now a lot of numbers and letters between square brackets. Would re-installing Windows solve the problem?
  4. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    Re-installing Windows is a bit drastic so early on. Wait for further advice. Do you have any unusual devices or unusual software or very small memory on that netbook? I am thinking a reinstall might not be a solution.

    Please note (or take a snapshot of) the exact error messages seen - it could be important at some stage.
  5. bollemanneke

    bollemanneke TS Rookie Topic Starter

    My RAM capacity is 1GHZ. I do use special software, but it only requires 19MB memory. Besides, four years ago I had another computer with the same ram capacity, but the braille software required more memory, and it still went faster than this one, and the Windows Explorer never crashed on my old computer.
  6. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    Sadly typical memory requirements for win98 were 300Mb, for XP 1-2 Gb, for Win7 3-4Gb

    That's MS for you. At 1Gb actual memory problems are a possibility. You would need something like a minimum of 2Gb swap page on the HDD. This is adjustable. Another problem is a lot of the more specialised software has never been (may never be) re-written for Windows 7, so a fundamental incompatibility is quite possible.

    It hurts me to say it, but your netbook may be not up to the task, or just as likely, Win7 starter is not. Most people find they can run such incompatible software in so-called XP-mode, but that may not be an option for you.

    I am thinking the RPC failure occurs when Win7 explorer tries to scan some hardware that reports itself incorrectly (braille pad etc??) And Win7 probably tries to cache explorer data with gross slowing after a period of time due to memory swapping.

    Depending upon what you typically use a netbook for, and really important, if you can find an equivalent version of your braille program in open source, you may do better with one of the smaller Linux distributions, and can drop Win 7 starter. Another thing you might be lucky with, will XP install on that particular hardware, and is there a down-grade option on the install DVD ?

    Also note in the last post of the last link I referenced, someone is saying RPC errors commonly come from a malware infection.

    Please run a test for me....disconnect every possible peripheral from your netbook (including printer and network). Close all anti-virus and any software not essential to just explorer. Make sure by RUNning services.msc that all non-vital services are stopped - especially Indexing service, Java, Does the problem still happen? What I want you to do is discover whether any particular service is conflicting or using excessive CPU. Many things are not essential see Black Viper

    I regret I cannot offer better advice.
  7. kristain

    kristain TS Rookie Posts: 47


    With a pre-installed computer, the odds of this issue being caused by 3rd party software is highly likely though. One place you can start is by using the System Configuration tool to selectively turn off all 3rd party software. It is called MSCONFIG. Here are some steops for using it (even though they are for Vista, it's the same info).

    How to use the System Configuration utility to troubleshoot configuration errors in Windows Vista -

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...