Windows Explorer randomly laggy

By Sai ยท 10 replies
Feb 28, 2010
  1. Hi

    I've got a problem with windows explorer being randomly laggy. After having not accessed windows explorer or any other folder for a while (usually over 30mins) when i next try to open windows explorer or any folder it will lag for about 5-10 seconds before finally opening.

    After opening there will not be any more lag at all, i can access any folder any number of times and it will be fine.

    But after another period of not accessing a folder or windows explorer (for a similar time to above, 30mins or more) it will lag again on the first attempt at opening a folder or windows explorer.

    I have tried defragging, disk cleanup, clearing temp files, making more hard drive space etc etc but nothing helps at all. My hard drive is never more than 40% full so im not sure whats causing this. Could my harddrive be on the way out/about to die? I've had this harddrive for about 2 years now whereas all other components in my system are less than 6 months old.

    Below are my specs;

    Windows 7 64 bit
    q9550 (E0 stepping) @ 3.4GHz
    ep45-ud3p mo/bo (rev 1.6 with FD bios (very latest))
    4gb ddr2 ocz reaper hpc 1066mhz
    WD caviar blue 500gb (WD5000AAKS)
    Thermaltake Evo Blue 750w psu

    Any help would be greatly appreciated.

    p.s i've tried finding solutions randomly with google and have read that kaspersky AV has caused some issues for some people but ive been running KAV for years and this issue has only recently occurred.
  2. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    Did that happened from the moment you migrated to win7 x64? Or at some later stage, perhaps you may have made some changes/or installed something?
  3. Sai

    Sai TS Rookie Topic Starter Posts: 36

    Nothing has changed that could have caused this to suddenly start happening.

    No hardware change for over a month. No software changes in month or so as well.

    I dont understand how it happens only if i havn't opened a folder or explorer for a while.
  4. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    Open Windows Task Manager (by pressing Ctrl + Alt + Del), and see which process is utilizing most amount of CPU time; also is there some process which is eating up lots of memory.

    Secondly, please follow instructions in this thread, and post your logs at the appropriate forum for analysis/examination; to make sure you do not have any malware/rootkit issues.
  5. Sai

    Sai TS Rookie Topic Starter Posts: 36

    Thank you for your reply.

    I've been keeping a regular check on task manager and nothing is using up cpu time. There are also no "alien" processes running. Nothing that shouldn't be there.

    I am very careful with my computer, i have Kaspersky AV 2010 running (official paid product) and regularly run anti-malware progs like malware bytes so its 100% guaranteed that its not malware related.
  6. compdata

    compdata TechSpot Paladin Posts: 529   +7

    are you sure you have the "show processes from all users" enabled in the task manager? If you don't you may be missing the program that is causing your issues.

    Also just wanted to point out that while you may not have installed any updates to programs, AV programs update them selves regularly - so it is highly possible you have had a Kaspersky update that may have caused the issue. Try installing another AV program in its place just to test. I have been using Microsoft Security Essentials recently and have been fairly impressed by it (Free from MS at
  7. Sai

    Sai TS Rookie Topic Starter Posts: 36

    Look no offense but its not a simple/obvious answer.

    A - I know there is a "show process from all users" button. I know a little about computers, i custom built this pc. I know there is no cpu useage other than "System Idle Process" which is normal.

    B - AV programs only "update themselves" if you select that option. I never use that option. I manually update all my software including AV's. And while there might be a slight chance that Kaspersky is causing this i can't tell if/how its doing it as no KAV process uses any cpu time.

    C - The lag occurs after the hard drive hasn't been used for a while, no folders opened or windows explorer not used. After the lag spike i can open any folder any number of times with no issue what so ever. Its only after some time where the hard drive has been inactive that this lag occurs.

    Now i dont know everything about computers so i dont know if my hard drive is dieing or if there is an OS issue that is causing this. I'm posting this in the OS section of the boards because thats where i assume the issue is but its not something "noobishly" obvious. I've tried googleing for solutions but cant seem to find anything similar to my issue.
  8. compdata

    compdata TechSpot Paladin Posts: 529   +7

    I was not trying to say it is obvious or simple, but you had left out a couple of details (like the fact that you manually update programs), that make it a little more difficult to offer suggestions.

    This is conjecture but It kind of sounds like explorer (or some system process) is getting erroneously pushed out to the virtual memory. What is your average memory usage? Do you see the hard drive light going when you experience the lag? You could try disabling the page file to rule out that as a possibility. I have discussed some page file issues i have seen with a friend who works for MS and he said that internally they are aware of some non-optimal usage issues, so it isn't out of the realm of plausible issues.

    Here is a vista link for how to do that, but it is nearly identical in win7
  9. Sai

    Sai TS Rookie Topic Starter Posts: 36

    My average memory usage is about 1gb and the harddrive light doesn't flash much when the lag occurs. It flashes as if it is working at a very slow speed. I've checked to make sure all my cables are attached properly and working and everything seems fine.

    As for the page file theory it didnt affect my issue at all. I tried disabling the page file, setting it to auto, manually changing it and nothing made any change
  10. compdata

    compdata TechSpot Paladin Posts: 529   +7

    Sorry pretty much out of ideas then. . . Last thing i can think if to check would be the power settings to make sure that it isn't turning your harddrive off after a certain amount of time. I doubt it is this based on the fact that you didn't change anything though.
  11. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    Windows 7 - pretty sure to be 'tuning itself up' all the time in the background. That's MS for you - 'we know best', so your PC is moving data around, shuffling the order of programs in memory, removing unused items from the desktop and most-recently used lists, playing about with pre-fetch, and so on, and so on. Typical result of all this babying is to eventually bring your PC to a grinding halt.

    Your best bet is find a 'tune-up Win7' site for yourself, which might get you back in charge of your own PC
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...