Windows won`t boot without having the Windows cd in drive?

By Starfox00000 ยท 14 replies
Feb 11, 2007
  1. OK, I've had this same problem with XP home 32-bit, and then after giving up on that, upgraded to XP pro 64-bit. The problem is that my computer boots fine and works A-OK (im typing on it right now) when the windows CD is in the drive. However, if I take the CD out and try to boot I get a hal.dll is missing or corrupt and cant boot. If i put the cd back in and try to boot again everything is fine. I have had the same problem with BOTH OS's. I have tried all the solutions I can find for hal.dll is missing or corrupt. It is there in the system 32 folder, and the boot.ini is fine. I have rebuilt the boot.ini before this installation as well as extracting hal.dll from the recovery console. In my bios the cd-drive is set to boot first.

    my specs:
    (i built my computer i'd been saving for and this sux)
    amd fx-62 @2.8ghz
    crosshair mobo 590sli
    5 HDD's, all sata 4x 320GB and one 400GB. they are NOT raided, ive been trying to install windows on the 400GB one.
    dual geforce 7950's
    680w PSU
    4GB OZC ram
    soundmax integrated sound
    generic dvd-burner.

    Also, most of the windows have been fresh installs (ive reinstalled / repair installed about 10-15 times) but ive always done the quick format in XP setup, idk if that will help at all but you never know. I usually can fix most problems on my own, but im at the end of my rope. Any help would be so appreciated you cant possible imagine how much I would appreciate it.

    EDIT: almost forgot - either once or twice I repartitioned the drive (deleted existing one and made a new one) using hiresn boot cd and I've had problems with the nvidia IDE drivers. If I install the nvidia ide drivers all hell breaks loose and I get delayed write failures on every drive and have to reinstall windows.
  2. Jesse_hz

    Jesse_hz TS Maniac Posts: 545

    You know, with a thread title like that you're bound to get tons of help around here!
  3. Starfox00000

    Starfox00000 TS Rookie Topic Starter

    Sorry, its just such a weird problem and Im totally out of ideas. thx for changing the title.
  4. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    I have heard of this issue before.

    I'm going to go out for a bit... Give this a good thought... And come back later with an answer (hopefully). Best of luck. :)
  5. Starfox00000

    Starfox00000 TS Rookie Topic Starter

    Hey, I was looking around and found this thread
    It looks like the problem is at least similar, thing is that i have SATA Hdd's. However the fact that I have had this problem with more than one windows could indicate something to do with hardware. I think Ill see if i have any other SATA cables and if windows boots with a diffrent CD (one that has a delay b4 starting windows, like hirens boot cd) in the drive. there may be hope yet! :D

    EDIT: yes I am a night owl and I do have school tomorrow :)
  6. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Quick format is every bit as good as an unconditional format in this case, so this isn't a problem. Don't worry about this. :)
    This is commonly caused by a missing or corrupted hal.dll (of course), an incorrect boot.ini or partition errors. I'm sure you've read all about this stuff in the course of trying to fix it...
    With 32-bit Windows, you'll probably need to add the 'physical address extension' switch to your boot.ini. I've seen a number of systems that would only recognize about 3-3.5GB of memory unless PAE was added.
    x64 should not have this limitation, but just a heads up for you.
    This is worth more investigation.
    I am going to take a moment to think out loud. To understand how this can happen, we need to understand the boot process. Here's how it works.
    1. System POST
    2. BIOS searches for the best possible bootable device and loads the MBR (AKA: master boot record, master boot sector)
    3. The MBR finds the active partition and passes control to the boot loader (NTLDR).
    4. NTLDR prepares for the boot process (Loads file system drivers to read FAT32 and NTFS).
    5. NTLDR loads boot.ini and displays the boot menu (if available)
    6. NTLDR begins to load Windows XP/2000 by running NTDETECT and loading HAL and NTOSKRNL.
    That's about it. Now we need to figure out what relationship the Windows install disc has to a bootable installation of Windows XP. Unfotunately, I don't understand the boot process of the install CD as well. However, I do know the install disc will attempt to boot from any hard drive with a valid file system. When it passes control to the hard drive, it seems to pick up where the boot.ini is processed (step 5). This means that your hard drive is still in control of loading the Windows HAL... Hmmm, that doesn't make sense. How does booting from an install disc change how the HAL is loaded? To tell you the truth, I don't understand it either. :(

    Things we know:
    • This problem happened with Windows XP 32-bit
    • This problem occurs with Windows x64
    • Your system displays the "HAL is missing or corrupt" error and does not complete the Windows boot process
    • This error goes away when the CD inserted
    While I was out thinking about this, the best possible explanations I could come up with were this... And bare with me, as these are the product of just sketchy brainstorming.

    32-bit Windows missing or corrupted HAL due to memory limitations
    This is pure speculation, but I would think it is possible to receive a "HAL is missing or corrupt" on certain systems if you do not use the PAE switch in your boot.ini. This would apply only to the 32-bit Windows. BUT, since your x64 install has the same problems, then this could only be correct if the missing HAL error is a coincidence on your x64 install.

    x64 and 32-bit problems
    If you somehow have managed to get a 32-bit NTLDR and a 64-bit HAL or a 64-bit NTLDR and a 32-bit HAL, then you would definitely get the "HAL is missing or corrupt" message. I don't have an explanation for how this would happen, but consider this.

    IDE controller problems. Most likely cause?
    I feel this may be the problem. My reasoning is your BIOS successfully boots to your drive, but the problem seems to lie with Windows' boot process. NTLDR gets loaded, no problem. We can tell this because it actually gets to the point where it tries to load HAL. Somewhere between NTLDR and HAL things go awry. What happens after NTLDR is it loads its own file system drivers. At this point, it reads boot.ini and loads HAL etc... Again, this is more speculation, but somewhere between this I think it would possible that your IDE/SATA driver issues could interfere with this process.

    With this in mind, I would consider these things. If you're using F6 to install 3rd party RAID/SCSI drivers, try some different ones. Make a new F6 floppy with the latest or older nVidia drivers. Make sure you aren't getting the x64 and 32-bit IDE/SATA drivers mixed up. In your BIOS, consider using IDE emulation/mode for SATA. Also, consider disabling any 'AHCI' or 'enahnced SATA mode' options. Also consider disabling SATA II/300/3Gbps and enabling SATA I/150/1.5Gbps (if this is an option). You may even want to try lowering the speed of your SATA drive from 3Gbps to 1.5Gbps (usually possible through the manufacturer's disk utility)... As I have seen this cause problems on a couple of (Intel) platforms and it could possibly be responsible for your IDE/SATA driver frustrations as well...

    A clean install should fix this...
    I know, this may contradict the troubleshooting steps you took previously. However, I'd like you to try it again - if - you don't have any data to hang on to. Try a clean install with Windows XP x64 and make sure to delete and repartition the drive this time. This should rewrite the the MBR and your problems should go away. I'd also be interested in seeing if installing Windows on your RAID setup (or a different drive on a different controller) makes a difference or not.
    1 person likes this.
  7. Starfox00000

    Starfox00000 TS Rookie Topic Starter

    good :D

    and tried every solution on several diffrent installs lol :p

    I knew that, one of my reasons for deciding to go 64bit.

    OK, I tried booting with hirens boot CD, and it DID boot. WEIRD. it also has a delay and if you dont do anything goes to windows, so either two things: 1. windows doesnt like being booted to first (wtf?) or 2. windows sucks so hard it needs to take a break now and again to rest lol. Is there a way to set a delay before windows loads? that would be helpful, mabey in NTDRL (or whatever the acronym is.)

    I dont think its a coencidence or even having to do with windows that would leave hardware, but what kind of harware malfunction could cause this?

    I first tried windows 32 bit and after giving up went to 64 bit. never tried 32 bit after 64 so i couldnt have a 64bit NTLDR with 32bit windows.

    I think your right, but I am using the original windows SATA and IDE drivers, installation of updated SATA drivers dosent help and the IDE drivers are, well, bad to say the least. Could my mobo's SATA and/or IDE controller be damaged? What doesnt make alot of sense is that why would my SATA drives get delayed write failtures after installing IDE drivers. Thats almost as weird as this whole thing so I think it could somehow connected.

    I would need to do this to use RAID, but as it is Im not and just use the regular windows install, and all my HDD's are 3.0Gbs SATA and are relatively new.

    SHOULD lol :p the 10 or 15 clean installs I did didn't help, and I already have some stuff setup (I keep all important things on the HDD's that dont have windows and just installed windows on one drive) so I dont want to do this unless necessary, just because i dont think it will do much.

    thanks so much for the help :D
  8. Starfox00000

    Starfox00000 TS Rookie Topic Starter

    Update: I had a though, why not try a non-bootable cd and see if windows would boot then. The awnser: no, windows will not boot with out a bootable cd. just though this might help a little. Thanks again
  9. Rick

    Rick TechSpot Staff Posts: 4,572   +65

  10. Goalie

    Goalie TS Booster Posts: 616

    While I pale in the hardware experience in comparison to Rick, maybe I can contribute. In my experience hal.dll is an error that comes up with non-native support chipsets. I've skimmed the thread and not seen it mentioned yet- Have you checked for motherboard/chipset driver updates?

    It's not uncommon for the driver CDs with motherboards to be outdated or even extremely nonfunctional at best. I would get the lastest from the website. You may even want to look at a bios flash - it sometimes can fix a wierd driiver issue, but not usually.

    The mobo maker may have a driver that solves things without the NVidia IDE drivers. Also- when you get to downloading those controller drivers, you'll sometimes get several options with them. Read carefully, as they'll have "only if" conditions attached to them.

    Let us know..
  11. Starfox00000

    Starfox00000 TS Rookie Topic Starter

    On this install I got all the latest drivers for everything that need installing, sound, mobo, video, etc. and I have the latest bios flash so yeah. The nvidia ide drivers come in a pack with the chipset drivers but you can choose not to install them like I do. thanks for the help but like i said i already tried everything that usually works (anything i could think of actually wether i though it would help or not.)

    Mabey i have windows RG lol.

    EDIT: Windows is still working well except for the CD-Thing, Im considering buying a drit cheap CD drive of newegg (i have an ide open) and simply leaving hirens boot cd in there. It would be convienent to have an OS you can always get to if something goes worng and it wouldnt cost much, what do you people think?
  12. Sam4

    Sam4 TS Rookie

    XP won't boot without CD - fixed

    I had the same thing happen to me this week - I would get the HAL.DLL corrupt message - but only if the Windows CD wasn't in the drive, even though I was not booting from it. It has been extremenly frustrating. At one point I had fixed it for a while then something else made it start again. Anyway the fix for me was in the BIOS. Somehow, it had placed the SATA drive ahead of my C drive in boot priority. Once I switched it back to the C drive first it was OK. It is not on the main BIOS screen where you pick CD-ROM, USB, hard drive, etc. It was somewhere else - maybe on the IDE page.

    I think what happened was I had installed a second copy of Windows to try to recover things from the main copy, and somehow that switched it. I had been running recovery console a bunch of times from the 2 versions at times. Also the first time I fixed it I had run FixMBR and FixBoot from the recovery console, but the last time that did not fix it, the BIOS setting did, once I stumbled on it when I had updated my BIOS. ANyway, if the BIOS setting doesn't fix it, you may have to run those 2 things from recovery console. It warns you that fixMBR may mess up your hard drive, but it didn't mine. Also I saw on Microsoft's site that the message is not real.
  13. moeezzy1

    moeezzy1 TS Rookie

    bug memory leak try reinstallning the whole dam thing
  14. tyrsis00

    tyrsis00 TS Rookie


    In my experience, most of the time when this error occurs, you can go into the BIOS and set the hard drive you want to boot from as a higher priority than the CDROM drive and it will work. For some reason, some motherboards have issues booting to the hard drive if they try to boot to the CD first (all the ones I've seen have been issues with SATA not recognized if the CDROM is selected as a boot device before the SATA drive). Some, I've only had issues with this if the SATA is setup to use RAID instead of just standard SATA.
  15. Mafiarat

    Mafiarat TS Rookie

    Check the Drive Letter Windows is assigning the Installation. if your motherboard boots to C: and Windows is installed on H:, M:, etc. you will get that error.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...