Windows XP Won't Install New USB Drivers

By RedSwirl ยท 84 replies
Feb 7, 2007
  1. mtasquared

    mtasquared TS Rookie

    it worked for me too

    Thank you DigitalOxygen! I had this usb problem and I tried everything under the sun with no help. But replacing the entire inf folder fixed my computer. Yeehaa!
  2. mpfinn

    mpfinn TS Rookie

    Windows XP won't install USB devices

    It has been 2 days and arround 5 hours working on this issue. I was unable to install my new Microsoft Wireless Media Keyboard and Mouse along with the HID Non-User Input Data FIlter drivers identified while attempting to install the prior.
    Removing Microsoft's own Service Pack 3 resolved all of my issues. A company that loves to step on thier own feet.
  3. mpfinn

    mpfinn TS Rookie

    Also, I returned a Kensington Wireless Key Board and Mouse prior to this because it had failed to install. I am sure the service pack 3 was the problem there also.
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    A bios update might have been useful prior to installing SP3. I have installed XP SP3 on 20 computers ranging from 3 to 9 years old... No problems were encountered, although most all of these computers were freshly formatted before a "clean" XP SP2 install was done
  5. pelkiukikimara

    pelkiukikimara TS Rookie

    solved this problem

    i don't know how by you all, but when i've got this problem, i had only service pack 2, now i downloaded sp3, restarted and problem solved :) i hope this will help for someone :)
  6. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Hooray for XP, SP3! It is always wise to install Windows Service Packs. If you don't you should be running Linux, and not Windows
  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    100% absolutely as Tmagic650 points out.

    And for anyone else finding their way to this thread, please see this post: [post=744411]USB Device Problems? Check for Windows Updates[/post]
  8. s6g2k

    s6g2k TS Rookie

    Just to join the chorus, I too was afflicted with this problem. This is the only place where I have found anything really useful. Thank you all!

    Using a dell x300 (with media base), I had a logitech usb headset and a flash drive that didn't work. They would show up as "other devices", windows would not find drivers, blablablabla. Interestingly, I did have an older flash drive that did work, a DCS camera, a Creative MP3 player. Granted for the player, I did install software.

    I was almost at the point of doing an OS reinstall of some sort, but really didn't want to (I got the laptop used and could not reload some of the cool apps if they went away). I knew that these two devices worked on another computer, so I copied the c:\windows\inf folder from that computer onto a cd. on the dell, I created a new folder, c:\window\inf_bak, and moved the contents of c:\windows\inf to that folder. I deleted everything in c:\windows\inf and moved the other computer's folder contents to that folder. I can't remember if it required a restart to make it all go, but everything now works! no problems. I did have to direct device manager to find the drivers for the flash drive, but the headset started with no prompting.

    three things
    1) I left the cd with the new inf folder in the drive and It seemed that the CD was searched for the drivers for the flash drive.
    2) I don't know if I needed to, but I did the above file transfers in safe mode from the command prompt. I went this route because I couldn't delete the inf folder (makes sense). I may have been able to do this from windows, but I didn't. I am believing that if you are here, you probably know a bit of something so you'll probably figure it out.
    3) I do own a copy of winXP, but I chose not to copy files from there as the files in the "inf" folder were called "<filename>.in_". Didn't want to try to make those work though they may have.

    I did a test and restarted the computer without the cd in it and both devices restarted with zero prompting. I am very happy now. I could have worked around the issue, but I really didn't think I needed to. Thank you everyone for the tips and tricks!
  9. s6g2k

    s6g2k TS Rookie

    I meant to mention - Windows XP SP3 - reloaded several times and it still had this problem.
  10. s6g2k

    s6g2k TS Rookie

    follow up, two days later...
    Most everything is still good. Several restarts, some just for testing, and devices are still recognized.

    One thing that occurs is that I don't get the little comfort balloons telling me that such and such a device is installed. Nonetheless, they install.

    I think this is unrelated, but occasionally the combo-drive in the "media-base"/docking station of the X300 is not recognized and I need to re-dock. Note that this computer is a pre-netbook kind of system. Laptop itself only has HDD and usb - no optical drive at all. the media base provides hook up to other peripherals and also the connectivity to monitor, etc. Note that I am not looking for help on this. I am just including for information.

    Thanks again
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...