Windows XP Won't Install New USB Drivers

By RedSwirl · 84 replies
Feb 7, 2007
  1. Hi, right now I'm going around every PC support board I can find in order to solve this problem I've been having on my laptop.

    For some reason now whenever I try to plug in a new USB device that's plug-n-play (meaning it shouldn't require any installation procedure) like my PSP, an external hard drive, or even a new USB flash drive, the Found New Hardware Wizard will appear, search for the drivers to install the hardware, won't find them, and then simply won't install the device.

    The only USB devices it takes now seem to be things that were already installed long ago like one of my USB flash drives, my mouse, my camera, and my printer. Nothing else works.

    When I tried to contact Dell, we tried to uninstall every USB driver in the computer and then reinstall them and Windows XP would not accept any of them. After that Dell said that I needed to reinstall Windows but I'm sure there must be some other way to fix this problem.

    On top of that, because nothing new I try works, I don't have any way of transferring anything from my computer that won't fit on the 128MB flash drive that I have for it, which means I have absolutely no way of backing up most of the stuff on this computer.

    Has anyone else ever had this problem?
  2. jobeard

    jobeard TS Ambassador Posts: 11,177   +990

    I think it's a procedural issue to make this work.

    1. uninstall the device driver(s) and the HUB too
    2. power off (not restart)
    3. now cable the device to your system and then power it on (if applicaable)
    4. boot your system
    The driver for the USB HUB and the specific device should be reinstalled for you.
  3. orko1978

    orko1978 TS Rookie

    I would have to echo Jobeard's comments and...

    thanks to backward compatibility, this definitely is USB Hub related. You also might want to check to see if inactivity is disabling these and not able to logically regrant power. Go to Control Panel>System>Hardware>Device Manager>USB Controllers>USB Root Hub>(right click)>properties>power management(uncheck top box, check lower box) restart
  4. roggers

    roggers TS Rookie

    iv got same problem. if i borrow my mates USB drive and plug it in, it tells me i need to install the drivers and software from the CD, but all my old USB devices still work. would installing drivers i.e Ipod and samsung phone drivers corupte my USB's? as i dont have the back-up CD on me i dont wana try anything to knacker my computer up as i am in need of it till weekend! appreciate some help, also i have tryed the above solution but found they have not realy helped me
  5. RedSwirl

    RedSwirl TS Rookie Topic Starter

    When I check USB in the device manager, all of these show up:

    This laptop only has two USB ports in the back so what do all the "HUB"s mean?

    Intel(r) 8280 1DB/DBM USB2.0 Enhanced Host Controller - 24CD

    Intel(r) 8280 1DB/DBM USB2.0 Enhanced Host Controller - 24C2

    Intel(r) 8280 1DB/DBM USB2.0 Enhanced Host Controller - 24C4

    Intel(r) 8280 1DB/DBM USB2.0 Enhanced Host Controller - 24C7

    USB Root Hub

    USB Root Hub

    USB Root Hub

    USB Root Hub

    Not sure what you meant by "device drivers" but I went and uninstalled everything that was under USB in Device Manager, powered off my comp, connected a device I wanted to use, then powered the system back on and booted it up.

    When I did that the system reinstalled three of the drivers I listed above, but did not reinstall the one that said "Intel(r) 8280 1DB/DBM USB2.0 Enhanced Host Controller - 24CD", nor did it reinstall the four HUBs I had. So now the Found New Device Manager keeps coming up repeatedly and all the HUBs are gone.

    ...and now I can't stop the found new hardware wizard from popping up. even if i tell it not to try to install the hardware (which is one of the USB drivers in the system) ever again, it still comes up, even when I restart the system or try system restore.

    Also, neither of my USB ports work anymore.
  6. orko1978

    orko1978 TS Rookie

    Do Not Fret

    Redswirl, what is the make and model of the computer?
  7. RedSwirl

    RedSwirl TS Rookie Topic Starter

    Dell Inspiron 8600.
  8. orko1978

    orko1978 TS Rookie

    Fix the USBs

    Allow the prompts to reinstall whatever they want. Let the wizard search applicable subfolders in this directory. 'C:\dell\drivers' If this doesn't work, I'd be glad to help you through RD. email me,
    email removed
  9. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    For what it's worth, whenever I insert a new flash drive into a USB port Windows XP gives me the found new hardware message. It does this for each USB controller, in fact. However, in my case the difference is Windows finds and installs the driver and I'm good to go.

    If Windows isn't finding the driver, you may have to reinstall Windows despite your reluctance to do so.
  10. RedSwirl

    RedSwirl TS Rookie Topic Starter

    Didn't work. The Wizard wouldn't let me search that folder at all. Said it didn't contain any driver information files.
    And what's RD?
  11. orko1978

    orko1978 TS Rookie

    What is RD?

    Remote Desktop
  12. RedSwirl

    RedSwirl TS Rookie Topic Starter

    remote desktop? i'm trying to fix this on a laptop!
  13. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    It's a feature of your O.S. Try googling the term remote desktop to get an idea of what orko1978 is talking about.
  14. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Yes mailpup,
    I see this in my laptop repairs from time to time, and the only thing that fixes the problem is to reinstall Windows
  15. nick carntowan

    nick carntowan TS Rookie

    My USB ports have suddenly stopped working fully too. Previously working devices continue to work correctly but I cannot connect new ones. When I try, Windows recognises the new hardware and launches a wizard to find a driver but then fails to find it either locally or on the Internet. Subsequently the device is ignored when plugged in. The devices all work correctly on my other (laptop) PC.

    The system with problems is a Mesh desktop PC running WinXP Home SP2 with automatic updates enabled. My old Olympus digital camera, HP printer and 256MB flash drive still work fine however my new Panasonic digital camera, 2GB flash drive and LG mobile phone do not work on the Mesh but are fine on my Toshiba laptop.

    I am aware of one event that might be significant. I have a cheap webcam that used to work on the desktop but I unplugged it to use with my laptop. That was fine except that it will not now connect to either PC. This was the first instance I noticed of a USB driver not being found (although I hadn’t uninstalled the webcam) but it doesn’t appear to have affected the laptop in any other way.

    I have tried unplugging all USB devices and un-installing all USB drivers. On re-booting XP finds the 3 USB controllers (I have 3 pairs of physical USB ports) but cannot find the driver software. I have done a System Restore to get back to where I was before. There are no question marks in Drivers under USB devices and under Devices I have deleted the USB camera and USB drive which did display yellow question marks.

    My motherboard (ASUSTeK Computer INC. A7N8X2.0) is not listed on the manufacturer’s site (presumably because it is a “special” manufactured for Mesh) so I can’t search for updates.

    Any ideas on what is wrong and what else I could try? Re-installing Windows is too big a step for me (I only have the recovery disc as it was pre-installed by the manufacturer).

    P.S. Would something like Diver Magic be likely to help me?
  16. orko1978

    orko1978 TS Rookie

    Idea for you

    RedSwirl, I've been thinking about your problem and realized another option. Backup your stuff here, and then reinstall your OS.
  17. RedSwirl

    RedSwirl TS Rookie Topic Starter

    Oh, I got everything to work now. I just told the Wizard to look in C:\I386 and it found all my drivers again and was even able to install new ones.

    Whenever I put in a new device that's plug n' play the Wizard still shows up which I know shouldn't happen, but so far I've been able to tell the Wizard to look in C:\I386 for every device and it installs eventually, even if I have to tell it where to look for several more files (in the same place).
  18. nick carntowan

    nick carntowan TS Rookie

    Perhaps the c:\i386 folder would help me too. However the wizard no longer appears when I plug in my "new" devices - it only popped up with "Recognised ne hardware" the first time they were connected. Can anyone help (i.e how do I force it to attempt to install the devices)?
    I ran Driver Detective (drivershq) and under "Unplugged Devices" it lists the memory key, digital camera and mobile phone but marks them with "No driver found for your device".
    Driver Detective also lists under "USB Controllers" 3 controllers: Standard Enhanced PCI to USB Host controller; Standard Open HCD USB Host Controller; and USB Composite Device. The first of these is marked as "driver is not up to date" but the other 2 are OK. I have not (yet) signed up to download the newest driver as I'm not convinced this is a problem - several other drivers are listed as out of date without giving problems e.g. most of my NVIDIA drivers.
    By the way, since my laptop has installed the devices OK can I copy the drivers from there - if so, how?
    I'd appreciate any help.
  19. groomo

    groomo TS Rookie

    Me neither

    Hello there this is my first post and would appreciate your help a lot if possible. I have exactly the same probelm as outlined above. Everything that was on ym pc before it going wrong works fine on the usb and everything I try and plug in after doesnt. This even comes down to I have 2 usb flash drives exactly the same. 1 works as was used before the computer breakage, but the other doesnt as was trying to use it after the computer breakage. I have unfortunately not got the windows xp cd as do not believe i got with the comp. I have a Dell dimension 5000
    intel pentium 4 3.40 ghz
    1 gb ram
    nvidia geforce 6800

    I have ran a program called version tracker pro which has advised me I need updates for the following

    I downloaded these and installed. But each time I run this program it says I still need to update them.
    I have also tried the above suggestion of the i386 file. I had nothing in this file at all. My dad had a windows cd kicking about that had this file on it so i copied its contents accross. thinking that it might find them in here and if not then I can jsut delete. It didnt find them in here either

    I think this all started when I got a external enclosure for a hard drive which didnt work. I may of accidently installed a windows 98 driver for it. Im not sure. I have tried rolling back comp but this does not work either.

    I also read somewhere to type in "sfc /scannow" which would scna the system files looking for any problems, alas that did not seem to work for me. Its quite anoyigng as I am sure that the files are actually there, it is just the computer does not seem to recognise they are. Is there any files i could replace from another windows xp installation in the driver files that may cure things?

    Crikey for my first post its a bit pleading and a bit of a essay. sorry! Anyones help would be greatly appresciated and I will try and help anyone with any other problems in the future. Thank you

  20. orko1978

    orko1978 TS Rookie



    Did you try simply uninstalling the USB hubs, rebooting, and when they are found fetch drivers online? The windows update should identify the components and provide updated drivers. Cheers. :D
  21. glassceiling

    glassceiling TS Rookie

    I too have been all over the internet looking for a simple fix, I am aware of the reload, but will it work, has anyone else done it and it worked?

    I spent a lot of time yesterday burning DVDs as a back up. I tried a update HP suggested but it caused my external usb hard drive that was working to stop.
    HP was no help at all, in fact the guy tried to blame everything on the devices, didn't matter they worked fine else where.

    There are a lot of people out here with this problem, it amazes me Microsoft hasn’t jumped in with a fix. Or am I not surprised !!

    I tried the i386 folder and it was empty as well as when I selected it the ok button was grayed out, maybe because it was empty.

    Does anyone know where else the needed files may reside.

    I downloaded Tuneup Advisers RegCurebut, it claimed it would fix the problem but it didn't do anything to fix my problem and now I'm out 30 bucks and the site doesn't have a contract link, if I had noticed that I wouldn't have gotten it, but I'm getting somewhat desperate with this plug n play problem.

    Does anyone know if reinstall will fix it?
  22. groomo

    groomo TS Rookie

    I did this before I remembered my mouse/keyboard were usb :p DOH! just gonna grab a ps2 mouse/keyboard. Will update thread with any progress
  23. groomo

    groomo TS Rookie

    hi me again

    It turned out that ther was no ps2 ports on this computer which made things a tad crap! What I eventually having to do was swapping my hard drives round and installing windows on my other one this, thank god, solved my usb problem. But I imagine there must be a easier way! I will be keeping my eye on this thread, too see how the rest of u get on with ur errors and will keep my eyes oopene for any mroe information. Thanks again. AND REMEMBER



  24. Sly319

    Sly319 TS Rookie

    Yep, me as well

    Hi all - just wanted to jump on the bandwaggon and say that I now have this problem as well.

    I have 'lost' the last two weekends trying to get my sons Kodak camera recognised along with a Western Digital external hard drive - both of which 'plug and play' on both my and my wifes laptops but my HP D330 wont have anything to do with either of them. All my existing USB devices work fine at the moment.

    This looks to be a problem that has occured to a number of people since January, could it be a 'service release' that has caused the problem as I havent had this issue with flash drive devices that I have installed in the past? It also looks like its only related to storage device type devices (!)

    I cant remember if I tried using the i386 folder (sure I did though) as a lookup but I will try that tonight.

    Attempted to re-serive pack (SP2) but that didnt make any difference - typically I was trying to get the external drive working so I could back everything up before I tried a XP re-install!

    Glad to see I am not alone but would rather everything worked!

  25. groomo

    groomo TS Rookie


    I dont think that this is a service pack fault. I had thought tis too for a moment. If it was then surely Everyone would have it. When I reinstalled windows it all seemed to work ok and didnt lose anything which was good. Could it possibly be tried to instal a driver for something that didnt need one? and ended up installing a win98 driver. I think this is what happened to me possibly.

    Good luck tho. Ive been there and its not a good place to be !
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...