X won't start on fresh Mandrake 10.0

By RealBlackStuff ยท 16 replies
Jun 26, 2004
  1. I finally took the plunge and installed the latest Mandrake 10.0 Official (3 CDs) on a spare PC.
    It has Kernel 2.6.3-7mdk on an I686/tty1 if that means anything.
    Asus P2L97-S (SCSII)mobo with PII-300 and 128MB memory, Matrox Milennium G200 8MB, and a 10GB harddisk.

    During install, I did not (yet) configure the network card (Interface eth0 failed) and the soundcard (SoundBlaster AWE64 Value, ISA) was not found/recognised.

    Linux is the only OS and was allowed to use the whole HD during install.
    I can log in with my Username (being the only user, so no password installed), but when I type "startx" after the xxx]$, I get "execve failed for /etc/X11/X (errno 13)".
    I have run xf86config a few times, but to no avail. The config-file in the X-directory looks fine.
    I have re-installed twice, but I keep getting the same error.
    Any suggestions?

    PS: this is my first shot at Linux, so bear with me...
  2. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Could you attach your XF86Config file so we can have a look at it ?

    & also the /var/log/X*.log ( I'm not sure if Mandrake 10 uses XFree or Xorg ).
  3. RealBlackStuff

    RealBlackStuff TS Rookie Topic Starter Posts: 6,503

    Thanks, Didou.
    I don't find any /var/log/X*.log files. The .log files that are there say "access denied"

    Following is my XF86Config, with all # lines taken out:
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    "access denied" means that you are trying to look at them as a non-root user. Please log in as root and try again. The X log files should be in /var/log. Post the contents of this directory if you can.

    You can also try starting X as root and trying to start plain X by running "X"
  5. RealBlackStuff

    RealBlackStuff TS Rookie Topic Starter Posts: 6,503

    No can find any X-files (I am not surprised, where are Mulder & Scully when you need them?)

    Found the following in /var/log:
    auth.log, boot.log, cron, daemons, dmesg, explanations, kernel, ksyms.0 - ksyms.6, lastlog, epr, mail, mdkkdm.log, messages (see contents below), news, samba, scrollkeeper.log, secure, security, security.log, spooler, syslog, user.log, wtmp

    Found 1 dead body though: mdkkdm[943]: X server unexpectedly died, see somewhere below

  6. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    So what happens if you run X manually instead of startx? Just run "X".
  7. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    I wouldn't be surprised if it was because of 128 MB of physical memory. Linux distributions have gotten bloated these days, especially Gnome and KDE.
  8. RealBlackStuff

    RealBlackStuff TS Rookie Topic Starter Posts: 6,503

    I get the same error, whether starting as root or user, and it makes no difference if I enter X or startx.

    I'll "borrow" another 128MB from my daughter's PC, see if that helps. If that is the reason, then Linux has well grown beyond it's basic needs, AFAIK it should run on 32 or 64MB!
  9. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Linux runs fine even on 16MB. And X should run OK too.

    It is the window managers that have bloated beyond common sense.

    You could try updating the X packages to the latest version or installing a vanilla version of X from www.xfree86.org.
  10. Didou

    Didou Bowtie extraordinair! Posts: 4,274

  11. RealBlackStuff

    RealBlackStuff TS Rookie Topic Starter Posts: 6,503

    I will re-install just once more. I know hardly anything about Linux, let alone how to update any program. This PC is not connected to my network nor can it go online, its only communication at the moment is via floppy or CD.
    I am not willing to run a command-only Linux, if this X cannot be sorted out. I know enough about DOS but Unix is still beyond me.
    If I can't get into any GUI, I will forsake Linux, I think.
  12. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Allthough it is a good idea to try a RedHat based distro for your first jump in Linux, RedHat distributions aren't really known to run well on "limited" hardware.

    A Debian distribution is more suited for that kind of hardware but the installlation isn't quite as easy.
  13. RealBlackStuff

    RealBlackStuff TS Rookie Topic Starter Posts: 6,503

    A 300MHz CPU and 128MB ram and 10GB HD are not really limited. Also, the Matrox Millennium G200 that I use is supposed to be the best-supported and least problematic of all graphics cards for Linux.

    This new Mandrake 10 is supposed to be an all-singing, all-dancing distro. So far it has yet to even beep at me, let alone show me anything better than multi-coloured log- or setup-files, that need to be accessed through an extremely primitive editor (vi).
    As the UK Queen Vic said "we are not amused".
  14. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Like I said, the Mandrake distro (especially with a 2.6 kernel) isn't meant to be run on that kind of machine. You would be better off running a Slackware or Debian on that.

    I'm hapilly running a RedHat 9 (shrike) on a K6-2 450 with 384mb of Ram. I mostly use it in text more via ssh. When I log on the machine itself, I use xfce instead of KDE/Gnome. If I had to work on it more often on it in graphical mode, I would remove RedHat & install something else as even with xfce it's not very snappy in response time.

    Try reinstalling Mandrake, installing only the necessary packages. Then configure it to boot in text mode (you can always set graphical mode sa default later on). Once you've done your first boot, it would be a good idea to run urpmi xfree86 or urpmi xorg, depending on which X server is installed with that distribution (but you're gonna need an Inet access ). That will update the X server to the latest version, in case that's what giving problems.

    PS. VI is quite far from being primitive. It might not be very intuitive but primitive it is not.;)
  15. RealBlackStuff

    RealBlackStuff TS Rookie Topic Starter Posts: 6,503

    Today must be my lucky day, because third time around, it worked!

    After reading up on the Mandrake website, I left out the option "LSB" (sounds like a drug to me), paid really good attention, et voila, everything works EXCEPT again the soundcard.

    When on the Desktop, I click on Run, type in "sndconfig" w/o quotes, but nothing happens. I don't mind having no sound, but I would still like for it to work.
  16. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Try opening a command prompt & then type the following

    *enter password*
  17. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    LSB = Linux Standard Base
    It is a set of "must have" programs for a unixoid system.
    Mandrake setup didn't complain if you removed that?!
    Really clever.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...