Getting an X gui on a windows box

By Ian Rutherford ยท 4 replies
Oct 13, 2005
  1. Help!
    I'm pretty much a linux noob and I'm trying to admin a remote redhat server here from a windows box (I have no physical access to the server). It came fairly bare-bones, all I have is ssh for access, and I'm trying to get a GUI working remotely. I installed the latest XFree86 but of course the server has no mouse or video. So I've tried both Xwin32 and Cygwin/X and they both seem to have the same problem - whenever I run 'X -configure' it always comes up with the same error:

    XFree86 is not able to detect your mouse.
    Edit the file and correct the Device.

    And when I try 'XFree86 -xf86config /root/' as it suggests, I get the same thing:

    (EE) xf86OpenSerial: Cannot open device /dev/mouse
    No such file or directory.
    (EE) Mouse0: cannot open input device
    (EE) PreInit failed for input device "Mouse0"
    No core pointer

    Fatal server error:
    failed to initialize core devices

    Isn't Cygwin/X supposed to emulate the mouse and the display for me? I'm running an 'X -broadcast' on the windows machine and have followed the advice of some good online tutorials to get this set up properly. How do I get this to work? Thanks in advance for any advice.

    - Ian
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Uninstall the X server from the Linux box. You are not displaying anything on the server so you don't need to run the X server software either.

    If you want to run single graphical apps from Linux then you can use Cygwin just fine. Run the Cygwin X server. Log into Linux with SSH (make sure X forwarding is enabled) and run your graphical program from the command line. The window should magically appear on your WIndows desktop.

    If you want to have access to the Linux desktop, install a VNC package and run vncserver instead of the X server in Linux.
  3. Ian Rutherford

    Ian Rutherford TS Rookie Topic Starter

    OK I uninstalled XFree86, but I still have the problem that I can't install apps that require XFree86 (eg tightvnc)
    How do I get around this?
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    There are many parts to X. You do need the X libraries. What you don't need is the actual X server (since you won't be using any displays/mice on the server).

    It would be a good idea to use yum or apt-get to install software so only needed components are installed with things.
  5. jobeard

    jobeard TS Ambassador Posts: 11,138   +985

    See the Exceed Hummingbird; an excellent choice for X based applications. For remote systems,
    of course you'll need a DNS to resolve the name and if it's interior to a corporate
    firewall, you're going to need a VPN connection.

    The Xterm $hostname:n command will create a window on your PC for
    accessing $hostname. the :n is a reference to the frame buffer,
    typically '0' (zero)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...