XP detects IDE ODD as SCSI

By JoeyT ยท 6 replies
Apr 18, 2007
  1. Hi, new to the boards so I hope this is in the right place, if not you have my apologies.
    Theres probably a really simple solution to this th atI haven't thought of. I built a new system on a Foxconn motherboard recently, thought everything was working fine until I tried to burn a disc for the 1st time. Found that the dvd burner I'd bought and cd burner I'd taken from a previous machine weren't being recognised as anything other that readers. After lots of swearing I realised that both are being detected by XP as being SCSI instead of IDE. Anyone experienced this before and know how to get around it?

    XP Home SP2
    Foxconn P9657AA-8KS2H Motherboard (95% sure, not at home to check it)
    Sony AW-G170A DVD+/-R/RW
    (Some old Lite-On CD +/-R/RW)

    Don't think any of the other spec are particularly relevant but happy to give more info. Both ODDs use windows generic drivers and I've checked that I've got the most up to date drivers and firmware for them.
    Thanks in advance.
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Are you running any SATA hard drives? If not, make sure you set the SATA controller (if any) to IDE
  3. JoeyT

    JoeyT TS Rookie Topic Starter

    I've got 1 250GB SATA
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Are you sure the optical drive isn't SATA too?

    Many SATA controllers look like SCSI to Windows.
  5. JoeyT

    JoeyT TS Rookie Topic Starter

    No both ODDs are IDE, no connections for SATA on them (from what I'd read before buying it seemed the motherboard doesn't support SATA optical drives yet)
  6. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    If you have a single IDE channel, make sure the ODD's are configured as Master/Slave and not cable select. The bios should list the ODD's first, then report the SATA drive later, after the SATA controller is reported
  7. JoeyT

    JoeyT TS Rookie Topic Starter

    DVD is master on end of cable, cd is slave on second slot. I'm just trying to update my raid controller in the hope that its a conflict the wonderful windows isn't picking up.
    Thanks for the help so far, it makes me feel that the things I've tried so far aren't quite as stupid as I was beginning to fear ;-)

    Cracked it! I had to track down some JMicron drivers (windows couldn't find them) from their less than intuitive site but I've finally beaten the darned computer. Phew. Now to put them somewhere safe before the system crashes again.
    Thanks for the advice guys, I'll see you around the site
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...