1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

XP Pro RDP won't connect

By PRBROWN ยท 15 replies
Jul 14, 2008
  1. Machines: Dell Optiplex GXS270(client)
    Dell Dimension xxxx(host) Both machines standard setup
    OS: XP Pro SP2 on both. Norton AV 2004 with current updates.
    Client pc uses cable modem; host uses dsl. All settings for RDP as per MS KB.
    Host uses static ip. NAV firewall configured to allow remote control on both. Host pc is on p2p network. Host is primary; secondary pc connects via wireless. Error msg states "..Cannot connect at this time.." or similar. I followed instructions and feel confident the settings are correct. Still cannot connect.
    Any thoughts?
  2. ITGuy702

    ITGuy702 TS Member Posts: 70

    I apologize if you have already checked this. But it never hurts to start at square one when troubleshooting, right?

    Have you checked to see if "All users to connect remotely to this computer"?

    How to check the above:

    1. Click on Start
    2. Right-Click on My Computer
    3. Click on Properties
    4. Click on the Remote tab.
    5. Check the Remote Desktop check box if unchecked.

    Also, I know you said that NAV firewall is configured to allow remote control. But is the Windows firewall disabled?

    Is the computer you're trying to connect to behind a router? If so, is port forwarding for RDP turned on? RDP uses port 3389.

    PRBROWN TS Rookie Topic Starter

    RDP problem

    Thanks for your fast response. Yes, I have checked and re-checked those settings. Also, I am aware of the ports. That's why this is so bewildering. I have implemented this procedure many times. While each one has its own problems, this one is particularly troublesome. I know I must be overlooking a switch or a check box somewhere, but everything appears to be correct.
    Thanks again...
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Administrator accounts?
    password set or not?

    All the ipconfig / release done ? (Lots more info Here)
    No Virus/Spyware ? Scans done?

    You know what I do is when they just won't connect, is physically connect them via ethernet. Then return them to normal, and sometimes all works ok (I understand this may not be possible remotely)

    PRBROWN TS Rookie Topic Starter

    Thanks for your reply. All AV, spy- adware configured, admin rights, pw set. Didn't release the ip, however. I did do several hard restarts. Great suggestion on direct-connect; unfortunately not possible because of distance. I will bring a laptop to simulate that procedure.
    Again, thanks for the input.
  6. ITGuy702

    ITGuy702 TS Member Posts: 70

    That's odd....:confused:

    try the following site to verify the port is open:


    If you receive an error...I strongly suggest you to disable* the firewalls to test the connection.

    * I know you said the firewall is configured, but have you tried to disable it for that "just in case reason"?

    If that doesn't work then I wonder for whatever odd reason one of those ISPs are filtering or blocking that port. Not sure why they would since it's a common port. But it is possible as my ISP filters just about everything. :mad:

    I hope this helps. I know how frustrating it can be.
  7. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    I like that page

    So I tried it, here's the results, no firewall, no live protecting anything programs running.

    Error: I could not see your service on **.***.**.*** (note: I removed the IP) on port (3389)
    Reason: Connection timed out
  8. ITGuy702

    ITGuy702 TS Member Posts: 70

    LOL! Is that sarcasm? :)

    Are you behind a router? Or does that fall under "no firewall"?

    If you are and port forwarding for RDP isn't set, I'm pretty sure the test will fail.

    Also, another site to consider would be:

  9. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Oh sorry that's a port forwarding port only'

    Anyway I did the above (only with Windows security updates - no other security)
    And it passed !

    How strange

    Anyway, I am fully aware of security issues, actually up until about 2 years ago, I wouldn't even browse the net without having full anonymity, those days are gone hey? These days I'm protected only from the boards IP being used not mine in this open forum.
  10. ITGuy702

    ITGuy702 TS Member Posts: 70

    That is strange...

    I hear ya. Nowadays, the threats are everywhere...it's ridiculous.

    I think I can be considered borderline paranoid when it comes to security sometimes. I try to practice "safe surfing" as much as possible. :)

    Although, a person can have "all the security" available and still get compromised. Nevertheless, security is important.

    PRBROWN TS Rookie Topic Starter

    I will try the link you posted tomorrow. If that doesn't solve my problem, then I will try third-party software or suggest (yelch!) a subscription service. (Although, they would probably encounter the same anomoly...)
    Thanks for all your help.
  12. ITGuy702

    ITGuy702 TS Member Posts: 70

    Remember to disable the firewalls...

    IMO, the chances are that if you try another product you may still have this problem. I would hate to see you spend money on a product that doesn't work.

    Please note that I'm only basing this off the theory that something may still be blocking ports. So I could be completely wrong about the other products. :p

    Since I don't have 100% faith in software firewalls, I still urge you to disable them for this test. I mean, it's software...software has bugs (sometimes nasty ones at that).

    PRBROWN TS Rookie Topic Starter

    Again, thank you for your response. As I noted in my earlier reply, I do realize that aftermarket strategies could encounter the same anomoly. While this particular installation is proving to be troublesome, it is a procedure I have performed many times.
    I really appreciate the great suggestions from you and other members here at TechSpot. Whenever I encounter a problem that can't be resolved by myself and local resources, its good to know that there is a place like TechSpot that people can refer to.

  14. leoaraujo79

    leoaraujo79 TS Rookie


    I'm very late for help you I think.

    But i had the same problem that you and found the reason.

    I did try every thing to solve my problem and on the end format my machine, install every thing new and could not conect using rdp.

    So I install once more the windows xp, without my graphic card drivers, and it worked.

    If I install the driver it stop to work again.
    I have a geforce Fx550 and the driver I install was,
    I lost the cd that come with the card so at the moment my video don't work very well but i can conect on the rdp.

    hope it help you, and if you find any other solution let me know.
  15. leoaraujo79

    leoaraujo79 TS Rookie

    Its working now and i found another driver that makes my video card work aswell.

    93.71_forceware_winxp2k_international_whql.exe this driver is from 2006 and did the job and don't mess with rdp.

    I case some one had the same problem with nvidia.

  16. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Thanks for letting us know :grinthumb
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...