XP SP2 not recognizing USB ports.....I've tried it all.

By lneuman ยท 9 replies
Jan 24, 2005
  1. For no reason today my machine froze....after that my USB ports would not work. I've enabled USB2.0, enabled USB2.0, reinstalled the Intel Chipset Driver, updated XP with SP2 (although I already had it), set the ports to 1.1, checked the jump drive (USB device) on several other computers, searched Microsoft, searched the Internet.....I can't find any answer or fix. Any...ANY....insights would be much MUCH appreciated.

    Machine Stuff:
    Mobo: Soltek 915GPro-FGR
    Processor: Intel P4 2.8 GHz
    Ram: 1gb

    Please help.
  2. Anarchi

    Anarchi TS Rookie


    1) One of your USB devices have faulted, or is causing a resource conflict (or similar)
    -- Remove all USB devices, and reboot.

    2) Your USB chip/ports have been damaged.
    -- Find a spare HardDisk or bacjup your data and re-install Windows and see how that goes.

    3) Your Power Supply Unit (PSU) isnt supplying enough power to your PC (usually caused by a Video card upgrade). Try a more powerful PSU ... 400watts should do the trick

    4) Bad memory (RAM) can cause wierd problems. run memtest for an hour to make sure your memory is ok. go to w w w . memtest . o r g
  3. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    It sounds like you've done everything I would have tried.

    The only other thing I might do is save my information or use a second hard drive and reinstall Windows - Just for testing - And see if the USB problem is solved.

    If it is not solved, then you know for (almost) certain it is a hardware problem. That would at least help you get started in the right direction, because at this point it may be very time consuming to figure out.
  4. jamiedb

    jamiedb TS Rookie

    SP2 knocked out my USB too

    Installing Service Pack 2 on an XP Hewlett-Packard rendered all USB ports dead, although Device Manager did not show any errors in USB. Uninstalling SP2 was all it took to restore full USB functionality. Now I want to know the source of the problem...
  5. ChineseTechie

    ChineseTechie TS Rookie Posts: 85

    I wouldn't suggest installing SP2 either for XP. It sucks up lot more resource and create more problem than anything else.

  6. denniscraig

    denniscraig TS Rookie

    usb 1.1 works but updating to usb 2.0 stops recognizing usb 2.0 device

    Similar problem but also different. I recently purchased a amd 3000+ with asrock 754 board with upgrade to 939 facilitys, anyway I installed sp1 on and it was recognizing my ipod and my dazzle dvc 90 usb capture card. before installing sp2 i installed the usb 2.0 hotfix on update then it stopped recognizing those two devices. I then formatted and tried it again. it worked again till i put the full version of sp2 on. same story. My printer , usb stick, 3.5 floppy drive usb all work but then again they are not as resource intensive. I have tried to manually install drivers and they tell me that the drivers arent for the devices but they come with the hardware. anybody got any ideas?
  7. Elcamp

    Elcamp TS Rookie

    Microsoft Scanner and Camera Wizard not coming up automatically

    I have both Panasonic and Sony digital cameras and I have always been able to just plug in the camera to a USB port and a menu would come up automatically asking what I wanted to do, i.e. Open file to view pictures, Copy pictures to hard drive using Microsoft Scanner and Camera Wizard, or various other programs, etc. It was working fine as recently as Aug. 25th, but today, the menu does not come up automatically when I plug in my cameras. All my other USB devices are working properly.

    I have Windows XP Pro SP2. Any help with this problem would be appreciated.


    Elcamp :bounce:
  8. Neuron

    Neuron TS Rookie


    1. check out your device manager to see if there are any resource conflicts before you start needlessly ripping out hardware.

    2. Update your bios.

    Hit Start->run, type "msinfo32".
    expand "hardware resources" Copy and paste these three things:


    This will help find your problem. I also suspect it is an IRQ conflict. Most USB devices are put on IRQ 21.
  9. Fred

    Fred TS Rookie

    I ran into an IBM Thinkpad that had a similar problem with USB. USB devices couldn't be detected by Windows XP for some reason. When I plugged a Scanddisk Cruzer Mini thumb drive into the port the light lit up, but windows couldn't see it. I went into the cmos setting and tried everything but still no luck. There was another identical Thinkpad in the office with the same image on it and it worked fine, so I was not convinced that Windows was causing the problem. Instead I made a NTFSDOS boot disk that had the Panasonic USB DOS drivers and booted up from that to see if DOS could see the thumb drive and it couldn't, but the thumb drive could be seen on the good laptop with the DOS USB drivers. We had to send the bad laptop back to IBM for repair.
  10. jobeard

    jobeard TS Ambassador Posts: 11,170   +989

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...