XP won't let me change IRQ numbers!

By Master Toddy ยท 58 replies
Jan 30, 2003
  1. sargaana

    sargaana TS Rookie

    I already disabled ACPI, still IRQ settings cannot be modified. I've a centrino laptop, not sure if its possible with that.
  2. StormBringer

    StormBringer TS Maniac Posts: 2,244

    oh, its a portable, thats an entirely different animal. What is the make and model? Portables are a bit of a pain sometimes.
  3. sargaana

    sargaana TS Rookie

    I've a Samsung SensX15plus laptop with Intel Centrino Mobile (Pentium M) 1.5 GHz, Windows XP Pro, and NVidia GeForce FX 5200Go 64MB. It's got Phoenix BIOS ver OOBK.
  4. andygibbs

    andygibbs TS Enthusiast Posts: 60

    I had a belkin wireless pci card installed in my computer and working fine. Then i installed a new graphics card (geforce fx5200 256mb) into another PCI slot. In my third PCI slot i have a firewire card. When i installed my new graphics card, my wireless card stopped working properly. I have tried swapping the PCI cards round, putting them in different slots but it has made no difference.

    My graphics card is on IRQ 17, my wireless card is on IRQ 19 - so that shouldn't be causing a problem.

    Does anyone know what could be causing the problem?
  5. Myth

    Myth TS Rookie

    First of all I'd like to thank all of you for your help because I'm having these problems as well but mines a little differnt apart from others. This has tortured me for a month and I've been disscouraged in the process. Some one said within this topic that you can spend numerous hours trying to reslove a problem on your pc but then realize that your comptuer is owning you. I've been pwnt for atleast a month now and I'm loosing my sanity puke: . There are instances where the same devices are running within a differen't IRQ! But my biggest problem lays between my ATi Radeon 9600 Pro and my Adaptec AHA-2930CU PCI SCSI Controller being on the same IRQ. This is causing my system to crash my games and other applications with a IRQ Driver not less or equal error. After I reboot I recieve another error that Windows XP has encountered a serious error until I reboot again. I've tried everything that I could find or come up with but I still haven't found a positive answer. Perhaps using the directions described whould help but I'm a little confused if this is comptable with my processor or not. I'll try installing a freshly formated copy of windows xp onto my other hd to ensure this but until then are any of you able to dig up some information on why it claims to only support Intel processors, i'm currently running an athlon 1700+. If that's not the case care to describe?

    Standard PC-
    Applies to any Standard PC, non-ACPI, or non-MPS. The CPU may be a 386, a 486, a Pentium, a Pentium II, or a Pentium III.

    IRQ Specs-

    Resource Device Status
    IRQ 9 Microsoft ACPI-Compliant System OK
    IRQ 5 NVIDIA nForce PCI System Management OK
    IRQ 21 Standard OpenHCD USB Host Controller OK
    IRQ 21 Realtek AC'97 Audio OK
    IRQ 22 Standard OpenHCD USB Host Controller OK
    IRQ 20 Standard Enhanced PCI to USB Host Controller OK
    IRQ 19 Adaptec AHA-2930CU PCI SCSI Controller OK
    IRQ 16 3Com EtherLink XL 10/100 PCI TX NIC (3C905B-TX) OK
    IRQ 14 NVIDIA NForce 2(tm) SPP/IGP ATA Controller OK
    IRQ 15 NVIDIA NForce 2(tm) SPP/IGP ATA Controller OK
    IRQ 0 System timer OK
    IRQ 8 System CMOS/real time clock OK
    IRQ 13 Numeric data processor OK
    IRQ 6 Standard floppy disk controller OK
    IRQ 4 Communications Port (COM1) OK
    IRQ 3 Communications Port (COM2) OK
    IRQ 12 PS/2 Compatible Mouse OK
    IRQ 1 Standard 101/102-Key or Microsoft Natural PS/2 Keyboard OK
  6. fiveapes

    fiveapes TS Rookie

    Using the button? Is that so terrible?

    I have recently changed my mobo to an Asus K7v, and I encountered IRQ conflicts( xp doesn't say it was a conflict though) with my SBlive 5.1 sound card. It distorted the sound during game play. After I discovered about 6 different things stacked on IRQ 9 I switched to the standard PC HAL. :eek: You all sound like this is the end of the world for xp. After doing this and shuffling my sound and ethernet cards all seems to be well. The only "problem" I have encountered is that the start menu shutdown only shuts down Windows.Is there any solution to this? Aside from updating back to ACPI, which I have done, then switched back. Should I just reinstall as a standard PC? What problems could I encounter if I leave it as is? Is it so terrible to use the off button? Any Insight will be greatly appreciated.
  7. Myth

    Myth TS Rookie

    That's because you disabled power managment
  8. metalbass

    metalbass TS Rookie

    I don't care what everybody else has to say, but Phantasm is da bomb!
    I had the same irq-problem with my MAYA44 MKII soundcard. The sound was terrible! By checking the irq settings of all devices i discovered that all PCI-cards i have installed had the same irq-number: irq 9.
    I followed the steps phantasm recommended and it worked like a charme!
    There's actually one thing i'd like to add to his explanation:
    Once you restarted your machine, the OS starts to re-install all hardware. Let it do just that and everytime it asks you for a driver-cd just point to your system32 directory: it's all there! since you installed all devices before...


    thanks Phantasm!

  9. Mambo.Ver2.0

    Mambo.Ver2.0 TS Rookie

    Hey guys, I was reading thru the thread coz i was having the same problem...my onboard sound AC97 was sharing IRQ 23 with ATA Serial Controller...so all i did was roll back the driver to the standard one and it selected itself a different IRQ so now everything is fine...what i want to knw is where i can get different ATA drivers that wont do what i did in the first place or how to prevent it from happening again.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...