Radeon HD 5870 Crossfired low fps on Dead Space 2?

By Ryan0605
Feb 4, 2011
Post New Reply
  1. My specs. Amd 955 x4, Ati 5870 x2 crossfired, 6 gig ddr3, win 7 64. I am trying to play Dead Space 2 but i am getting low fps, 10-25?? I have installed the latest catalyst drivers but still have no luck. Help!
  2. dividebyzero

    dividebyzero trainee n00b Posts: 4,891   +1,258

    Probably a Crossfire driver issue I would guess. Have you tried playing the game using one card?
    You may need to wait until AMD release a newer version of the CrossfireX application profile for some better compatibility. The present CAP was a 24 Jan release which would indicate that the driver itself is around a month old.

    Single card performance shouldn't give you the same grief. It looks less than graphically demanding judging by this review benchmark out today.
  3. red1776

    red1776 Omnipotent Ruler of the Universe Posts: 5,219   +157

    Don't feel to bad Ryan. I purchased DS2 two days ago and get only 75FPS (1920 x 1080) with 4x5850's OC'ed to above 5870 specs, or more accurately 5870 output. We need a CF update for it.
  4. Ryan0605

    Ryan0605 TS Rookie Topic Starter

    Tried the game with one card and the fps where even less!?!
  5. dividebyzero

    dividebyzero trainee n00b Posts: 4,891   +1,258

    I presume you are using CCC.
    You will probably need to disable AA and AF (Check the "Use application settings" box) in Catalyst if you haven't already, and use the in-game settings for your AA/AF. This may explain the situation a little better if you have MSAA or EDAA checked in Catalyst.
    Some games also prefer that you disable Vsync in Catalyst also.

    Let us know how you get on.
  6. Ryan0605

    Ryan0605 TS Rookie Topic Starter

    Thanx, that did the trick, am getting 80-160 fps now!

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...