What's New:

  • Fix for The Witcher 2: Assassins of Kings Enhanced Edition
    • Added Products:
      • Support for the AMD Radeon R9 295X
    • Features:
      • Ubuntu 12.04.4 support
      • Full support for OpenGL 4.4
      • OpenGL 4.4 supports the following extensions:
        • ARB_buffer_storage
        • ARB_enhanced_layouts
        • ARB_query_buffer_object
        • ARB_clear_texture
        • ARB_texture_mirror_clamp_to_edge
        • ARB_texture_stencil8
        • ARB_vertex_type_10f_11f_11f_rev
        • ARB_multi_bind
        • ARB_bindless_texture
        • ARB_spare_texture
        • ARB_seamless_cubemap_per_texture
        • ARB_indirect_parameters
        • ARB_compute_variable_group_size
        • ARB_shader_draw_parameters
        • ARB_shader_group_vote
    • Resolved Issues:
      • [388835] : Corruption and system hang observed while running Sanctuary BM with Tear Free Desktop enabled
      • [391994] : Memory leak about hardware context
      • [392921] : EGL create context error for glesx
      • [393622] : GPU hand in CrossFire Mode
      • [392271] : [Piglit] Test "spec/arb_vertex_array_object" failed
      • [393283]: Glxtest failures observed in log file
      • [392666] : [Piglit] Test "glx/GLX_EXT_import_context/free context" failed
      • [389496] : [Piglit] Test "spec/ARB_seamless_cube_map" failed
      • [388194] : [Piglit] Test "texture swizzle with border color" failed
      • [391231] : Blank screen observed while running steam games with Big picture
      • [394935] : 4ms delay observed in the glxSwapBuffers when vsync is enabled
      • [375710] : RBDoom3BFG the game auto quit when use the security camera terminal
      • [394504] : ETQW segmentation fault
    • Open Issues:
      • Performance on some Steam OS games is lower on 1GB graphics memory cards, compared with 2GB graphics memory cards
      • Some Piglit tests cause a system hang under Ubuntu

    Supported Products:

    The AMD Catalyst 14.4 Driver for Linux is compatible with the following AMD products.

    AMD Desktop Product Family Compatibility

    • AMD Radeon R9 290 Series
    • AMD Radeon HD 8000 Series
    • AMD Radeon R9 280X Series
    • AMD Radeon HD 7000 Series
    • AMD Radeon R9 270X Series
    • AMD Radeon HD 6000 Series
    • AMD Radeon R7 260X Series
    • ATI Radeon HD 5000 Series
    • AMD Radeon R7 250 Series
    • AMD Radeon R7 240 Series

    AMD All-In-One Desktop Product Family Compatibility

    • AMD Radeon HD 7600A Series
    • AMD Radeon HD 6600A Series
    • AMD Radeon HD 7450A Series
    • AMD Radeon HD 6350A Series

    AMD Embedded Product Family Compatibility

    • AMD Radeon E6760
    • AMD Radeon E6460

    AMD APU Product Family Compatibility

    • AMD Radeon R7 Series
    • AMD Radeon R7 Series
    • AMD Radeon HD 8000D Series
    • AMD Radeon HD 8000G Series
    • AMD Radeon HD 7000D Series
    • AMD Radeon HD 7000G Series
    • AMD Radeon HD 6000D Series
    • AMD Radeon HD 6000G Series

    AMD Mobility Product Family Compatibility

    • AMD Radeon HD 8000M Series
    • AMD Radeon HD 6000M Series
    • AMD Radeon HD 7000M Series
    • ATI Mobility Radeon HD 5000 Series

    Linux Distributions Supported:

    • Red Hat Enterprise Linux Suite 6.4 and 6.5
    • SUSE Linux Enterprise 11 SP3
    • openSUSE 13.1
    • Ubuntu 12.04.3 and 13.10

    System Requirements:

    Before attempting to install the AMD Catalyst Linux graphics driver, the following software must be installed:

    • Xorg/Xserver 7.4 and above (up to 1.15)
    • Linux kernel 2.6 or above (up to 3.13)
    • glibc version 2.2 or 2.3
    • POSIX Shared Memory (/dev/shm) support is required for 3D applications

    Note: If a Linux 2.6.11 or newer kernel was built with CONFIG_AGP enabled, the kernel AGP frontend is required to load the fglrx kernel module. To identify whether your kernel with CONFIG_AGP enabled, look for CONFIG_AGP=y in the kernel config file, or if the 'agpgart' module is loaded

    System Recommendations:

    For optimal performance and ease of use, the following are available:

    • Kernel module build environment
      • Kernel source code include either the Kernel Source or Kernel Headers packages
    • The RPM utility should be installed and configured correctly on your system, if you intend to install via RPM packages

    The following packages must be installed in order for the AMD Catalyst Linux graphics driver to install and work optimally:

    • gimp-help-en
    • gimp-help-common
    • XFree86-Mesa-libGL
    • libstdc++
    • libgcc
    • XFree86-libs
    • fontconfig
    • freetype
    • zlib
    • gcc