2 SATA drives not recognised by Win XP

Status
Not open for further replies.

BBoW

Posts: 25   +0
Hello all,

My old HDD started clicking, so I installed a new HDD and installed a fresh WinXP on it.

My setup has got 3 HDD's. The main one (new one) is a 500 Gb, IDE-connection with 3 partitions and I also have another 2 x 160 Gb, both with 2 partitions, these 2 drives are SATA.

I had both SATA drives disconnected during WinXP installation to prevent any issues of drive designation and installing. After the installation was complete I reconnected them and now I can't see the drives in Windows.

Looking at Device Manager I can see the there are 2 yellow question marks with "RAID Controller" behind them under other devices. The drives do not appear under "Disk Drives". Should I install new drivers for the drives?

I am suprised to have this problem, because I've not had this problem the last time I installed WinXP on my old IDE-HDD (the one that's clicking).

I'm not sure if it's a problem, but under my old setup the 2 drives had a designation of F: , G: , H: and I: . Under my new setup the 3 partitions created are designated C: , F: and G: . Could this be conflicting?

Any ideas,

Many thanks,


Bbow
 

Tmagic650

Posts: 17,233   +234
Quite a mess you got there. 1 500GB IDE, 2 160GB SATA and 7 partitions. You need to activate the partitions on the SATA drives. I wonder if the SATA drives manufacturers installation software will see the SATA drives. Have you run the drive installation software?
 

BBoW

Posts: 25   +0
Hi,

Thanks for the reply.
With regards to the drivers for the HDD's, I clicked on the yellow marked RAID Controller under device manager and selected "Reinstall driver", I put various floppy disks with various RAID drivers and also the CD-ROM that came with the computer (that should have the drivers on it), but everytime it says "no suitable drivers found".

Interesting to note that on the old 'clicking' drive (that also has WinXP on it) it does recognise the drives. So could I perhaps get the drivers of that, or find out which drivers they are? and so install them?

I reckon this must be just a Windows-based problem as the BIOS does recognise the drives.

EDIT: I just realised what I've done wrong! I forgot to load the Scsi drivers during the WinXP installation! Is there a way to reload them, without having to format the drive?

FIXED IT!


It turned out to be the drivers! I had some more drivers on a CD-ROM and installing those has fixed the problem! It turned out to be the VIA SATA drivers, and RAID.

All 7!!! partitions are working fine now!

Many thanks for your help.

Bbow
 

Tmagic650

Posts: 17,233   +234
Good work,
now, what do you use 7 partitions for? do you realize just how much usable disk space you are wasting?
 

BBoW

Posts: 25   +0
I know, 7 is a bit much. I read somewhere it was good to have a drive partitioned so that it works quicker. Not too worried about losing a bit of space.
 

kimsland

Posts: 13,806   +3
Partitions cannot make your drive response quicker
But having 2 HardDrives (on Desktops of course) and then putting the PageFile on the 2nd HardDrive, can
 

Tmagic650

Posts: 17,233   +234
Partitions cannot make your drive response quicker
But having 2 HardDrives (on Desktops of course) and then putting the PageFile on the 2nd HardDrive, can

Can we do that in Vista? Creating RAID arrays can do the speed up too
 

kimsland

Posts: 13,806   +3
Well on a Desktop computer (I have to keep saying that you know!)
Just purchase another internal HardDrive (likely Sata, but you may need to check your specifications from your motherboard manual, or just open it up!)

Then mount it in (you know, screws and power, and data cables)
Then turn on your computer, and allow Windows to start
Then go to computer management in Administrative tools in Control Panel
Format to NTFS

Then change the Pagefile location, here's Vista's settings on that
click the Start button
click Control Panel
click System and Maintenance
click Performance Information and Tools
click Advanced Tools (in the Tasks pane at the left side of the dialog box)
click Adjust the appearance and performance of Windows.

After answering the User Account Control prompt, you’ll arrive at the
Performance Options dialog box. You’re nearly there

click the Advanced tab, and then click Change.

Sorry just noticed XP again
Well it's about the same location !
 
Status
Not open for further replies.