A Serious HDD Problem

By Shrubbery ยท 13 replies
Nov 8, 2009
  1. Hello everyone,

    First of all I'd like to say that there have been similar posts on the net and on this very forum, however I'd like to point out several aspects of my particular problem which make it difficult to solve.

    In a nutshell, my Fujitsu Siemens Amilo Pro notebook simply stopped booting into Windows XP. I turn on the thing, select the desired boot up method, ( Safe mode, normal, etc. ) and soon enough I get the BSoD appear for a fraction of a second, after which the machine restarts and repeats the same irritating routine.

    The general consensus is that it is either a RAM or HDD problem and there are various suggested solutions, none of which apply to me specifically, and here's why.

    I have a dual boot system with Windows XP Professional and Intrepid Ubuntu Linux, and I have no troubles whatsoever booting into Linux. Correct me if I'm wrong, but that should rule out memory. What is annoying, however, is that I cannot access the Windows partitions from Linux either - I just get informed that the volume cannot be mounted. Can the HDD be partially corrupted, so that only the Windows partitions don't work?

    Attempting to repair a partition or to reinstall Windows results in a message stating the following: "setup did not find any hard disk drives installed on your computer."

    What's odd about that is the fact that when I go into the BIOS Setup, by pressing F2 before the menu in which I choose either Linux or Windows, the HDD is recognised. I tried playing with the settings, rearranging the order in which devices should be booted, and the type of drive, (auto, user, atapi #, etc.) all to no avail.

    The fact it's a laptop makes taking the hard drive out and connecting it to another PC somewhat difficult, so I suppose that's ruled out as well.

    There have been suggestions that any extra hardware should be removed before attempting to boot into Windows, however I quite literally don't even have the power cable plugged into the laptop, and the issue persists.

    I'd rather like to avoid losing the data I have there, so I would appreciate any advice on the matter, and should additional information be required I'd be happy to provide it.

    Thanks in advance.
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    If you are able to get to the Advanced menu where Safe Mode etc exists as an option, then Windows has successfully found the drive

    Have a look at running CheckDisk from the Recovery Console. Info HERE
  3. Shrubbery

    Shrubbery TS Rookie Topic Starter

    Thanks for the swift reply, I'll give it a shot and post the results.
  4. Shrubbery

    Shrubbery TS Rookie Topic Starter

    I tried several times, but like I said - Trying to access the recovery console results in the following message:

    "Setup did not find any hard disk drives installed on your computer.

    Make sure that any hard disk drives are powered on and properly connected to your computer, and that any disk-related hardware configuration is correct. This may involve running a manufacturer-supplied diagnostic or setup program.

    Setup cannot continue. To quit Setup, press F3."

    F3 is, naturally, the only option.
  5. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Please go to your Fujitsu support website here>> http://ts.fujitsu.com/support/downloads.html
    Locate your Harddrive controller driver
    Download it (possibly unzip it)
    Burn to disc

    Then when you are starting with your Windows disc, select F6 (when prompted) and point it to the unzipped Harddrive controller drivers
    Continue into the Recovery Console to run CheckDisk
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    kimsland beat me to it! :)

    I concur. Was also going to say sounds like Windows doesn't have the driver to read your hard drive!
  7. Shrubbery

    Shrubbery TS Rookie Topic Starter

    Once again, thanks for the quick reply.

    I gave it a shot, and while the solution you suggested might be valid, it appears I'm going to have to get my hands on a USB Floppy Drive in order to get it done, as a disc will not do.

    I'll try and get one tomorrow as it's past 3 AM here, and I'll report back how it goes.

    Thanks again.
  8. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Also I think its under "chipset" drivers, on your download page
    Anyway, just let us know when you're not so sleepy :zzz: :D
  9. Shrubbery

    Shrubbery TS Rookie Topic Starter

    Hello again, I'm sorry it took me this long to get back to you, but it took me a while to get my hands on an external floppy drive.

    I managed to copy the following files onto a floppy disc (should it prove helpful in solving the issue):


    I downloaded them from under "Chipset Drivers" in the section for my particular ( v3525 Amilo PRO) laptop. The bundle was called "Intel Matrix-Storage-Manager Driver (SATA)". I assume that's the correct bundle?

    Upon starting the laptop and going into the windows setup, after having pressed F6 and going on to press S, to specifically point to the hardware I want installed, I was prompted to select one of four possible choices:

    Intel(R) 82801GR/GH SATA RAID Controller (Desktop ICH7R/DH)
    Intel(R) 82801GR/GH SATA AHCI Controller (Desktop ICH7R/DH)
    Intel(R) 82801GBM SATA AHCI Controller (Mobile ICH7M)
    Intel(R) 82801FR SATA RAID Controller (Desktop ICH6R)

    I went on to install the 2 RAID options, as well as the 1st AHCI one, none of which did anything to help resolve my issue. It is even possible I made a blunder by installing the bottom one as the next time I ran setup, it actually asked me what kind of computer it's being run on. However, selecting the only available option other than "other" resolved the possible problem without a glitch. Before I cause any additional damage though, I'd rather ask for help.

    Bottom line, am I doing anything wrong, or is this method simply not going to work for me?

    Thanks in advance for any feedback you might provide.
  10. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Everything looks right
    Obviously you needed to select this one on your Mobile, not Desktop, computer:
    Intel(R) 82801GBM SATA AHCI Controller (Mobile ICH7M)

    So what was the result?
    Note: You may need to start clean install once you recover your data (this being the only issue I feel)
    A clean install means to remove the XP partition during the initial Windows Setup (you know that "L" prompt, or whatever the sequence is)
    Once the Partition is removed (obviously this is only after you have got all your data saved)
    Then continue Windows Setup (Windows will automatically, create an NTFS partition and format)
  11. Shrubbery

    Shrubbery TS Rookie Topic Starter

    Cheers again, it did allow me to run the Recovery Console and chdsk is running as I type this.

    Hopefully it will resolve the issue, even though I find it odd that my data partition should suffer from this and be inaccessible from Linux as well, as there's no OS installed there.

    Anyway, I'll post as soon as it's done and I see if it's helped.
  12. Shrubbery

    Shrubbery TS Rookie Topic Starter

    Right, chkdsk finished and reported that it did, indeed, find and fix some errors.
    Alas, the issue persists. Linux still won't access them either.

    Perhaps it's of some use to mention that when trying to boot into Safe Mode, the last file it loads is MUP.sys, and it prompts me to cancel loading SPTD.sys, before it flashes the BSoD and restarts.

    Also, should you be familiar with Linux, is there perhaps a way of fixing this from within that OS? It does offer to force its way into the partitions, but warns of possible damage it could do.

    The error message it shows is: "Internal error: No mount object for mounted volume"

    Once again, thanks in advance for any further assistance.


    Okay, I feel like a complete retard now.

    I went browsing on some Ubuntu forums and found the solution. While Linux won't access them by double clicking the partitions, it allows me to do so, without any further glitch or warning, by right clicking and selecting the appropriate option from the dropdown menu. -___________________________-

    It appears to be a common issue among Ubuntu Intrepid users, and, to make things worse, it's completely unrelated to my problem and only happened to occur in such an inopportune time.

    I'm going to back up all my data now. However, if you want and so as not to have wasted anyone's time, I'm willing to give it a few more shots purely so that the issue does not remain unresolved, in case someone else might run into a similar problem and not be as lucky as I was.
  13. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Oh wow that's pretty good
    It makes me feel better that you were able to find out how to do all this and now willing to go further in resolving the fault

    But ;) There are already enough User faults out there to deal with and learn from
    With similar or any wide and varied difference.
    Therefore if you have successfully backed up your data, then please continue below to the exact guide on a clean install:

    Microsoft's Windows XP Professional Repair Install step by step (* Including Delete Partition)
    http://www.windowsxpprofessional.windowsreinstall.com/sp2sp3installxpcdoldhdd/indexfullpage.htm (This page has large easy to see pics)
    * Warning deleting the Partition will remove all User data and Windows system files
  14. Shrubbery

    Shrubbery TS Rookie Topic Starter

    Cheers, and thanks for all the help! :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...